TITLE:
Java Plugin and Web Start Version Specification Security Issue

SECUNIA ADVISORY ID:
SA21570

VERIFY ADVISORY:
http://secunia.com/advisories/21570/

CRITICAL:
Less critical

IMPACT:
Security Bypass

WHERE:
From remote

SOFTWARE:
Sun Java JRE 1.5.x / 5.x
http://secunia.com/product/4228/
Sun Java JRE 1.4.x
http://secunia.com/product/784/
Sun Java JRE 1.3.x
http://secunia.com/product/87/
Sun Java JDK 1.5.x
http://secunia.com/product/4621/
Java Web Start 1.x
http://secunia.com/product/1005/

DESCRIPTION:
A security issue has been reported in Sun Java Plugin and Sun Java
Web Start, which can be exploited by malicious people to bypass
certain security restrictions.

The security issue is caused by an error that allows applets and
applications to run with a version of the JRE that it is not
specified to run with (e.g. that does not have the latest security
fixes).

The security issue affects:
* Java Plug-in included with J2SE 5.0 Update 5 and earlier, 1.4.x,
1.3.1, and 1.3.0_02 and later.
* Java Web Start included with J2SE 5.0 Update 5 and earlier, and
1.4.2.
* Java Web Start 1.2, 1.0.2, 1.0.1, and 1.0.

SOLUTION:
Updated to a fixed version.

-- Java Plug-in --

Windows:
Update to Java Plug-in 5.0 Update 6 or later.

Linux/Solaris:
The vendor recommends using the latest JRE releases and to remove all
symbolic links to earlier versions of Java Plug-in from the browser
"plugins" directory.

-- Java Web Start --

Update to Web Start 5.0 Update 6 or later.

PROVIDED AND/OR DISCOVERED BY:
Reported by the vendor.

ORIGINAL ADVISORY:
http://sunsolve.sun.com/search/document.do?assetkey=1-26-102557-1