Resolved Question

Vizio TV disconnection error while plugged into ethernet?

I have a Vizio 55" D Series Smart TV purchased in 2014. I've used wifi connection through a Nighthawk router 2.4Ghz band and most recently a 1GB up/down FiOS router 2.4Gz band (for the last 7 months) for internet the entire time I've owned it without an issue. The TV is 6ft away from the current FiOS router.

In the last few days while connected via wifi, a "Network Disconnected" error screen has started randomly popping up every 30-45 minutes when NOT using an app, but just watching TV through the cable box. When it appears, the "Network Setup" button is highlighted but is not selectable. Only "Close App" is selectable. The idea that "Close App" is an option when no app was opened is the confusing part. I had changed no settings or connected any new input devices up to this point.

So at first I:
- Rebooted the router
- Reset the TV to factory defaults
- Turned "off" DHCP
- Turned back "on" DHCP

None of that worked, so I just decided to hard wire through ethernet, thinking that would take care of it. It did not.

So I reset the factory defaults one more time while the ethernet cable is plugged in just incase the wifi settings were still interfering somehow. The error message still showed up.

With the wired connection I'm getting about the same connection speed through the TV as when it was using wifi, 10-45mbps.

It appears that this only happens while on the FiOS cable box input with no apps open. If a Vizio App or my Roku input are being used there's no issues, I'm not getting any dropped connections during use, only when apps are not being used.

I'm at a loss. Logically, none of this makes any sense.

Discussion is locked

downincircles has chosen the best answer to their question. View answer
Answer
Follow
Reply to: Vizio TV disconnection error while plugged into ethernet?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Vizio TV disconnection error while plugged into ethernet?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments

Best Answer

- Collapse -
It’s a Vizio bug
- Collapse -
Answer
A few things to try.

1. Be sure the TV's firmware is up to date.
2. Be sure the time and date is set on both router and TV.

If it continues to fail, report it to the TV maker as they won't fix what folk don't report.

- Collapse -
Same

Same thing is happening to my tv. Not sure how to fix it. The issue just started

- Collapse -
Since you tried what I wrote

I take it the maker is not offering to fix it. In your case the cheap fix is to ignore the smart TV feature and use the Roku or Fire TV sticks to provide the usual Netflix, etc.

- Collapse -
Close but no cigar

So since the tv can connect to the internet it likely has the latest firmware. Vizio doesn’t even let you know which version to look for, their support page just days it updates automatically while the tv is off and connected.

Also this issue doesn’t happen during app usage. It happens during regular hdmi cable usage when no app is in use, but then throws the app connection error.

I wouldn’t be surprised if it’s a new firmware update that’s causing it. Right now it’s the only explanation.

- Collapse -
Let's say it's a firmware issue.

Only Visio can cure that. I forgot a thing. Try the 8.8.8.8 DNS, How is all over the net.

- Collapse -
Yep it’s Firmware and they’re aware
- Collapse -
Answer
Experiencing the same problem

I am experiencing the exact same problem on a hard wired connection testing 200mb/200mb. As others, the same message pops up while using an HDMI connection (typically connected to an NVIDIA Shield).

This is the first problem I have ever experienced with this TV.

I did try try the suggested alternate DNS settings 8.8.8.8.

Seems to have fixed the problem for 45 minutes now. I am sure I will submit this comment and it will immediately the error.

Thanks for the original submission for this problem.

- Collapse -
Resolved?

It’s possible they fixed the problem on their end. I had the same issue so I reset my tv and skipped internet setup as they said it would stop the message but ultimately wouldn’t get a firmware update once they fixed it. Connected back up 2 weeks later (earlier this week) and haven’t had the message since.

CNET Forums

Forum Info