Windows Vista forum

General discussion

Vista won't let me remove programs!

I am running Vista home premium (which I hate). I go to the uninstall programs area in the control panel. When I attempt to remove a program I get the message, "you do not have sufficient access to uninstall.... Please contact your system administrator." Guess what. I AM THE SYSTEM ADMINISTRATOR and I would not know how to deny access to someone other than set them up as a "regular" user. Yes, I am logged in as the administrator. Please help!!!!

Discussion is locked
You are posting a reply to: Vista won't let me remove programs!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Vista won't let me remove programs!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Try...

In reply to: Vista won't let me remove programs!

The program's own uninstaller, if any, found at the program's folder, or its shortcut folder at the start menu... or

Reinstall it again whereby the previous installation will be ovr-ridden. The uninstall to [via control panel-add or remoe programs... else find out about 'CCleaner' and use that to remove unneeded programs.

Collapse -
edit permission settings

In reply to: Vista won't let me remove programs!

You can do this by right-clicking the program you wish to remove; scroll down to 'Properties', click on the Security tag.
Click on your name, then click 'edit-to change the permission setting'.Once in the Edit section; again click on your name, check the box 'Full Control', apply, okay.
This should give you Admin rights to remove said program

Collapse -
I've changed all the setting and still cannot remove Skype.

In reply to: edit permission settings

Though I've changed all settings to allow me permission to uninstall, I still can't uninstall Skype. It insists I contact the administrator. I am the administrator! It is eating up resources and really slowing my system down.
Any other suggestions?

Collapse -
The Old Blow It Away or "manual uninstall."

In reply to: I've changed all the setting and still cannot remove Skype.

If uninstalls fail I could always boot up some UBUNTU LIVE CD and delete the Skype folder then boot back into windows to correct what errors that created.

Shotgun!
Bob

Collapse -
same problem here

In reply to: I've changed all the setting and still cannot remove Skype.

security setting didn't help me either

Collapse -
Run as Administrator

In reply to: Vista won't let me remove programs!

When trying to uninstall, is there an option to "Run as Administrator"? If there is, click it and enter your admin password.

You can also try uninstalling the program while Windows is running in Safe mode. To find more information on safe mode, search the help menu for "safe mode".

Cheers,
Cassandra

Collapse -
administrator

In reply to: Run as Administrator

Um, as I said, I am logged in as the administrator. In addition, if I right click, there is no option to "run as administrator."

Collapse -
won't hurt at this point to

In reply to: administrator

give my earlier suggestion a try

Collapse -
Thanks!

In reply to: Run as Administrator

This worked on google earth which I was having trouble uninstalling. I had to go into the program folder, right click on uninstall google earth and then "run as administrator." (I had been trying to uninstall it from the control panel.)

However, Skype and some of the other programs I want to get rid of don't have the "unistall" icon in the program folder.

Collapse -
UAC is blocking unistall

In reply to: Vista won't let me remove programs!

Turn off User Account Control (Type UAC in search), reboot and uninstall with administrator privileges. Right click program and check that your user name has administrator privileges. That should do it for you.

Collapse -
Uninstall Adobe Reader

In reply to: Vista won't let me remove programs!

Hi,had a "MESH"comp since end sept,new motherboard and corrupt Vista within 5 weeks,came back Vista not installed properly.Cant update Adobe as i tried several times diff ways keeps coming up ERROR 1606 could not access network location %APPDATA%\.Mesh wont help,spent over

Collapse -
MESH computers

In reply to: Uninstall Adobe Reader

Collapse -
Adobe Reader

In reply to: Uninstall Adobe Reader

Hi,i have reinstalled Win Vista 2 weeks ago,it was only way to use Reader 9,Skype and other programs.If anything goes wrong seek help from someone you know (or try yourself as i have learnt alot) not TECHNERDS as they dont tell you the whole story.They were useless and i got more done by myself.

Collapse -
That's a FINE SOLUTION.

In reply to: Adobe Reader

In fact my brother returned a laptop I loaned him and what a mess. It had been hit with Antivirus 2009 (a malware!) and he had used registry cleaners and what else.

Armed with many moderators advice here I looked at it, ran the usual and it was still a mess. Since there were no files to save I booted the restore media and in the next hour it was back to it's pristine fine self.
Bob

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

GIVEAWAY

Enter to win* a free holiday tech gift!

CNET's giving five lucky winners the gift of their choice valued up to $250!