General discussion

Vista - Will not load printer among...........

Vista Sucks!! Now that I have that out of the way??.

I upgraded from XP Pro to Vista Ult. and can no longer use my Lexmark X7170. Check this: Installed new drivers from Lexmark. WILL NOT COMMUNICATE. (In 20+ years of IT, I have never had a printer defeat me until now!!)

Printer works on other PC's. A loaner Epson works. Both are USB.

Uninstalled/rebooted/re-installed. Same. Uninstalled. Cleared all files. Cleared registry. Rebooted. Re-installed. Same. 19 tries....

Tired out Lexmark support. Tired out Microsoft support.

Any genius want to try?

++ Yeah, when I am employed again, I will get a new PC with Win 7, but that could be awhile. Real help would be appreciated. ++

And the WPD driver just loaded for the 48th time. Does that with almost every reboot. Any way to stop that?

Discussion is locked
Follow
Reply to: Vista - Will not load printer among...........
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Vista - Will not load printer among...........
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Lexmark printer....

A question: when switched on, does the power light of the printer blinks ? Anyway, try:

1. To install the printer, click on the drivers .exe....the installer will ask you to connect the printer and switch it on... then follow on screen insructions [this is quite different from others where I first install the drivers, then plug in the device for it to be detected by Windows, whereby it installs itself.

2. Install the printer manually [Windows 9x method]. Connect the printer and switch on....Windows will detect the new hardware and try to install it....then ask you for the CD....or a location where the drivers are. Choose thee location, i.e. point to the CD drive or the folder where you have saved the downloaded drivrrs...

3. Use the add hardware wizard at Control Panel...


[ In all the above cases, uninstall previous attempted installations, and reboot before tring to install again]

- Collapse -
Tried all of those. No go.

I did find deep in system32 a few Lexmark files. Even as ADMIN, I could not remove. I could not chnage ownership or permissions in order to remove. Strange. Part of problem? Don't know.

- Collapse -
Try - go to control panel....

...Printers folder. Open that. Do you see the Lexmark as the defauult printer ? The next time the printer does not work...click at the printer icon at the notification area [Tray] and see whether 'stop printing' has been checked.

Also, try a different USB port, and disconnect other USB devices.

Make sure that you have the printer's drivers specifically for Vista from Lexmark.

If still not succesful go to System Information [Start>Accessories>System Tools.... and see whether you have "problem devices" or "conflicts" ....

- Collapse -
Tried That......

P.E.:

I have been in the business for 20+ years. I am well beyond the obvious. This printer worked on XP, works on PC's other than Vista, and does not work on any USB port. However, an Epson printer works well on this PC (VISTA ULT.) on any USB port.

No conflict.

11 EM tries by Lexmark before they gave up. 4 by Microsoft before they quit. It has me buffalo'd.

- Collapse -
The not so obvious...

From the information provided, it seems that the fault is at the computer...some settings gone, maybe.... Try creating a new user account with Administrator privileges... and install the Lexmark there. If successful, you may have to "take ownership" of copies of your files before you can print from the new accounnt.

If the printer still does not work, how about running "Startup Repair" ? That may replace some bad files....

- Collapse -
Vista-Ptr-PROB

P.E.,

Thanks for hanging with me. Another view is appreciated. There were some obscure files in Sys32 that would not delete until I backed up to change permissions at the sys32 folder on down. Finally got Lex files deleted. There are two entries in the registry, however, that I cannot delete - even running as administrator. If these changes do not work, I will try a repair like you suggested.

Having come originally from the UNIX world, I resent not being able to remove anything that I think needs to be gone. $@#$%@%$$@^&*^^%$!%

Already tried as another user with admin. Nope. I agree. PC/Vista problem.

Will try one more install........

- Collapse -
Even in UNIX

I need to not only be root but have permissions to remove a file.

What I find is many don't want to learn the OS they moved to and complain bitterly about deleting a file. We have tools like FILE ASSASSIN and my fav, the UBUNTU LIVE CD.
Bob

- Collapse -
Files Deleted

Bob,

Changed permissions. Deleted files. Reboot. Total fresh install of Lex X7170 using Lexmark's "Vista" drivers. Nada.

It is not going to happen. That printer is not going to install. Vista and Lexmark do not like each other and I may take another guy's advice and just can Lexmark.

- Collapse -
Isn't this from 2004? And...
http://www.lexmark.com/US/x7170/specs-tech.html does not list Vista. Sorry but sometimes we have to get medieval on these things.

See if Linux supports it and cheat like we did years ago. We would have a print server that would accept PDF files in an INCOMING directory and it would print one copy of that.

Worked for years until the IT staff couldn't do the penguin dance.
Bob
- Collapse -
Printer works on other PCs....

....I presume with the Vista OS ?. You mentioned that new drivers from Lexmark were installed...those should be drivers for Vista...and Lexmark support have not mentioned about your model being not compatible with Vista ?
Do you actually get the printer's icon at the Printers folder at Control Panel ? If so, create a shortcut to the Desktop...see if you can right click and go into compitable mode for....XP . I have seen a Lexmark Z640 working on Vista SP1.

Also try a USB cable...one which you know works...or connect via a USB hub ?

If all things fail, then blame it on the Upgrade [XP to Vista] disk....or maybe your XP OS was not clean enough for the upgrade...so things were mesed up[e.g. some Windows drivers required for Lexmark were corrupted]. Again,was the printer's power on light blinking ? [it may be a clue]...

CNET Forums

Forum Info