Set the video mode to 800x600, 60 Hz and then OK your way out, reboot and see if it's just you setting the video mode too far out.