Basically, it is probably b/c you are using Microsoft Word as your Outlook editor. Unfortunately, according to the microsoft website, it is something you cannot turn off. Follow this link from Microsoft, and it should tell you more about it.

My suggestion is: if it is so annoying, just switch to outlook editor instead.
Hope this helps!
Have a great day! :o)