General discussion

Virus blocking antivirus software and websites?

I had my laptop wiped and I cant seem to download any anti virus software. I can not gain access to anti virus websites and if I download through the installations stop because they "cannot connect to server" am I right to assume its a virus causing this?

All websites other than anti virus sites work fine. Im running windows xp. Thanks

Discussion is locked
Reply to: Virus blocking antivirus software and websites?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Virus blocking antivirus software and websites?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
Virus/Malware can prevent you in visiting security websites

It can also hijack your hosts file.

I suggest to review your hosts file if any antivirus website is blocked or just reset it. Download the file at to reset the hosts file.

Example of host file: sample domain name here or sample website name here.

If the hosts file is not hijacked or modified, you might want to use another download site to see if it'll work. Example:,

If you can't get the antivirus software to download, I suggest to use another clean PC in downloading the scanner and removal tools below:


a-squared Emergency USB Stick from
Save it in your desktop or USB stick then extract the content to the USB stick (in the root directory of your USB stick, not in any folder). Proceed by running a2Free.exe from the USB stick
More info

Malwarebytes Antimalware (MBAM)
You can also download it from

- Collapse -

Thanks for all the advice downloading through file hippo worked =D

- Collapse -
You're welcome! I hope there's no malware after

your first scan using the scanner that you've downloaded from

- Collapse -
NON of this works on PCs with foreign Languages.

There must be some kind of problem with the language interface that prevents all of the above mentioned applications from working.

I been sitting here for the last 5 hours reading through tech frum after tech forum and have downloaded everything from ComboFix to Malwarebytes, superatiSPYware, to tdskiller to mbam to regbooster to SDFIX.... NOTHING WORKS. EVen tried the the old ipconfig /flushdns

NON of this works!

SO my basic question is..... what on GOD green earth on this PC could be stopping me from browsing to, avg, trend micro, malwareorg, etc.

There has to be something on THIS pc thats stopping me from seeing these sites.
There has to be a way to force this PC to go to these websites.

Where exactly s the problem? What exactly did the Trojan change on this PC. If I knew that I wouldn't need to download a billion pieces of software. I could go directly to the threat and take care of it.

Is there anyone out there who knows exactly what to do besides downloading 3rd party apps?

Is it a registry problem.. ts obviously not the host file!! Been there done that!
What is blocking these websites? Got to be something here.. HELP!!

- Collapse -
Did You Try Rkill?

If not, you can read about it here.

Did you try ALL Donna suggested? To include using another PC to download the tools?

If you haven't tried Rkill and need further help, please let us know.

Best of luck..

- Collapse -
If none of the above links work ...

but it seems you can actually access the Internet then it might well be your firewall configuration blocking the sites and updates.

Although possibly but not too likely an LSP problem (often associated with malware removal) you might also try LSPFIX

Before trying that you might get it fixed by resetting the LSP catalog by opening a command prompt and typing in (or copying and pasting) the following bolded text:
netsh winsock reset catalog

CNET Forums