Computer Help forum

General discussion

VBScript disabled or not Installed...

by CrazyRoundMan / December 23, 2006 8:23 AM PST

Been having problems with my computer lately, and I think I may have finally hammered down the problem, though I'll be honest when I say I have no idea how to fix it.

After some effort, a restore, and a few other things I have myself running at about 90% of what I should be, but a few programs refuse to work, and I regularly have problems installing new programs.

I recently got this message, which may explain a lot:

"<program name> could not be installed because Visual Basic Script (VBScript) is not installed or has been disabled. Make sure VBScript is installed, turn off script blocking in anti-virus and personal firewall software, re-register VBScript, and install the program."

I've been looking around.. but I can't for the life of me figure out *where* to re-enable VBScript or more importantly, reinstall it. I'm fairly sure I have no script blocking software, so I'd really like to reinstall VBScript... anybody got any ideas?

Discussion is locked
You are posting a reply to: VBScript disabled or not Installed...
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: VBScript disabled or not Installed...
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
A Few Things To Do..
by Grif Thomas Forum moderator / December 24, 2006 5:05 AM PST

First, it would sure help if you gave us more information about your computer, specifically the operating system...

Second, start by installing the newest Windows Script Engine from the appropriate link below:

Windows Script 5.6 for Windows 98, Windows Millennium Edition, and Windows NT 4.0

Windows Script 5.6 for Windows XP and Windows 2000

Next, if that doesn't help, then please download and install the Visual Basic 6 SP6 runtime files from the link below:

http://www.microsoft.com/downloads/details.aspx?familyid=7B9BA261-7A9C-43E7-9117-F673077FFB3C&displaylang=en

You may also need Java, but please try the above steps first and let us know how it goes.

You may also have a problem with spyware which is causing the issues.. Have you scanned your computer with antispwyare tools and if so, which ones?

Hope this helps and let us know more.

Grif

Collapse -
A Few Things To Do..
by Bob__B / December 24, 2006 6:16 AM PST
In reply to: A Few Things To Do..

First my apologies to the poster for hi-jacking the thread.

Does 'windows script' have anything to do with 'windows scripting host'?

Answer>>>yes>no>maybe?

W98..I uninstalled WSH...I was not sure what to expect so I tested the browser..IE6...with a site that used vbscript...no problems.

What the heck is WSH for?
Is this a product that allows ME to write scripts?

Collapse -
Windows Scripting Host...
by Grif Thomas Forum moderator / December 26, 2006 8:35 AM PST
In reply to: A Few Things To Do..

...was first installed in Windows 98 and afterwards became available for all the following Windows operating systems.. In laymans terms, it users to automate tasks in Windows by providing access to the Windows shell, file system, registry, and more. "Writing" script can be done with text files created from notepad. There are lots of links in Google where you can read about it.

The Wikipedia link below provides a fairly inclusive answer:

http://en.wikipedia.org/wiki/Windows_Script_Host

Although you may have uninstalled the most recent version of the WSH,(5.6), I'm guessing the machine simply reverted back to an older version.. That's why it may have worked correctly with the vbs script you tested. If you had correctly disabled or removed the "Wscript.exe" file, you should have seen a "Program Not Found" message.

Hope this helps.

Grif

Collapse -
Thanks.
by Bob__B / December 26, 2006 11:20 PM PST

I think I see where my confusion came from.

The test site I used does not send a vbs file.

It looks at my browser..IE.. and says yes that's vbs capable.

Collapse -
Visual Basic Script (VBScript) is not installed
by Ronses / May 30, 2007 7:24 AM PDT

This seems to be the fix

Register the module vbscript.dll from an elevated Command Prompt window. To open an elevated Command Prompt, click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.

Type the following in the Command Prompt window and press ENTER

regsvr32 %systemroot%\system32\vbscript.dll

And then type the following to exit the Command Prompt window.

EXIT

Collapse -
it worked
by kavinimpact / June 2, 2007 12:10 PM PDT

thanks that did work.

Collapse -
VBScript is not installed or disabled
by ttorri35 / June 23, 2007 1:07 AM PDT

I have gateway notebook with windows vista operating system and I am trying to download Itunes and I keep getting the message about the VBScript not being installed or disabled or script blocking my on and I need to turn it off. I have no clue what I am doing. Please help with this. Thanks.

Collapse -
it worked
by ernest mattio / June 25, 2007 11:05 PM PDT

Thanks that worked really fast!

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?