Question

Using USB stick to communicate between Windows 10 and Mac or

After an upgrade from Win 7 to Win 10, my Vaio all-in-one PC will read the directory of a FAT32 formatted USB stick, but when any attempt to access any file (to open, copy, modify etc) I get the "File Access Denied" error "You'll need to provide administrator permission to copy this file". I AM the administrator and have tried all the methods of Taking Ownership and trying to modify the Security on the files. None works, as FAT32 files don't have security!! The stick works perfectly on another Win 7 machine, a Mac and used to work on this PC. Anyone have a solution?

Discussion is locked

Follow
Reply to: Using USB stick to communicate between Windows 10 and Mac or
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Using USB stick to communicate between Windows 10 and Mac or
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Check the properties of the file.

Right click on the file - Properties - Security. The check boxes will show Full Control, Modify, read & execute, read, write and special permissions. The files could be set to read only.

- Collapse -
No Security Tab

Fat32 files do not have the Security tab, so all attempts to modify the security do not work. That was the cause of the problem, which I have yet to find a way round.

- Collapse -
Answer
Let me be clear that I have yet to see this message.

But I have a clean W10 to play with. Some antivirus has a "File System Shield" that can cause this. But here we don't know what you have besides w10.

- Collapse -
Spec:

Win 10 upgraded from Win 7. AVGfree antivirus. I have tried disabling the antivirus. It has no effect. The USB stick was formatted on the same machine under windows 7 some time ago. I have swept the machine for virus and malware - none.
I found that (on another usb stick with similar problems) that if I used the command "convert X: /FS:NTFS" the filing system was changed to NTFS without loss of data, and the problem disappeared. This is not a solution to the problem, however, as Macs can't read NTFS and the stick is used to communicate data between a mac and the PC, amongst other things.
Anyway I shouldn't have to jump through hoops to get a USB stick to work on a simple "upgrade" (or is it a downgrade?) from one MS operating system to its free successor!!!

- Collapse -
Woah. Apple Macs here read NTFS

Now I wonder what's up with your Apple Macs!

Something is different about your setup. I can't see it from the clues here but 10, USB sticks and Apples are fine at the office.

- Collapse -
Mac & NTFS

Macs can read NTFS but not write to it without even more software and fiddling about, so transferring data from mac to PC is a problem.

- Collapse -
It's not a problem here.

Something's up but the clues here are missing. Did you try formatting the stick on the Apple? Here's a note how.

Read https://discussions.apple.com/thread/4805253?start=0&tstart=0 and look for the word DOS to see a note about making it compatible.

Works here. I wish I was there to give your PC an once over but I'm not.

CNET Forums

Forum Info