Windows Vista forum

General discussion


by paultogo1 / July 24, 2009 3:51 PM PDT

I obtain an error message when trying to update some software and so terminates. States that it can not expand or find %APPDATA%

Discussion is locked
You are posting a reply to: userappdata
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: userappdata
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
(NT) What software is this?
by John.Wilkinson / July 24, 2009 4:47 PM PDT
In reply to: userappdata
Collapse -
Similar problem
by veedubdubh / July 26, 2009 8:20 PM PDT
In reply to: userappdata

Interesting I also have just come across this problem.

Some more details - Vista Home Premium SP2(recent update) and updating Iobit Smart Defragment.

Internal error - unable to expand user appdata

Any help anyone can give would be appreciated.

Collapse -
This sounds like an old issue reborn in Vista.
by R. Proffitt Forum moderator / July 26, 2009 10:15 PM PDT
In reply to: userappdata

First, read but don't do what notes.

If you don't use the command line then stop here.

Ok, we should test this by opening a CMD prompt and typing

The environment variable must expand to the path to your Application Data folder. If not, tell what happened.

Another cause is UAC. I often find I need to turn that off for some updates. No, I do not write what UAC is. This is only a little advanced and can be researched if you need that information.

Collapse -
by paultogo1 / July 27, 2009 12:15 PM PDT

Did at CMD, result>C:\users\STD\AppData\Roaming not defined

Collapse -
Try again?
by R. Proffitt Forum moderator / July 27, 2009 12:40 PM PDT
In reply to: %APPDATA%

Sorry but you ran all the output on one line so I didn't get a clear view of what happened. But you are onto the cause. It looks like the same old thing.

Collapse -
SOLVED - unable to expand user shell data
by veedubdubh / August 2, 2009 8:52 PM PDT
In reply to: Try again?

Hi there,

I have solved this problem.

R. Proffit is correct the error message (in english!) means that when the application tries to install it is unable to get to the proper place to install itself due to an incorrect registry entry.

The registry entry in question is the "rule-book" tell in the application where to go to install itself so if the rule gets damaged the application cannot install.

I changed the offenging registry back to the correct value and it fixed the problem.

The question I have now, however, is how did the registry get changed in the first place - have run Spybot, Ad-Aware, Malware and run McAfee up to date as a subscriber all the time. I got one alert a while back that a trojan had been intercepted on a webpage - maybe that?

Also where could I go to get an idea of what totally clean and "uncorrupted" registry entries look like.

I still ahve a weird looking reg entry in user shell folders.

Any and all help is greatly appreciated.


Collapse -
I'll try but
by R. Proffitt Forum moderator / August 3, 2009 6:18 AM PDT

What key do you want me to export for a looksee?

Collapse -
Same problem, need help
by momroxs / August 7, 2009 3:21 PM PDT

I am having the same problem that you described. But I do not have as much computer knowledge as both of you.....can you please explain how I get the registry back to allow the installation of SpyBot. I'm also needing to update the anti-spy/security software the end of this month, and need to fix the registry so that installs!
any step by step instructions on how to get the userappdata registry back up and running would be very appreciated.....

Collapse -
If you follow the forums.
by R. Proffitt Forum moderator / August 7, 2009 8:31 PM PDT
Collapse -
by paultogo1 / August 8, 2009 2:24 PM PDT

Tried your URL to download Malwarebytes, but failed with the same error message.

Collapse -
Not to repeat the above posts.
by R. Proffitt Forum moderator / August 8, 2009 10:32 PM PDT
In reply to: %APPDATA%

But Malwarebytes is fine on Vista. I noted the old new (new old?) problem but the original poster ran the output together so I never got a good picture of what's up. They also seem to have skipped over some items linked about how this works.

I'll leave it to you to re-review how this path works. I know some don't want to learn the command line but even on Apples I find we get to drop to the command line at times.

Collapse -
by paultogo1 / August 9, 2009 9:40 AM PDT

I am not an IT person so I donot know how to make the computer do things in more than one line. From Vista, the following is a copy of the command line:
c:\set %APPDATA%
Environment variable C:\users\STD\AppData\Roaming not defined

If possible, please advise on what this means and how to fix it.

Collapse -
That's a bug in their software.
by R. Proffitt Forum moderator / August 9, 2009 9:44 PM PDT
In reply to: %APPDATA%

For example read and other software maker's notes and you see where they are fixing bugs in their software.

"Bug fixed:
# If the environment variable $APPDATA$ is not defined, NDepend reports properly this problem that prevent from installing the VisualStudio AddIn.
# If the environment variable $APPDATA$ references a network drive, NDepend can now install the VisualStudio AddIn.
# If the environment variable $APPDATA$ references a network drive or is not defined, VisualNDepend doesn't raise an exception at startup time. "

There is nothing for us to fix here. Ask the software maker to correct their software. You could try to set the variable but that's not the right fix.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Meet the drop-resistant Moto Z2 Force

The Moto Z2 Force is really thin, with a fast processor and great battery life. It can survive drops without shattering.