First, if you haven't already, try switching the ethernet cable on the affected computer. (We recently had a similar issue with the cause being a bad RJ-45 plug on one end of the CAT5 line.

Or... have you tried updating the ethernet driver on the problem machine??

Next, on the affected computer, it may be an ethernet device issue. I'd try making sure it's still set to full duplex.. In Device Manager, click on the + sign next to the "Network Adapaters" listing, then RIGHT click on the specific ethernet device, choose 'Properties', then click on the "Advanced" tab. Depending on your setup, choose the "Link Speed & Duplex" listing and make sure it says "Auto Detect" or you might even try setting it manually to "100 Mbps\Full duplex".

Hope this helps.

Grif