PC Hardware forum

General discussion

USB2 letting me down

by malbow / April 21, 2004 6:02 AM PDT

Hello there, 21st April 2004
I have been trying to install a ?Freecom CLASSIC CD-ROM/CD-RW? but according to my computers System Information there is a problem with the USB 2 port. The message is:- This device has a problem Code=28 [0x1C].
I have been using this hardware for a couple of months without any problems. But then I got a virus. My Windows 98SE was re-formatted which cleared the virus but the CD-ROM/CD-RW will not re-install. I inserted the Floppy in the ?A? drive slot as per the instructions but nothing at all happened.
The computer is a CentaurHauls x86 Family6 model 7 stepping 1.
56.0MB RAM.
Unfortunately I?m not experienced with computers or computer jargon and am hoping that someone can help solve this problem.
Yours

Mal.

Discussion is locked
You are posting a reply to: USB2 letting me down
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: USB2 letting me down
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re:USB2 letting me down
by Coryphaeus / April 21, 2004 11:54 AM PDT
In reply to: USB2 letting me down

W98SE doesn't support USB-2. Have you installed the USB-2 drivers?

Collapse -
Re:USB2 letting me down
by Elmer / April 21, 2004 9:58 PM PDT
In reply to: USB2 letting me down

is the cd-rom internal? or is it external and connected to the USB2 port?
is this usb port built in or in expansion pci?
code 28 usually refers to unknown device in pci or scsi bus. You can check through device manager for any devices which has problem ( normally with exclamation mark.

Collapse -
Re:USB2 letting me down
by Bob__B / April 21, 2004 11:09 PM PDT
In reply to: USB2 letting me down

This device was working.

Someone formatted the hd and installed windows.

Did this someone install the mobo drivers?

Did this device come with install media, if so has it been used?

I am not a usb user but I suspect windows may need a little help with handling such a device.

Collapse -
Re:USB2 letting me down
by chuckieu / April 23, 2004 3:47 AM PDT
In reply to: USB2 letting me down

The problem is very probably that with the re-format, the
USB 2.0 drivers were not installed. These are different
than the USB 1.1 ones that automatically load from the
Windows disc. Mine are on the Motherboard disc. You are
going to have to look for them. What kind of discs were you supplied with? Happy to give you places to look, but we more info. chuck

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?