Question

USB Thumb Drive Problem - Code 38 in Win 7 Pro

I have been trying to solve a problem with my USB thumb drive. In Win 7 pro, I am unable to see any USB thumb drives in My Computer or Disk Manager. My USB mouse works fine. In Device Manager, I can see the drive but it has a yellow exclamation mark. In Properties, the system says Error Code 38. I have tried uninstalling and reinstalling the driver and all of the USB port drivers to no avail. I am able to get the USB driver to work in Safe Mode. I have also tried cleaning the registry without success. I have tried using Windows native troubleshooter - no help. Using MSCONFIG, I rebooted without any Startup programs or Services and in Diagnostic Mode - the problem still persists. Before I spend a day reinstalling Windows and all my software, I wanted to see if anyone could suggest a solution I have not considered. Thanks.

Discussion is locked
Follow
Reply to: USB Thumb Drive Problem - Code 38 in Win 7 Pro
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: USB Thumb Drive Problem - Code 38 in Win 7 Pro
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Missing details about this PC.

Make, model, story "It worked until I installed this CD emulator" and such.

Windows can do this but my suspect is drivers such as motherboard drivers NOT USB drivers and apps.

- Collapse -
re: USB Thumb Drive Problem - Code 38 in Win 7 Pro

My computer is a Dell XPS L702X. The problem first appeared when I forced Windows to shut down by pressing and holding the power button after waiting a long time for the computer to shut down. I have reinstalled the chipset drivers and it did not help.

- Collapse -
There are prior code 38 discussion. Try.

CNET Forums