Windows Vista forum

General discussion

USB Problem - All devices

by Deiota / October 28, 2006 4:49 AM PDT


I've installed Windows Vista RC2 5744 x86 on my laptop but I'm having problems with USB ports!

On device manager, all ports are installed and drivers are up to date an working correctly but the main thing is Vista won't detect any of my USB devices!

Neither 3 Pen drives, neither Pocket PC and neither optical mouses!

I've tested on all 3 ports!

The laptop is Aopen 1557G and my USB controllers details are:

Intel(R) 82801DB/DBM USB 2.0 Enhanced Host Controller - 24CD - WHAT IS THIS?

Intel(R) 82801DB/DBM USB Universal Host Controller - 24C2 - WHAT IS THIS?

Intel(R) 82801DB/DBM USB Universal Host Controller - 24C4 - WHAT IS THIS?

Intel(R) 82801DB/DBM USB Universal Host Controller - 24C7 - WHAT IS THIS?


The wierdest thing is that I have 3 USB 2.0 ports, and appeard 4 USB Root Hub.

I don't really understand the meaning of these devices!

Please help me!

Hugs and Kisses to all!


Discussion is locked
You are posting a reply to: USB Problem - All devices
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: USB Problem - All devices
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
by John.Wilkinson / October 31, 2006 12:55 AM PST

I don't want to see the question go unanswered but at the same time don't have much information to offer.

In Device manager Root Hub basically refers to the physical USB ports while the controller refers to the drivers. Thus, all that's normal. When it comes to the number, are you sure you only have 3 total? Most newer computers also have front USB ports, so look around on the front panel, on the memory card reader (if you have one), etc...a fourth one should be there.

As to Vista not recognizing anything you plug in, the only thing I can think of is to plug in a flash drive and then go into Computer Management->Disk Management through the control panel...see if the flash drive is recognized there at all. If not you could try reinstalling Vista, but if it's a drive compatibility issue then the only solution would be to wait for Intel to release an update.

Good luck.

Collapse -
usb problems in vista
by sjmkerrigan / October 8, 2007 7:41 AM PDT
In reply to: Strange...

Hi, just read you notes on issues with usb ports on vista, i bought my son a presario f500 laptop and having great problems with usb ports not working, although when i go into computer management...then disk management.......the data bar drive is there ....but in my computer is not showing any icon... it sounds like the bar boots in,its lit up all the time.... but no way of finding it....please help.


steve kerrigan.

Collapse -
Same issue same laptop
by garethsrob / January 28, 2008 5:11 AM PST
In reply to: Strange...

must be a problem with the Compaq presario f500 cause i'm having serious issues with my usb ports... i've tried everything and keep thinking its a vista issue, but noone else with vista is having our haedaches... help, help help

Collapse -
Similar USB issues w/ nForce4 Chipset
by broo2 / January 12, 2007 11:23 PM PST

I am having similar issues, but only with certain USB ports. I have an nForce 4 motherboard and none of the on-board ports will properly detect a USB thumb drive/hard drive/storage controller- they seem to work Ok for web cams and such.

I have two PCI USB addon cards (I have a LOT of USB devices) and the USB drives seem to work through there- and also through USB hubs connected to the cards.

I know the ports are good as they work flawlessly in Windows XP- which I reverted back to until they figure out the USB problem.

If you find a solution to this, please post a quick note back here.


Atlanta, GA

Collapse -
USB woes!
by tacwalker / January 16, 2007 8:57 AM PST
Collapse -
need help restoring usb recognition by computer
by calixtesaint / May 4, 2007 1:26 PM PDT
In reply to: USB woes!

I have an Acer Aspire media edition with windows XP.AST660-EP821M
Somehow I deleted the icon "removable disk J" from 'my computer'.
Now the port I normally use does not work.In fact 2 of the 3 usb ports on the front panel do not recognize my memory sticks(both work perfectly on my laptop and are recognized by 1 front panel usb port)
The device manager says all is well with installed ports & hubs.
Is there another way to open my memory stick?
Is there a way to put back the deleted icons on "my computer"?

Collapse -
Perhaps you just disabled it?
by John.Wilkinson / May 4, 2007 4:13 PM PDT

Go into the Device Manager, right-click on the entry for the malfunctioning USB controller and see if you are given the option to enable the device. It may be it's just disabled, at which point it cannot be used but still reports full functionality without errors.

A second thought is that you may have hidden the drive letter in My Computer, but that it's still usable. Try entering the the drive letter into the address bar in My Computer (Ex: J:\ ) and see if it loads. It will typically be one or two letters after the last displayed drive letter.

A third possibility is a hardware malfunction, which can be caused by dust/dirt (use compressed air to clean the port out, if necessary), a loose wire (have you opened the case lately?), or aging equipment.

Finally, don't forget the old trick of uninstalling and reinstalling the device may just be the odd glitch.


P.S. You may want to repost in the Windows XP of Computer Help forum since you're not running Vista.

Collapse -
by calixtesaint / May 5, 2007 3:19 AM PDT

John, I appreciate your suggestion. i tried both 1 & 2 without success.
I'm a little scared to try suggestion 3. But here is some good news...
This morning when I tried the devices again something strange happened.
When I put the memory sticks into the front usb ports suddenly the icons for 'j' & 'k' appear on 'my computer' and the stick opens.
But both icons disappear when I remove the memory sticks!!!
At least now I can access my memory stick data so I am very happy!
Thank you for the help and quick response-this site is great!!!

Collapse -
That part's normal...
by John.Wilkinson / May 5, 2007 4:16 AM PDT
In reply to: Thanks

Optical (CD/DVD) drives, floppy/zip drives, and memory card readers will always show up in My Computer, regardless of if there's a disk in the drive. USB drives, on the other hand, will only appear when you have a readable device, such as a flash drive, plugged in. So what you're experiencing now is completely normal.

Congrats on getting it to work.

Collapse -
Know Vista USB problem
by camf33 / October 17, 2007 1:06 PM PDT
In reply to: That part's normal...

I provide IT support and have seen numerous Vista machines where suddenly when you plug any USB device it does not get recognized and prompts for drivers. I saw this occasionally in XP but not as much as in vista. There has to be a kernel glitch that affects the registry in conjuction with the USB root hubs. I am only guessing, I yet to find out a fix for it. Appreciate any feedback.

Collapse -
by noblemosby / October 22, 2007 2:28 AM PDT
In reply to: Know Vista USB problem

Ok, so I found out why vista has problems installing USB drives. Here's how to fix it:

1. In C:\Windows\System32\DriverStore\FileRepository I had two folders named "usbstor.inf" but each one had a different set of numbers attached to the end of the folder name. - could this be where part of the problem lies?

2. When i looked in my C:\Windows\inf folder i discovered the usbstor.inf and usb stor.pnf files were missing - this definitely had to be an issue.

Once I discovered these anomalies, I proceeded to copy the pnf and inf files from the most recently updated usbstor.inf folder to C:\Windows\inf. I then went back to the update driver wizard, pointed to the inf folder and what do you know but they all started working again.

I did this for my ipod and as soon as I reconnected it, it recognized it and worked immediately.
This worked for my Vista Ultimate 64-bit hope it works for you.

Collapse -
I'm new and just wasted 3 days of my life...
by flyakite80 / January 9, 2008 8:39 AM PST
In reply to: USB WORKING!!

...searching for the reason why my printer suddenly stopped working. I had tried EVERYTHING I know and I desperately started searching the internet. The printer could not be detected by the USB port - I have Vista. Finally, I found this post and your (noblemosby) solution worked for me!!! I am so happy I could cry, I can never thank you enough. THANK YOU!!!

Collapse -
There is another way!
by zentra / May 8, 2008 9:21 PM PDT
In reply to: USB WORKING!!

After looking at your solution to this microsoft wonder I had a poke around my self. In my case all the files in the file store were present in the inf folder but it still not working. so as a test i copied all the usb files out and backed them up and moved the ones from the store in then tried again. This solved it all, Thanks alot

Collapse -
problems with ubs
by kadetkadet / January 12, 2009 9:45 PM PST
In reply to: USB WORKING!!

i tried doing what u said, but because of my lock of knowledge with computers, can you give me step by step help on how to fix it? like copying the usb file to the next? please im begging you i have a knew camera and would love if my usbport recognise it..

tanx much

to: Noblemosby

Collapse -
There is a step by step now up at Kingston, other places.
by R. Proffitt Forum moderator / January 12, 2009 10:00 PM PST
In reply to: problems with ubs
Collapse -
by oshamajik / September 18, 2009 2:01 PM PDT
In reply to: USB WORKING!!

Great fix.. Thannks dude!!
This fix should be posted at the top so that people can find it.. I think most people are looking for this answer.. Dont know why the inf/pnf files would be missing though.. vista sucks as always :s

Collapse -
usb not working
by flatjack / May 28, 2010 6:30 AM PDT
In reply to: Know Vista USB problem

All usb devices are not working

Collapse -
by R. Proffitt Forum moderator / May 28, 2010 11:27 PM PDT
In reply to: usb not working

TiP: Don't bury a new request for help in old discussions.

Collapse -
Thank You
by Shereketha / January 27, 2012 12:22 PM PST

Thank you for this posting. I have been searching for a week as to why my mouse stopped working. I mapped the drive and I am back in business! Thank you......

Collapse -
by lucas_valentin / July 19, 2008 7:33 PM PDT

I had the same problem that most of the people here, one day I wake up and all my usb port won't work at all... I tryed everyting that is on the web to solve this problem and I didn't have success...
BUT searching I discovery that the problem was a update of microsoft, and this update is the responsible for all usb ports suddenly stop working. With this update, Vista can no longer find the drives for any usb device or it finds, but can't install! I just wanna share how I FIXED this annoying problem. I know that the problem is in a file in c:\windows\INF , but I don't know ecxacly which one.

So TO SOLVE this problem I just renamed the folder "INF" (C:\windows\INF) to "INFbkp" ( just made a backup), and I took the computer of a friend and copied the "INF" folder of his computer and placed in my computer (of course that I placed his "INF" folder in my c:\windows\).
In other words, JUST COPY THE FOLDER "INF" OF A FRIEND'S COMPUTER AND REPLACE THE "INF" FOLDER IN YOUR COMPUTER. (Of course that you need take a friend's computer that have all usb ports working normally!!!).


Well, thats how I made my usb work again. Sorry for the bad english, I made the best I could.


Collapse -
USB Host Controller conflict resolved; all USB Ports WORK
by jman0918 / July 31, 2008 2:16 PM PDT

I'm running Vista Ultimate x64 dual booted with XP x32. I knew that my USB ports all worked as I can confirm it in XP. I was puzzled as to why it wouldn't work in Vista.

After some investigating, I discovered a conflict. I had 5 USB Root Hubs for 4 pairs. Furthermore, I had 4 VIA Rev 5 or later USB Universal Host Controllers showing, and one VIA USB Enhanced Host Controller. Somehow (I don't remember) I discovered that the Enhanced controller wants all 8 ports, and each Universal controller tries for 2 ports.

I have a MSI VIA-based K8M800 board, with a ATI 2600 PRO AGP.

In the end, I disabled the VIA USB Enhanced Host Controller, which caused a root hub to disappear and my Logitech Rumblepad 2 to be installed. I can also plug in my LG VX8350 into any port.

Enabling the enhanced controller makes the gamepad disappear.

I've seen an Intel Universal Serial Bus controllers lineup. It looks the same, and at least one post somewhere reported an extra root hub. Please post your results.

Collapse -
Thank you so much Jman0918!
by DRaven84 / March 28, 2009 6:03 AM PDT

I have been searching all over the net for a fix to this problem and have tried nearly every suggestion I found to no avail. I had to create an account on CNET just so that I could say thank you for figuring out what the problem was.

I simply disabled the enhanced controller on my PC and all the USB hubs (4 at back and 1 at front) all started working perfectly.

Though I admit I still don't fully understand why the enhanced controller caused the problem. I would appreciate more info (like where you read that the enhanced controller wants 8 ports)

Thank you again jman,

Collapse -
re: USB Host Controller conflict resolved; all USB Ports WOR

I also was able to resolve the problem of USB devices not working by disabling the "USB Enhanced Host Controller" in the device manager tree.

Collapse -
Thank you Noblemosby and Lucas_Valentin
by metzen01 / December 8, 2008 11:57 AM PST

I had looked everywhere for the solution to my USB problems in vista and I wanted to thank you guys for finding the solutions. I first tried the suggestion Noblemosby but it didn't seem to do the trick. Finally I performed the suggestion that Lucas Valentin mentions which is copying the INF file from another working pc and this worked!!

All usb devices now work and I'm happy!!!!

Collapse -
USB Ports Not Working (Resolved)
by toniadm / March 12, 2009 1:23 AM PDT

I have a HP Pavillion Laptop dv6-1030us. After about 2 months of working fine, I experienced the problem with the USB ports yesterday. My USB ports all of sudden stopped working. I have four USB ports. Two of them didn't recognize that anything was plugged into them at all. The other two recognized when something was plugged in, but the unknown device error was received when the PC tried to locate the drivers. I noticed that there had been some updated to Windows. I backed those out. Still had the same issue. I tried deleting the INFCACHE.1 file. Still the same problem. Finally, I shutdown the PC. Still the same problem. Finally, I shutdown the PC and unplugged and disconnected the power cable and waited about 15 mins before powering back up. This cleared the problem for me. We'll see if it comes back.

Collapse -
USB ports not working (Resolved)
by czechnate / December 15, 2009 4:50 AM PST

I have a HP pavilion dv4 with Vista 32. Windows stopped recognizing my Iphone via the USB port. I too shut down my laptop and disconnected the power cord and took out the battery then held down the power button to release any extra power, then waited about 15 min. I plug it all back up and tried it out and now it is recognizing my Iphone. Thanks

Collapse -
USB Problems with Vista
by czahrte / November 30, 2009 4:29 AM PST

Open right click menu on the desktop and go to [Personalize] in the menu that pops up choose [Screen Saver].
In that window click [Change Power Settings], Pick the power plan you are currently on and click [Change Plan Settings].
In the new window choose [Change Advanced Power Settings] in the Power Options window open [USB Settings]
then [USB Selective Suspend Suspend Setting] and set both options to Disabled and Click the [OK] button. It may require
a restart but this should take care of your problem with the usb device.

Collapse -
back to square one
by kingdonking / December 16, 2009 10:30 AM PST

i did as you instructed and it worked fine - for a couple of days. And now I'm back to the same deal where my laptop sees USB storage devices but will not recognize them. I've tried several different external hd's and thumb drives with the same results. Other things such as external wifi devices all work okay. only storage devices experience the problem.

Collapse -
Fix front USB ports connected by wire to mobo header
by jman0918 / January 1, 2010 10:27 AM PST
In reply to: back to square one

I had an issue where my front USB ports wouldn't work unless i disabled the USB Root Hub or the VIA Enhanced USB Controller that governed the USB 2.0 flow, but this made my flash drive transfer speed really slow.

To add to the confusion, the ports worked in XP but misbehaved when I switched to Vista.

I did some research on USB headers, and learned that only 4 wires are needed per port so I decided to disconnect the S-GND wire from both pairs (the fat black ones), leaving the +5V, USB+/-, and GND connected. When I closed up the box and powered up my machine, my game controller and flash drive connected without issue.

Collapse -
Re:Fix front USB ports connected by wire to mobo header
by goingmad / January 5, 2011 6:58 AM PST

Thank you iman0918.

After searching for hours for a software fix with no luck removing S-GND wire from the drive bay usb device to the mobo header has competely fixed all the issues I've been having with Windows 7 64 bit, usb flash drives and the via usb enhanced controller.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


iPhone 8: Everything we know so far

This is all the iPhone 8 reports and rumors in one place. From a 5.8-inch OLED display, reports of wireless charging and even a 3D scanner for facial recognition, it's all here.