Computer Help forum

Question

USB ports not working

by evankli / October 15, 2015 9:35 PM PDT

All of my USB ports suddenly stopped working. I left my computer on sleep for a few days and when I came back my keyboard and mouse LED's weren't on. I tried different ports and none of them worked. When I tried replugging in the USB wires that go into the mobo, my mouse LED would flash for an instant and then go dead. Is there perhaps some type of problem with too much current going through the USB ports? My mobo is fairly new with not much use on it. I believe its a MSI Z97 gaming 3 or 5 motherboard.

Thanks!

Discussion is locked
You are posting a reply to: USB ports not working
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: USB ports not working
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
Sleep is known for such things.
by R. Proffitt Forum moderator / October 16, 2015 6:20 AM PDT
In reply to: USB ports not working

You didn't reveal if you did a full reboot.

Collapse -
Did reboot
by evankli / October 16, 2015 9:04 AM PDT

I tried doing a full reboot a few times, someone told me to go into BIOS using the PS/2 port for the keyboard. Going to try that when I get home.

Collapse -
Wait?
by R. Proffitt Forum moderator / October 16, 2015 9:14 AM PDT
In reply to: Did reboot

Are you telling me that your USB keyboard is working to get to the BIOS but it all fails in Windows? No, you haven't told me that yet so I can't guess what to do next.

If the ports did fail as you noted, then you would not get to the BIOS. Ya?

Collapse -
Clarification
by evankli / October 16, 2015 12:37 PM PDT
In reply to: Wait?

Sorry, I meant the USB ports don't work period. But someone told me that if i hooked up to the PS/2 port and try to get into BIOS that way it could help.

Collapse -
That's a good idea.
by R. Proffitt Forum moderator / October 16, 2015 12:42 PM PDT
In reply to: Clarification
Collapse -
Yea
by evankli / October 16, 2015 3:44 PM PDT
In reply to: That's a good idea.

Yes I tried the ones directly on the motherboard as well as other ports attached onto my case that were connected through a wire onto my mobo

Collapse -
Let's hope for the best.
by R. Proffitt Forum moderator / October 16, 2015 4:08 PM PDT
In reply to: Yea

About all I didn't cover was a CMOS reset. Since you have little to lose at this point, use the CMOS reset noted in your motherboard manual.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!