HolidayBuyer's Guide

Desktops forum

General discussion

USB port suddenly stops working

by aarons100 / May 16, 2009 4:59 PM PDT

I am having USB port problems. Sometimes it works and occassionally it doesn't work. It has become worse since a few days. My mouse suddenly stops working. Is it a hardware or a software fault. I am using intel dual core 2.5 ghz on an intel DG31PR motherboard running windows xp SP2.
I even reinstalled the USB drivers(controller, hub), etc. But still the problem persists. It happens more when I insert a second USB device, then both the ports stop working. Then I have to remove and reinsert the USB device and it starts working.
It is really annoying when all of a sudden in the middle of a game, both the usb mouse and keyboard stop working
Somebody please help me out.
recently i discovered one more thing . when i plug in the speakers in the AC outlet on the UPS, both the USB mouse and USB keyboard hang.
does this problem have to do anything with the power circuit of the CPU

Discussion is locked
You are posting a reply to: USB port suddenly stops working
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: USB port suddenly stops working
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
check the speed of your ports
by GENE8 / May 22, 2009 5:12 PM PDT

It is possible that your USB ports do not match the speed of the USB devices you are using. For instance, your USB ports might be 1.1 ports, while the drivers you are using with your mouse and keyboard requires a 2.0 port. If that's the case, then your system is going to have trouble working with those devices. If that is the problem you're having, then the best solution is to either upgrade your motherboard or get a USB hub that can upconvert your USB ports to a 2.0 speed so your devices can work with them.

Collapse -
USB port problem, migration
by cheyguy / May 23, 2009 2:37 PM PDT

HP m7560y (32-bit)with 8 USB ports, three years old. New Dell Studio XPS (64-bit) with 8 USB ports. HP appears to only have v.1.1 USB, while Dell has 2.0. A 7-port hub is connected to the HP, hub is 2.0, "works with 1.1". Front USB ports on HP no longer work, so hub is plugged into a rear USB port. Bought Laplink PCMover Pro, says it will transfer from XP32 to Vista64, and will work with 1.1. Tried to set up USB-USB migration, sets up on Dell, but not HP, yet I got a transfer started. Tried Cat5 cable, and it will run until midnight, then quit (80 Gb to migrate, programs and files, best I've gotten is 8 Gb, it's so slow). Filtered out games, Adobe CS3, turned off screensaver (Azure Bay), Norton 360, MS Auto Update, HP Update Manager, all of which try to update at midnight, migration still stops at midnight. I read a post about a hub that upconverts from 1.1 to 2.0, I've never seen one. Anyone know who makes it? Secondly, I have run out of likely reasons the migration stops at midnight. Any ideas?

Collapse -
Tried the reverse?
by deniceels / May 25, 2009 3:46 PM PDT

Have you tried the reserve of from HP to Dell? Does it happen to hang at midnight when doing so? How about trying to copy like 5mins before midnight and see if it goes through that time and copy.

Is your hub provided with and option of taking in external power source? Does both transfer stops at 8gb at different starting point and stops at midnight? Did you see what file it's trying to migrate over when it stops? It could be one of those huge files which takes too long that the software cutsoff transfer due to long inactivity.

Collapse -
USB port suddenly stops working
by squeeze / May 23, 2009 8:43 AM PDT

I found a couple things to try. First with the previous poster, to see if you have USB 2.0, click on start>rt. click My Computer> click Manage> in window that opens click Disk Manager, scroll down to USB controllers and click the plus sign to open that branch. Look for the word "Enhanced" in one of the branches. If there you have 2.0, if not chances are you don't have 2.0. Sometimes spyware will cause the USB devices to hang. Run at least 4 anti spyware programs (such as Ad aware, Spybot S&D, Superantispyware, and Malwarebytes, they are all free)Delete anything they find. Another issue that I found that affected the USB as well as Video was dust build up. Take the cover off the left side (as you look at it from the front) and gander at the insides. Is it a dust ball in there? If so power down and get a can of compressed air to blow the inside dust out (hold the fan blade from turning with a finger as the compressed air will spin it faster than it is supposed to go, and as always watch out for electro-static discharge. Of course I am assuming that this all worked before and now just started to happen. Another thing is to get rid of temp files and temp download clutter, cookies etc. Last but not least id defragment the computer if it has been a couple months or longer since it was last done (empty recycle bin before defrag.) Hope this helps. Jim

Collapse -
I suggest you check the dvice manager...
by davagain / May 23, 2009 1:12 PM PDT

... for reports of driver problems. I know you said you reinstalled the drivers, but the problem is persisting. I suggest you check to see whether your computer is aware of a problem. That may help you diagnose and correct it.

Collapse -
USB Power
by deniceels / May 25, 2009 3:41 PM PDT

From the looks, it seems like your USB ports are under-powered by the PC. Check the USB power distribution in your USB hub in device manager. Ensure it don't go to power savings and try it out.

Given when you plug your speaker to the UPS, have you tried plugging your desktop and speakers to the power mains directly instead? If it still persist, next is to test your keyboard and mouse with another system to see if similar problems occurs, followed by plugging in a external card-reader or maybe try using your mobilephone connecting the desktop. If all, except mobilephone works, you have a USB poweroutput issue.

Collapse -
more options
by jeff_windows_team / May 27, 2009 3:06 AM PDT

Sounds like a driver issue to me. Since they both work at some point or another, this is an unlikely solution but try plugging the USB devices into a different computer and see how they perform. It could be the devices themselves.

Jeff
Windows Outreach Team

Collapse -
How to resolve USB ports that suddenly stop working
by bor2b00 / May 5, 2014 12:40 AM PDT

I have done a lot of driver installs and system checking to determine the root cause of this issue that started after Installed windows 8 on my Dell Inspirion N5050 laptop. But I recently found the solution to the problem is a power saving feature in windows 8+ that causes the USB to sleep after a period of inactivity. How much power does it save to turn off the USB? Ok, so if you are like me and have tried everything suggested under the sun, try this:


Step 1: Open Control Panel

Step 2: Click on System and Security

Step 3: Click on Change when the computer sleeps

Step 4: Click on Change advanced power settings

Step 5: Scroll down the list to the USB Settings node and expand it by clicking the + sign on the left.

Step 6: Expand the USB selective suspend setting node by clicking on the + sign to the left.

Step 7: Click on "On battery:" to activate the selection drop down and select "Disabled".

Step 8: Click on "Plugged in:" to activate the selection drop down and select "Disabled".

Step 9: Click OK to exit back to the Edit Plan Settings

Step 10: Click Save changes.

Step 11: Click the "X" in the upper right corner of the Edit Plan Setting dialogue to close Control Panel


THE END!

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

The Samsung RF23M8090SG

One of the best French door fridges we've tested

A good-looking fridge with useful features like an auto-filling water pitcher and a temperature-adjustable "FlexZone" drawer. It was a near-flawless performer in our cooling tests.