Thank you for being a valued part of the CNET community. As of December 1, 2020, the forums are in read-only format. In early 2021, CNET Forums will no longer be available. We are grateful for the participation and advice you have provided to one another over the years.

Thanks,

CNET Support

General discussion

USB Plug and Play ** does not automaticly recognize/installs

Dec 19, 2007 11:27AM PST

Hi,
Recently i noticed that my computer does not automatically searches and installs the drivers for Plug-n-Play devices (with no user input), like USB drives, ETC.

I have to manually choose the driver for the USB Device(s), which ca be a gamble if you choose the wrong one, and annoying, and frustrating.

When a user plugs a new USB flash drive into the pc, the computer is suppose to automatically search the drivers, and installs them, as usual, and normal.

Does anyone knows what has changed that created this?
Does anyone knows how to fix it?
Does anyone knows how to revert it? (system restore does not works on my pc)

Carlitos287@hotmail.com

Discussion is locked

- Collapse -
The Computer Specs
Dec 19, 2007 11:29AM PST

Windows XP MCE 2005 W/SP2
2GB DDR2 @ 600MHZ
250GB HDD
blah blah blah...

oh and it is a:

Sony VAIO VGC-LS1

- Collapse -
USB drivers
Dec 19, 2007 7:01PM PST

Check that your USB drivers have no problems. Control Panel > System > Hardware tab > Device Manager.

Under USB controllers check for any ? or ! signs, and update the drivers for them, just let Windows automatically sort it out.
This might clear any USB related problems.

Also, any plug and play device will show in Device Manager, so they can be checked out there, once connected, maybe it needs enabling, or will detail any problems.

I hope that helps.

Mark

- Collapse -
the caracteristics
Dec 19, 2007 7:33PM PST

[[which can be a gamble if i choose the wrong one(s)]]

and it is frustrating...

now will this give you an image of what's going on?


>>>>>Oh, and nothing is wrong with any of my hardware.....<<<<<

- Collapse -
No, try the USB Controller drivers
Dec 20, 2007 1:32AM PST

not drivers for each individual USB device.

Sometimes drivers can fail. Updating the USB Controller drivers may solve the problem.

Mark

- Collapse -
OMG
Dec 20, 2007 4:01AM PST

OMG....IT"S NOT A DRIVER/HARDWARE Problemmm....

It's a software problem...

The computer MUST automatically search and install the driver for any plugged USB drives.

ok....

there's nothing wrong with the current hardware configuration/drivers..

windows only need to be told NOT ask the user to manually find the drivers to install the new hardware plugged in to the computer...

I have been working with computer for years now...
and if i knew the answer, i would not even bother asking this question on forums...

this needs the attention oo some VERY SPECIALIZED PEOPLE that have EXPERT knowledge in the Windows XP OS.

- Collapse -
Same Problem
Feb 25, 2008 11:15PM PST

Ya, Mark has no idea whats hes talking about...

I am having the same problem and its driving me nuts

I tried cleaning the inf cache and still nothing... (this fixes it for vista, i don't know what its not working in XP).

however maybe it will work for you

try going to C:\windows\inf\ and deleting the infcache.1 file (this is the file that tells windows were to look automatically for driver files)

this should force windows to rebuild the cache and hopefully find your drivers

let me know if it works...any other idea please?!? this is driving me crazy.

- Collapse -
it works!
May 14, 2008 8:45PM PDT

I had the same problem and deleting the infcache.1 file worked for me! thanks!

- Collapse -
Help me Please!!!
Nov 30, 2012 10:28PM PST

I have the same issue (USB) with my Dell Ispiron 1000 with XP (sp3). I couldn't figure it out so I ended up paying a lot of $$ for one of these online companies that did nothing more than remove and re-install the drivers. When the USB detects an additional it attempts to install the driver but errors out. "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)" I'm broke now... please email me at rwdavis05@yahoo.com.

- Collapse -
Locking this old post.
Dec 1, 2012 12:22AM PST

I see you have a duplicate post.

- Collapse -
the fix that worked
Feb 25, 2008 11:27PM PST

XP comes with drivers for USB mass storage. If it asks for drivers then it has forgotten where they are...
Start the Registry Editor (Run -> Regedit). Check if under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion the item 'DevicePath' points to '%SystemRoot%\inf'. Additional items, separated by semikolons, are ok but '%SystemRoot%\inf' has to be one of them.
Then delete the file C:\WINDOWS\inf\infcache.1 - XP will recreate it.
The INF folder and the infcache.1 file are 'hidden'. To see them in the Windows Explorer:
Menu 'Tools' -> 'Folder Options'
Tab 'View', mark 'show hidden files and folders'
If it still doesn't work after a restart, the files in C:\WINDOWS\inf might be corrupt. An Windows repair install helps then.

Another thing to check is if the values 'FactoryPreInstallInProgress' and 'AuditInProgress' are set to '1' under
HKEY_LOCAL_MACHINE\SYSTEM\Setup
and
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Factory
. They should be 0 or non present.

- Collapse -
Thank you dan2600!!
May 18, 2008 2:08AM PDT

My apologies for bumping a zombie thread, but I've been wrestling with this all weekend and finally found this. Thank you for a fix which WORKS. Microsoft needs to add this to their article about uninstalling the root hubs. "Windows will reinstall the drivers".. no it won't sometimes. Your post is printed out and now stuck on my office wall for use in the future. Silly

Thanks again!

- Collapse -
can rename file rather than delete
May 18, 2008 3:00AM PDT

Oh and if Windows doesn't want to let you delete the file, just rename it instead.

- Collapse -
Great fix for USB probs
Sep 23, 2008 8:04AM PDT

Thanks Dan2600, I had exactly the same symptoms on a PC and it was resolved simply by the DevicePath change you suggested.

I had been trying in vain to work this one out as I hate re-installing just for the sake of it.

Thanks again

- Collapse -
Fixed my usb problem too
Sep 27, 2008 12:37PM PDT

Thank you Dan2600. I also was not able to install or use any usb devices in any of my 3 usb ports.
My regedit results , i found the devicepath was set to a random folder in documents and settings. changed it to '%SystemRoot%\inf' and voila, i am able to access the usb devices.


your fix was perfect, after many hours of trying to update drivers for usb devices in winxp. Thank you.

- Collapse -
Additional Information
Oct 29, 2009 3:20AM PDT

I found some more information about removing those pesky residual keys from the registry that sysprep can leave behind.

"http://forums.windowsitpro.com/web/forum/messageview.aspx?catid=36&threadid=86870&enterthread=y"

well, in case anyone else found this page on Google like me, here's the solution that worked for me:

make the following reg changes:

HKLM\SYSTEM\Setup
AuditInProgress = 0
cmdLine = "setup -newsetup"
FactoryPreInstallInProgress = 0
MiniSetupInProgress = 0
SetupType = 0 //this one is important!!!
SystemSetupInProgress = 0

HKLM\SOFTWARE\Microsoft\Factory
delete this entire key

and on the HDD:
c:\sysprep (or wherever you extracted it to)... delete it.

- Collapse -
Thank you for The Fix that Worked
Dec 5, 2010 12:39AM PST

I had struggled for 2 weeks with this problem. Your fix worked perfectly. Thank you.