Question

USB only showing in Devices and Printers

I have a Sandisk Ultra USB 3.0 32 GB flash drive. I have not had any problems with it until last night.

When I plugged it into my laptop (Windows 7) last night the USB did not show up under "Devices with Removable Storage". After some looking I found the flash drive listed under "Devices and Printers". I tried it on a desktop running Windows 10 and the same thing happened. Today I tried it on my work computer (Windows 7 Pro I believe) and the same thing happened.

The drive is not appearing in disk management so I am unable to try changing the drive letter. Is there anyway to fix this so I can access what is on the flash drive?

Discussion is locked

Follow
Reply to: USB only showing in Devices and Printers
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: USB only showing in Devices and Printers
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Re: corrupted flash drive

Probably not possible to access the files on that corrupted drive. So you have to get them from your backup.

As we say here: "You only lose what you don't backup." Having only one copy of a file is an invitation for Murphy to come and visit you. That goes for internal and external hard disks, USB-sticks, sd-cards, and burned CD's and DVD's.

Kees

- Collapse -
Answer
Reinstall USB controllers

Hi @jadyn513!

Do you have any other USB devices connected to the PC and if yes - how do they appear? Do you have the same problem with them as well?

In this situation I would suggest to reinstall the USB controllers and see if the problem will be fixed. Since you're using Windows 7 you can follow these steps to do that:

1. Click Start, and type devmgmt.msc in the search field.
2. Select Device Manager in the list of programs.
3. In the Device Manager, expand Universal Serial Bus controllers.
4. Right-click every device under the Universal Serial Bus controllers node, and then click Uninstall to remove them one at a time.
5. Restart the computer, and the USB controllers will be reinstalled automatically.
6. Plug in the removable USB storage device, and then test to make sure that the issue is resolved.

Hope this helps and let us know how it went. Happy

- Collapse -
RE: drivers

Since the OP writes it happens on 3 different computers (including his work computer) I don't think that reinstalling drivers on his home PC will have any use.

- Collapse -
Answer
RE: Drivers

The flash drive in question is the backup. I was intending to update it when it started messing up.

Just because I have other copies of what's on the flash drive doesn't mean I'm not curious about what happened, how to avoid it happening in the future, and if it is an issue that can be fixed.

I will try reinstalling the USB drives tonight.

If the drive is corrupted can the info be recovered? I know there is software that can recover files after a drive has been accidently formatted, do any exist that do the same thing for corrupted drives?

- Collapse -
I would not do that.

Flash drives do fail. The fact it didn't work in all your PCs is not a sign of driver issues and the reinstall of drivers is not called for.

This is a great way to make matters worse. Try another flash stick and later, try the maker's formatting software on this stick.

CNET Forums

Forum Info