Question

USB not recognized

I have a question. When connect my USB to my system Window 10 then an error msg appear, USB not recognized. Any suggestions to solve this problem?

Discussion is locked
Follow
Reply to: USB not recognized
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: USB not recognized
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
USB Is Damage

Is it USB data storage. I think your usb is damage. you should buy new one. i have bought 2 online they only work one time. when i have deleted data and try to copy new data it did not work. take a long time and final system say to me USB not recognized.

- Collapse -
Answer
TRY THIS.

1. Open Device Manager.
2. Expand the Universal Serial Bus controllers branch.
3. Double-click the USB Root Hub device, and click the Power Management tab. (if there’s more than one USB Root Hub device, repeat these steps for each one.)
4. Turn off the Allow the computer to turn off this device to save power option, and click OK button.

- Collapse -
Answer
Just last month, that happened to me.

The USB cable turned out to be a factor. Changed cables and it worked again. Cut old cable in 5 pieces and put into the recycle bin. Hope it's that.

Be sure to test your device on another PC but that worked here so next try was a cable.

- Collapse -
Answer
Not with me

I tried it on other computers, it works. Maybe there are some settings in Window 10 who restrict my usb or some thing like that.

- Collapse -
At the office we are almost all W10 now

The stock settings just work.

As I only have the story above I shared something that happened recently. It did work on other PCs but I know about cables so that's what I changed and that worked.

-> To go any further, let's get more details.

Post was last edited on August 18, 2016 8:41 AM PDT

- Collapse -
Solved

Thanks for helps. problem solved and that was not cables. USB needed driver updation. I update driver and now USB is finally in working condition.

CNET Forums