Computer Newbies forum

General discussion

USB Memory stick not recognized

by Rezadoo / August 15, 2005 2:32 AM PDT

I just bought a new e-machines computer with a AMD 64 processor with XP SP2. However, whenever I stick my flash drive into the USB port, it isn't recognized. It shows up on my toolbar, but tries to find the drivers and it states that it cannot find the driver, INF file is invalid. I checked the BIOS and the USB is enabled and when I go to tech services they tell me the same thing, to go back to BIOS an enable my USB and reboot. This has not helped and I cannot find any drivers to load off the net to get me back to where I need to be. However, when I plugged in my printer, it was recognized and works fine. Can anyone help???

Discussion is locked
You are posting a reply to: USB Memory stick not recognized
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: USB Memory stick not recognized
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Visit OEM support website
by Willy / August 15, 2005 2:51 AM PDT

See if any bios updates are available, do check for your model mtrbd/system. Also, USB updates themselves from the vendor. XP should support USB drives alone, but glitches are known, in some cases to the flash drives themselves. I found one brand to be problematic, if that's yours try it in another system, that's Memorex brand. Here's a helpful link:

tada -----Willy Happy

Collapse -
You also might...
by jackintucson / August 15, 2005 4:58 AM PDT

check to see if that particular drive and the 64bit processor get along with each other. I fear this isn't the first time for this type of conflict and certainly won't be the last until drivers are written for the new 64bit format. Have you tried a different brand usb drive?

and life goes on...


Collapse -
What is 'your flash drive'?
by R. Proffitt Forum moderator / August 15, 2005 5:03 AM PDT

I have a few Amd 64's at the office with XP SP2 and the flash drives we own (Sandisk and Lexars) just work.

There are some no-names that required a driver which you'll have to find and install.


Collapse -
Drive Types
by Rezadoo / August 15, 2005 5:05 AM PDT

They are Sandisk's and they work on my Intel driven laptop. I did not see any "patches" on the AMD website. Does anyone know of any?

Collapse -
No patch required.
by R. Proffitt Forum moderator / August 15, 2005 5:16 AM PDT
In reply to: Drive Types

But there was some models that needed a firmware update of the USB stick. Details matter, but you are not supplying them yet.

Try exact make/model of the Sandisk stick.


Collapse -
I forgot to mention TWEAKUI
by R. Proffitt Forum moderator / August 15, 2005 5:17 AM PDT
In reply to: No patch required.

When I see this I always check TWEAKUI's drive letter settings to be sure that the drive letter isn't set to hide in Explorer.


Collapse -
by Rezadoo / August 15, 2005 7:27 AM PDT

Please forgive me for asking, but what is TWEAKUI? My flashdrive is a Sandisk Cruzer Mini. It is recognized once I plug it in, but my computer keeps looking for a driver to load, but it does nnot find one and notes that my ''INF is invalid''. If there are other points I am missing or not informing you of, please let me know and I will provide what I can. I am at wits end with this and appreciate the help.

Collapse -
Look at
by R. Proffitt Forum moderator / August 15, 2005 8:12 AM PDT
In reply to: TWEAKUI????

TWEAKUI is easy to find and one of its tabs is about Explorer and hiding drive letters. It's a common issue and easy to fix with the note (free) software. writes what you need to check (drive letter).

Collapse -
SanDisk Cruzer not recognized
by micpross / February 22, 2006 4:50 AM PST
In reply to: TWEAKUI????

I noticed the discussion from Fall 05, about SanDisk Cruzer not recognized by USB port in AMD systems. I have AMD Athlon 64 Processor system by Shuttle. I bought the SanDisk U3 Cruzer Micro; the read light stays on constantly. After 2-3 minutes it actually shows up as a CD Drive U in my file directory; but when I click to expand there is nothing there and it shows 0 objects. So, did anyone ever find a solution to this?

Collapse -
SanDisk Cruzer inconsistent
by Starving Artist / February 26, 2006 6:35 AM PST

Glad (?) to see someone else is having problems with this. I have tried plugging mine into two Intel laptops and have not had any problems. However, when I tried it on a number of desktops, most of them don't work. I get the same read light always-on and 0 objects showing up as well. I'll have to check later this week and see if they are running AMD.

I tried contacting SanDisk support and they are no help whatsoever. They said try using the Install CD when there isn't even one included.

Collapse -
The usual?
by R. Proffitt Forum moderator / February 26, 2006 8:21 AM PST

I find many XP installs by end users that don't know about motherboard drivers. It's proper for Sandisk and others to not help you fix the bum install.


Collapse -
They could at least steer me in a direction
by Starving Artist / March 16, 2006 12:32 PM PST
In reply to: The usual?

While Sandisk might be happy to give poor customer support, I'm using using a standard Gateway tower PC out of the box and the Cruzer Micro simply will not work. Yet I haven't had any problems with it on my HP laptop. They could at least suggest a possible problem; there are obviously other people that need help too.

Tech support said since it works on one computer, they couldn't give a refund. Unfortunately a USB key that only works on one computer isn't very useful at all.

Collapse -
Which is the crux of the issue.
by R. Proffitt Forum moderator / March 16, 2006 12:41 PM PST

Let's say they did fix it. Would you pay? It's not their fault that something is amiss with your machine.

I know that may rile you, but it's part of the problem.

Again, if you could look into motherboard drivers, enabling the USB ports and trying the rear ports you may lick this issue. is full of clues as well.


Collapse -
SanDisk Cruzer not recognized
by mzbenita / March 6, 2006 2:49 AM PST

I just returned my second 1 gig Cruzer. Both worked for a short time in my laptop and desktop, each with Intel inside, but soon were not recognized by any computer.

I liked the style of the Cruzer but I've moved on.

Collapse -
Why AMD, when you have emachine
by Willy / August 16, 2005 1:10 AM PDT
In reply to: Drive Types

Check the eMachine's support website. Also, check thier Q&A, FAQ what if anything is available as related to your problem. Since, you tested on another system, maybe there is a compatibility issue. Plus query At Sandisk's support website and explain your problem there. -----Willy

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Want to see the future of car technology?

Brian Cooley found it for you at CES 2017 in Las Vegas and the North American International Auto Show in Detroit.