Storage forum

General discussion

USB mass storage device suddenly not recognised

by jaybeef / October 14, 2005 8:04 PM PDT

Sorry - aware that several previous discussions have tried to deal with similar issues....but the issues vary every time it seems!
I have a Fujitsu (I think - nothing to tell me, and it was given to me new by another person) Mobile DIsk external data storage USB device, 40 Gb. Several days ago my computer (with XP SP2)said it did not recognise it. Previously it did. I have tried the device on another computer and it installs immediately and functions, so there is nothing wrong with the device, which powers from the computer directly. It powers up on mine, and everything indicates that the USB port is ok since I can plug in other devices (eg flash).
Basic question - how does one resolve this kind of problem? I only have a recovery disk for the computer, not a separate set of XP cds, and I hesitate to go all the way back to scratch! If I am correct, this is not a driver issue. Then what kind of isse is it? Would going back to a restore point succeed? I tend to think not. So.....?

Discussion is locked
You are posting a reply to: USB mass storage device suddenly not recognised
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: USB mass storage device suddenly not recognised
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Something you can try
by Steven Haninger / October 14, 2005 9:00 PM PDT

USB devices can be flaky and there's no end to stories like yours. I've had a couple, however, that were resolved by simply going into the hardware screen, removing the device, restarting the machine and letting Windows redetect it. It should have retained the driver and will reload it. Now, it does sound as if your device needs more power than most. Such could be the root cause of your issues. What XP will detect is the controller for the drive and the controller will then configure the drive itself. At this time, Windows should see the drive. Can you tell if controller is seen but not the drive? These devices need a bit more current than most others and the lack of power from the 5v to the USB header might be a clue.

Collapse -
USB mass storage device suddenly not recognised
by jaybeef / October 15, 2005 12:41 AM PDT
In reply to: Something you can try

Thanks for quick response. Minor joy but only because we are on the right track I think. But I hope we can still take further steps, because....after doing what you suggested, the rebooted machine initially said it saw an unrecognised device, went through the motions to tell me it was installed then seconds later gave me the old message again.
My Asus computer has 6 USB ports - a mouse in one and the HD device in another. Nothing else attached. I presumed it might be the mouse it was recognising on the reboot. I tried removing the two unrecognised USB devices (that's what the device manager said) from the machine and going through the same process. But while the mouse has no problem finding it's way back, the other still does. I think, in answer to your question that the controller is seen but Windows doesn't see the drive and I'm told anyway the device is unrecognised.
A minor annoyance is that my machine speaks Italian (so do I, but I have to think what the actual terms are in English, so if my descriptions are not precise that will be the reason). The quickest way to arrive at the device manager seems to be to double-click the balloon which tells me about an unrecognised device. That brings up the device manager immediately, showing the items under the USB root hub (6 ports) and highlighting one of them in bold. Double-clicking that produces the general properties and driver tabs, the first telling me that no driver is installed for this device (if I am translating that accurately). The driver tab gives me a range of options including uninstall - which I did.
I hope that process was all correct. AN option ot update the driver appears to be no help - where would I get it from?
So that's where I'm at, at the moment. Still without the use of the protable HD. IF power is an issue, it wasn't previously - the item worked perfectly on this same computer.

Collapse -
"AN option ot update the driver" is a bad idea.
by R. Proffitt Forum moderator / October 15, 2005 12:59 AM PDT

Here'w why. If you mean that driver update button in Windows, that is nothing more than a demo from my experiences. Better than 1/2 the time it results in degraded operations or failures. Microsoft does not produce your PC and can't get this one right.

-> Use the drivers from your PC's maker.



Collapse -
OK, agreed - but where does one go from here?
by jaybeef / October 15, 2005 5:08 PM PDT

The CD that comes with the HD device seems to be only appropriate for anything under Windows XP - in other words it does not seem to install the device for me, or put another way, the end result is still an unrecognised device! And is the driver the problem?

Collapse -
Here's how I update the driver and test the device.
by R. Proffitt Forum moderator / October 15, 2005 11:49 PM PDT

1. Update the driver. I visit the motherboard maker's web site for motherboard drivers.

2. Test the device. I try it on another good machine.

Hope this helps you narrow it down.


Collapse -
the solution is so easy
by jaybeef / October 17, 2005 6:00 AM PDT

In case others out there are still struggling with this vexing and msot annoying problem, the solution appears to be simple. In the first instance, though, it has to be said that after googling my around the net for several days in search of help, it appears the problem with USB recognition being occasionally flakey is widespread. 2nd observation is that people try to be helpful but none of the solutions (aand some are dire and dramatic like reformatting disks) seem to work----except one.
Close everything down, remove all peripherals ANDm importantly, remove the power supply. Leave the computer for about 30 minutes so that all residual electricity goes out, then reboot. Attach USB devices and other devices one by one - XP has been forced to restore all its drivers and away you go! Well, it worked for me, and I've read three other cases where it worked similarly (which is where I got the idea from). so why not try it?

Collapse -
Thanx Heaps
by Diggety / January 1, 2006 7:53 PM PST

I have been trying for 2 weeks to fix my problem of the USB. You have solved it for me. Thanx heaps

Collapse -
Clarification please...
by VAPCMD / January 2, 2006 6:27 AM PST

Thanks for sharing your solution and I certainly agree that some of the USB stuff just isn't ready for prime time.

RE your statement 'remove all peripherals ANDm importantly, remove the power supply.'

Do you mean disconnect (vice physically remove) peripherals as in internal and external drives (data and power) and remove any cards from the MB, etc.? Physically remove PS or just discomnnect it from MB and or remove the AC power cord ?

Do you get a lot of question about getting into the case on getting everything back together ?


Collapse -
This really does work!!
by Boss_Hogg / January 15, 2006 7:35 PM PST

Had the exact same problem, suddenly the computer would not recognise ANY mass storage device - Mp3 player, PSP, ect.

I just unplugged everything from the back of the computer and left it over night. No need to mess around inside the system, just took out all the leads.

Hey presto, all back to normal in the morning!

Thanks Heaps !!!!

Collapse -
USB Ports gone
by PJKok / October 11, 2008 8:24 PM PDT

Had the exact same problem, suddenly the computer would not recognize ANY mass storage device - FreeAgent, SanDisk, Scanner, etc.

I also unplugged everything from the back of the computer and left it for a few hours. After startup I replaced the USB connections one by one - problem solved.

Collapse -
by mattbatt / December 3, 2009 12:41 AM PST

thank you we need to give this solution some more google juice it took me forever to find it.

Collapse -
by LDP27 / February 22, 2010 10:12 PM PST

wanted to let you know this worked for me as well

Collapse -
Thanks! It Worked
by TheCHIMP / November 25, 2008 6:21 AM PST
In reply to: Something you can try

HP 6110 All In One
Running on XPSP2
Suddenly showed up as a non recognized USB Device

Thought it was because I tripped over the cable and knocked out the USB cable from the machine and might have damaged the port. But it wasnt.

As stated, deleted the HP from hardware. Rebooted laptop, printer automatically showed back up. Thank you!

MG in LA

Collapse -
I seem to have a problem native to the device itself
by MarketStEl / January 3, 2010 1:31 AM PST

I purchased a 4GB PNY flash drive about three months ago. Up until last week, it functioned OK even though it would constantly open when I carried it in my pocket.

Last week, it got bent while in our laptop computer's USB port. The plug will still snap closed, but I sometimes have to pry it out of the enclosure. And for about four days now, when I plug it in the USB port of our laptop (Windows 7), I hear the sound that indicates the computer recognizes the device, but the device doesn't appear in the list of removable media. When I plug it into the desktop PC (WinXP), I see the removable drive in the list of drives, but when I click on it, I get the message "Please insert a disk into drive [letter]:"

Any way to recover what's on this disk?

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions

The Samsung RF23M8090SG

One of the best French door fridges we've tested

A good-looking fridge with useful features like an auto-filling water pitcher and a temperature-adjustable "FlexZone" drawer. It was a near-flawless performer in our cooling tests.