Samsung forum

Question

USB firmware upgrade failed for soundbar

by rajmohan1978 / December 30, 2015 5:46 AM PST

I have HW-J551. Download the ROM file from samsung website. downloaded to USB thumb drive formatted in FAT32. When connected to soundbar, soundbar display NODATA. Not able to upgrade. Required some of your help.

Discussion is locked
You are posting a reply to: USB firmware upgrade failed for soundbar
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: USB firmware upgrade failed for soundbar
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
Follow Inst.
by Highland_Logan / December 30, 2015 7:37 AM PST

Along with the firmware (correct countries site I assume), did you also look at the PDF instructions on how to put this file onto your USB drive?

Collapse -
Clarification Request
Same issue here
by brandonsbillingham / January 1, 2016 8:07 AM PST

Having the exact same issue as you! Any luck yet?

Collapse -
Clarification Request
Whats wrong with
by itsdigger / January 4, 2016 10:12 AM PST

the soundbar ?
Why does the firmware need to be upgraded?

All Answers

Collapse -
Answer
Re: No data
by Kees_B Forum moderator / December 30, 2015 5:55 AM PST

My guess is that this means that there is no sound file on the stick. The ROM probably only is recognised in firmware upgrade mode, which of course is quite special. What does the user manual say about doing a firmware upgrade?

Compare with a PC. If you have a BIOS-update on a diskette or a USB-stick and insert that, the PC won't go and do a BIOS-update on its own when it's in Windows. You have to start that somehow.

Kees

Collapse -
Nope
by jbirge / January 3, 2016 8:38 PM PST
In reply to: Re: No data

According to the Samsung website, there is no special firmware upgrade mode, and the system will automatically install a proper firmware ROM file on an otherwise empty USB key. I've tried following the instructions and couldn't upgrade the firmware, either, on the same soundbar. If I had to guess, I'd say that it's very difficult to get a ROM file on a USB without the OS (either Windows or Mac) writing other hidden files to it, which the sound bar then has a problem with. Either that, or Samsung simply screwed up either the instructions or the ROM file name.

Collapse -
Same problem
by Chris Gaunt / January 4, 2016 10:00 AM PST
In reply to: Nope

I cannot get it to work either, I have re-formatted the USB stick every way possible and still it says 'No Data' !!

Collapse -
USB firmware update on HW-J551
by Chris Gaunt / January 4, 2016 10:06 AM PST
In reply to: Same problem

....Or I get 'Read Error' .... I actually can't get it to read a USB stick, tried several too !

Collapse -
Call it in. 1800SAMSUNG in the USA
by R. Proffitt Forum moderator / January 4, 2016 10:22 AM PST
In reply to: Same problem

Samsung.com for other contacts.

Some older models only support small (1GB?) sticks and FAT32 only. BUT and I stress this I've never had to update the firmware on sound bars out of the box. I've lost count of folk that have a failed bar and then try to update firmware. Nope.

Collapse -
Call it in
by Chris Gaunt / January 4, 2016 10:44 AM PST

Fair enough, the smallest USB stick I have is 4gb. Maybe I shouldn't be wasting my time trying to update it, I only got it last week, kinda whish I hadn't looked for updates ! ...but it's sort of thrown down the gauntlett so to speak and challenged me to get it done !!

No idea what the upgrade will bring to the party anyway ??

Cheers for the reply !

Collapse -
Point taken...
by jbirge / January 4, 2016 2:11 PM PST

Normally I wouldn't take the risk of screwing with firmware, but the sound bar has been cutting out occasionally. I'm not sure it's the soundbar or the TV, but the soundbar has outstanding firmware upgrades so that's what's getting my attention.

Collapse -
Cutting out here as well
by brandonsbillingham / January 8, 2016 3:32 PM PST
In reply to: Point taken...

Same issue here which is why I want to do the firmware update. I'm also having issues with the audio going out of sync with video, are you?

Collapse -
Also same problem
by GLBBend / January 10, 2016 11:51 AM PST
In reply to: Same problem

Getting the same "nodata" displayed on j550 soundbar. FWIW, I updated the firmware when I got the unit the end of November 2015 and it worked perfectly (you could tell because it showed a percentage progress on the display.) But the latest firmware dated December 30 2015 just won't work. I am doing everything as instructed and exactly as I did before. After seeing this thread I suspect a corrupt file or file name on Samsung's part.

I am experiencing occasional failure to mute. I have to hit the down volume once and then mute will work.

Collapse -
Sounds defective.
by R. Proffitt Forum moderator / January 10, 2016 11:59 AM PST
In reply to: Also same problem

I take it's new so repack and return as defective due to the have to hit the other button before mute. Seems cut and dry to me.

Can't seem to figure out why companies ship products with defects. Only way to stop that is returns.

Collapse -
J550 firmware RESOLVED
by GLBBend / January 16, 2016 1:57 PM PST
In reply to: Sounds defective.

Update January 15, 2016. I did pack it up and take it back to BB for exchange for same model. The new unit upgraded the firmware (v.1010.0) with no problems. So far no problems with failure to mute, but it was very intermittent on the original, so we'll see.

Collapse -
Answer
Same here too
by anonymous_user_1 / January 6, 2016 11:16 AM PST

I am undergoing the same problem as we speak. I downloaded the firmware update (unzipped .ROM file) and saved in the USB thumb drive root directory just like the instructions say.

Tried it twice with two different USB drives - got same NODATA error.

Contacted Samsung and they mailed me a USB thumb drive with the file on it.

Same error.

Contacted them again.

They are resending another USB drive with file.

I will let you know how it goes in a week or two.

They said after this step they would escalate.

Customer Service seems pretty good to me.

Collapse -
Glad your chasing
by brandonsbillingham / January 8, 2016 3:33 PM PST
In reply to: Same here too

I tried to email them today but they're seems to be an issue with their website at the moment. There must be something wrong with the ROM itself, what's annoying is I can't find out how to see which Firmware I have or where to download previous firmware versions.

Collapse -
Answer
Simple fix guys.
by D_Vin_Gado / February 10, 2016 11:56 AM PST

The problem is that the sound bar is not reading that it is a .ROM file. This is because when it is extracted, the file name has a period in it. Example: HWSB-J551-1010.0.ROM. Remove any periods in the filename and your good to go. Not sure why Samsung software engineers didn't pick that up. Basically you can rename the file to whatever as long as there are no periods in it except for the one right before ROM.

Collapse -
No luck
by brandonsbillingham / February 14, 2016 4:51 AM PST
In reply to: Simple fix guys.

Tried that and it didn't work. Still claims no data.

Thanks

Collapse -
Soundbar ROM update fix
by Chris Gaunt / February 14, 2016 9:01 AM PST
In reply to: Simple fix guys.

Exactly as you said ; D_Vin_Gado, if you remove the period from the filename (i.e. HWSB-J551-10100.ROM ) then apply it, all is fine and the soundbar can read the update file.
Still not sure if there is any benefit, as mine was working ok anyway. Thanks for the comments everyone.

Collapse -
Yep. Fixed it! Thanks
by Darkbob2 / July 2, 2016 7:56 PM PDT
In reply to: Simple fix guys.

Worked perfect. I renamed:

HWSB-J551-1010.0.ROM

To

HWSB-J551-10100.ROM

(Notice one period I removed?)

And it worked perfect. Not sure what the update really does... but at least the update went in now. It started counting up percentages, got to 100 and rebooted.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

Does BMW or Volvo do it best?

Pint-size luxury and funky style

Shopping for a new car this weekend? See how the BMW X2 stacks up against the Volvo XC40 in our side-by-side comparison.