Storage forum

General discussion

USB drive 'Unknown Device'

by smash / December 1, 2004 9:55 AM PST

Hi I just got a new Creative Muvo MP3 player and my computer won't recognize it as a portable hard drive. I'm running XP Service Pack 1 on an Athlon 1.7GB.

When I plug it in it recognizes a 'USB device' ---> and the new hardware icon pops up. Then it labels it an Unknown Device and that's that. There ARE NO DRIVERS for this MP3 player - it's suppsoed to be recognized by the PC automatically.

I tried the player on my roommates' computers - both worked 100% [one is running XP, other is running ME]. So it's definitely something to do with my PC. What's going on?! All my other USB devices are working properly! HELP I am all out of ideas - I checked Device Manager, BIOS, etc...

Discussion is locked
You are posting a reply to: USB drive 'Unknown Device'
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: USB drive 'Unknown Device'
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: USB drive 'Unknown Device'
by R. Proffitt Forum moderator / December 1, 2004 9:58 AM PST

1. Does it work on other machines?
2. Did you install the latest motherboard drivers?
3. USB 1? 2? 2.5? other? Hint: I ran into that exact message on USB 1.1 ports. The poor soul really wanted it to work on USB 1.1, but it never did.

Bob

Collapse -
Re: USB drive 'Unknown Device'
by smash / December 1, 2004 10:22 AM PST

THANX for the tip but I figured it out. Apparently completely uninstalling your USB Hubs & Controllers helps. Works like a charm now!

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

Does BMW or Volvo do it best?

Pint-size luxury and funky style

Shopping for a new car this weekend? See how the BMW X2 stacks up against the Volvo XC40 in our side-by-side comparison.