Storage forum

General discussion

usb drive not recognized by explorer

I have the same problem, my 80gb Western Digital USB drive is recognized by Disk Management but not "My Computer". I have Windows XP. Do you know where the "systems properties" equivalent is in Window XP?

Discussion is locked
You are posting a reply to: usb drive not recognized by explorer
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: usb drive not recognized by explorer
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re:usb drive not recognized by explorer

In reply to: usb drive not recognized by explorer

I note the same symptom if I plug mine into the USB 1.1 port rather than USB 2.0. Go figure.

If you press Start, Help and Support, it has where that item is.

Bob

Collapse -
Re:Re:usb drive not recognized by explorer

In reply to: Re:usb drive not recognized by explorer

My Dell PC only has USB 1.1. The Western Digital USB 80bg drive I'm trying to install is USB 2.0 but is "backwards" compatible. When I first installed out of the box everything worked, drive letter was assigned (I didn't put any data on it). Then I unpluged it without EJECTING HARDWARE (as I should have). Then when I plugged it back in, the plug and play recognized it, added it in device manager but "My Computer" now didNOT recognize it.

Since then I've uninstalled all usb hubs/drivers etc in SAFE MODE, restarted Windows XP, plug and play recongnizes all my devices again, but now gives me a message when I attached my USB Drive - "HI SPEED USB Device added to non-hi speed usb" and "Problem with install device may have problems" and now the USB Drive doesNOT show up under Disk Drives in Device Manager and under USB Controllers, there is a yellow exclamation point. I have SP1 and all updates to WindowXP. Enough info?

Thanks for any help!

Collapse -
What they say works vs. what really does.

In reply to: Re:Re:usb drive not recognized by explorer

You can take my word that this rarely works.

I have found no cure for this behaviour besides installing an USB 2.0 PCI card. At least such is cheap now.

Bob

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.