Computer Help forum

General discussion

USB Cannot Detect Thumbdrive

by witprob / April 19, 2008 9:13 AM PDT

USB port can detect mouse and keyboard but cannot detect thumbdrive.
What is the problem and how can I solve it?


Discussion is locked
You are posting a reply to: USB Cannot Detect Thumbdrive
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: USB Cannot Detect Thumbdrive
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Need More Info
by Darton Fury / April 19, 2008 9:19 AM PDT

What operating system, computer, thumb drive????

Collapse -
Need More Info - Answer
by witprob / April 19, 2008 4:13 PM PDT
In reply to: Need More Info

Window XP Pro
Thumbdrive - Kinston & Apacer

Collapse -
In addition to what Darton asked ...
by Edward ODaniel / April 19, 2008 11:27 AM PDT

have you tried other USB ports and does the thumb drive get recognized on other computers?

Collapse -
by witprob / April 19, 2008 4:15 PM PDT

Tried other USB ports - same problem
Thumb drives recognized on other computer

Collapse -
Since it works on other computers ...
by Edward ODaniel / April 20, 2008 9:26 AM PDT
In reply to: Reply

and I am assuming no external USB storage media is showing up go to Start->Settings->Control Panel->Administrative Tools->Disk Management with the drive in the computer and see if there is a drive letter associated with the thumb drive. If not, assign a drive letter.

Alternate method - Right click on "My Computer", click Manage, click on disk management, locate your thumb drive, right click and choose assign (or change) a drive letter. If it already has a drive letter, give it a different one as it?s already in use.

You should now be a "happy camper" with an available for use thumb drive.

Collapse -
same problem,different situation
by xetoxgarshiz / May 3, 2008 4:00 PM PDT

Hi, mind if I ask you? I have 4GB Kingston DataTraveler n I've plugged it in various home,at cyber cafe, but it still cannot be detected. What's the problem with my thumb drive?

Hope to get replies from you.Thank you

Collapse -
Try reformatting it.
by Dango517 / May 3, 2008 4:47 PM PDT

If this doesn't work get a new one. (Hope you've made backups.) If it still doesn't work...Are your drivers for the USB ports and controls current? Check them in Device manager under "Universal Serial Bus controllers", right click on everything with USB in it and choose update driver. Is your PC due for a bios update? Check your PC manufactures web site for a BIOs update, some system BIOs can be obtained here:

If it still doesn't work your mother board maybe bad. Does it have other problems? If so then take it to a local PC repair shop and have them look it over. If not then this might fix it. (No guarantees from me. Use these suggestions at your own risk.):

This is not an endorsement, just some examples. Study the specifications carefully and get the right one. I'll leave that up to you. You needn't be a P.H.D. in computer engineering to do this but it may take some of your time to get it right. You might learn something in the process.

Collapse -
Kingston 4G DataTraveler seems "temperamental"
by Ol Rod / May 4, 2008 6:57 AM PDT

I have one of them. It seems to work with some OS and not others. It is usually ok with XP, I have an Apple Tiger OS X, always works there, but some older windows can't "see" it. By comparison, I have couple of PNY Attache 2G which just "work" on everything I try them on. Your problem may be that Kingston Flash Drive.
P.S. I'm not any "guru" just play with computers at home.

Collapse -
Kingston 4Gb Datatraveler (DTI/4GB) Problem
by xtekm / August 29, 2008 12:06 AM PDT

I've also recently got one of these, and it works fine on the WinXP Pro @ work, Vista x86 on notebook, but fails to work on two different PC's (1xQuad Core Intel, 1xDual AMD 939) both running Vista x64 (it actually hangs the Vista that I have to do a hard reset).

The 8Gb Traveller seems to work flawlessly, but the 4Gb seems to be a problem.

I've also noticed that the 8Gb formats really quickly (in seconds), yet the 4Gb takes about a minute...

Collapse -
Kingston Datatraveller problem
by Bhutanmen / July 10, 2010 5:32 PM PDT

I have the same problem with my Kinston thumbdrive 1 GB. I used it less than 1 year. When I connect to office computer, I lost all my data & it ask formatting. When I formatted, it is said failed to format & I can't use my thumbdrive & lost my important files. When I use DDR Pendrive recovery, it said "cannot repair".

Collapse -
If you read other posts like this.
by R. Proffitt Forum moderator / July 10, 2010 5:56 PM PDT

You find that recovery is rare. It's why someone should have backup copies.

Collapse -
USB thumb drive not detected
by busty3 / November 27, 2011 11:44 PM PST

I know this is a late reply but I also had the same problem with a 16gb thumb drive. It would not be recognized by any computer I tried. That's five of them with xp and some with win7. I didn't know what I did to the drive and it was fairly new. I decided to take it apart which I had done with a previous one years ago out of curiosity. With this one I ran a magnet over it. I had done this with something else in the past and it worked so I thought what the heck I've got nothing to lose. Low and behold my 16 gb drive was restored and works with no problem. Don't ask me why. Perhaps I had it in my pocket near a magnet in the first place and it screwed it up. Now it works. What have you got to lose? I thought i'd pass this on for people with the same problem it just might work for you too.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


iPhone 8: Everything we know so far

This is all the iPhone 8 reports and rumors in one place. From a 5.8-inch OLED display, reports of wireless charging and even a 3D scanner for facial recognition, it's all here.