Computer Newbies forum

General discussion

USB 2.0 Flash Drive / Windows can't find driver

by Shirley R / April 10, 2005 11:54 AM PDT

HP 6630, W98SE, 64MB RAM. I purchased a new computer and I am trying to copy files from this computer, HP6630, to my new one. I purchased a PNY Attache', USB 2.0 Flash Drive to copy and transfer files, but I can't get Windows to locate the driver. I downloaded the driver files from PNY'S web site and followed their instructions, but Windows keeps telling me that it is unable to locate a driver for this device.

I opened Device Mgr. and under "OTHER DEVICES" it shows "a YELLOW question mark, and USB Disk25X" which is the device for the Flash Drive. When I click on "Properties" it states that the driver is not installed (code28). I clicked on "reinstall driver" and selected C:\program files\PNY\attache 2.0, and I keep getting message that Windows is unable to locate driver.

I went to PNY's web site for support and one of the FAQ's said to check in BIOS to see if "USB controller option" is enabled. Well I rebooted PC and got into BIOS but was so confused as to how to find this out I exited.

Can anyone give me step-by-step instructions to check if the USB controller option is enabled, and any other help to get this driver installed?

Thank you.

Discussion is locked
You are posting a reply to: USB 2.0 Flash Drive / Windows can't find driver
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: USB 2.0 Flash Drive / Windows can't find driver
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Meanwhile back at bios...
by Willy / April 10, 2005 12:37 PM PDT

"went to PNY's web site for support and one of the FAQ's said to check in BIOS to see if "USB controller option" is enabled. Well I rebooted PC and got into BIOS but was so confused as to how to find this out I exited."

Goto the bios area again and find a listing for "pheriphals" or similar. If you can't find, then toggle through the listing until you find a "USB" option, then enable it or verify what it is. If you have no other current or never used a USB device, like a camera or kybd. then you problably never had it turned "enabled", so check it. Make sure to "save" before exiting the bios, then reboot. Hopefully, you should see USB available now. You don't need a USB driver for winMe, W2K or XP os, but do for win95b/98 from the PNY vendor. Undersatnd also, if you have an old system you may not have a USB 2.0 port but a USB 1.1 port, but that won't be a big problem just slow down transfer abit. Make sense?

tada -----Willy Happy

Collapse -
BIOS--still can't find it (:
by Shirley R / April 10, 2005 1:28 PM PDT

Hi Willy:
I went into BIOS and couldn't find USB or pherpiphals. At the top there is: Main, Advanced, Power, Boot & Exit. I went to each one of them and couldn't find USB or pherpiphals. I guess I'm just a dummy. I don't have any other USB devices on this PC so I probably do have to enable it. Just wish I could find it.

Thanks for trying.


Collapse -
Just what is your system? model, etc.
by Willy / April 10, 2005 11:09 PM PDT

That info is needed to further your quest. Its possible you have an old system and *NO USB* is present. If that's the case, you then need to buy a PCI card with USB ports in order to install USB capabilities. -----Willy

Collapse -
Alternatives to a USB-key.
by Kees Bakker / April 10, 2005 8:48 PM PDT

You might not like them, but they will work.

1. Buy an network card and a 'crossed' cable and install a small home network (that is all you need for it). Then transfer all your files using Explorer.
2. Install a CD-burner in your old computer, and burn all those files on it.

If you tell the name and version of the BIOS (it should be in the upper left corner of the screen first thing at boot, or maybe somewhere in the BIOS-screen also), somebody might be able to tell you where a possible mention of USB is on your machine.

Hope this helps.


Collapse -
USB devices.........
by TONI H / April 10, 2005 9:39 PM PDT

This is from the PNY website:

To install the Windows 98SE driver, follow the step by step procedure to guide you
through the process.
1. DO NOT plug/insert your Attach

Collapse -
Toni, you were correct, but
by Shirley R / April 11, 2005 11:29 AM PDT
In reply to: USB devices.........

OK, I did install the incorrect driver initially. It was for w98SE, but i picked the incorrect amt. of MB's.

I followed your/their instructions to a "T" and when I rebooted, and inserted the PNY device NOTHING happened.
I went into Device Mgr. and the yellow question mark was there again.

My BIOS is Phoenix Technologies LTD l.06, dated 11/15/99.
I have two external USB ports on the back of the PC.

Do you think I need to "enable" USB in BIOS? If so, can you tell me how to do this? As mentioned, I went into BIOS, but couldn't find anything.

Any help will be greatly appreciated.

I'm ready to give up and return the blasted thing.

My PC is a HP6630, purchased Jan., 2000. 64MB RAM,
10.2 GB Hard Drive, W98SE.

Collapse -
In the BIOS on my Soyo
by Ray Harinec / April 11, 2005 12:11 PM PDT

it is in the section of the BIOS called features setup. Not likely to be the exact same name for the section.

One problem with proprietary systems such as yours, the BIOS that they allow the user to access is often very limited.

But somewhere in one of the sections of the BIOS the should be a place to enable the USB controller. Your new memory is probably USB 2.0 but the computer is likely only 1.1 but it should still work fine, just a little slower.

I don't know about a computer as old as yours, but I was impressed by the amount of support information available at the HP website. If you have the model number and serial number there is a wealth of info. I know its out of warranty, and I don't know how much they charge for a tech support call, I would gather the info and consider paying for the call. It should only take a minute to get the answer.

I would download the manual, but knowing how little info they provide in the manual it probably be a waste of time for me. I had talked to them about a friends computer under warranty and the person that I got was great. I didn't have her computer handy, but told him I understood them and we simply discussed what to do to accomplish what I wanted. He might have been in India, don't know for sure but he had no accent and was easy to understand.

I would be happy to call them for you. If you want you can email via my profile with all the info. Maybe I'll ask you what the new computer is that you bought. LOL Emailing via my profile does not give me your email address. it is a one way deal.

Collapse -
Here's a link to hp
by Ray Harinec / April 11, 2005 12:35 PM PDT
Collapse -
Shirley, did you before doing anything else
by Ray Harinec / April 11, 2005 12:56 PM PDT

go up in safe mode and go into Device Manager and remove ALL instances of the USB controller and the root hub et al. Must remove each independently. When they are all removed, and there are no USB devices of any type plugged in, reboot. Hopefully Windows will detect new hardware [the USB controller} and give you the opportunity to install your drivers. I'm not sure that this will work, but if Windows detects the new hardware, it would seem logical that they are enabled, possibly by default.

I see nothing at the HP site that mentions enabling, nor mentiong USB in the BIOS.

Possibly a call to them could save a lot of grief.

Collapse -
(NT) (NT) Yes, tried that, too. Didn't work.
by Shirley R / April 11, 2005 1:42 PM PDT
Collapse -
Qucik check...
by Willy / April 11, 2005 2:07 PM PDT

Going furthere using the HP link ray provided, try this:

Hopefully, \that provide other clues to resolve your problem. While the link Ray posted offered help on a HP6630, it was generic and it so happens there wasn't anything listed as USB in the "advanced" bios section but it makes sense to be there. Be aware to go through all listing as not all get posted initially on the first display under advanced(maybe), toggle down the listing as more maybe there. Since, I have no HP6630 to quickly to refer, you got the ball.

tada -----Willy Happy

Collapse -
The USB is working!!!
by Shirley R / April 12, 2005 7:05 AM PDT
In reply to: Qucik check...

I gave up on the Attache'. Either I installed the wrong driver or it was defective. In any event I returned the new computer to Best Buy. After reading the specifications, it was produced in March, 2003 and all of the software was outdated, and the rebate forms were driving me crazy. In my estimation, it wasn't worth the $300. If I forgot to "dot an i" I probably wouldn't get the rebates.

I did purchase a HP Deskjet 3745v printer from Walmart with a USB port and installed it to my old W98SE, HP6630, and it is working perfectly, no errors!

So, like I said above, either the Attache was defective or I installed the wrong driver again, but I don't think so.

I am happy with my W98SE and new printer for now, but I will keep looking for a new PC and a way to convert my files to it.

A very big thanks to all of you. I really appreciate all of the time you spent trying to help me.


Collapse -
I had a feeling your USB ports were enabled
by TONI H / April 12, 2005 8:17 AM PDT
In reply to: The USB is working!!!

or nothing would have showed up in Device Mgr re: the attache......not even with yellow marks.

Now.....if you can get your hands on a cdrw burning device, and a few cdr disks, you could actually burn all your stuff to cd and have loads more room on that cd for your files than any keychain device will give you.......for alot less money spent. DVD-cdrw devices (a dvd reader only with a cdrw which gives you 700MB of space or even a dvd-rw which gives you over 4GB of space) will hold a massive amount of data files and can be found for less than $50 now compared to the couple of hundred they cost just a year ago.

That would be the route I would take. If your system already has a burner device, you're already in business.


Collapse -
Tks. Toni, for info on CDRW'S
by Shirley R / April 12, 2005 12:50 PM PDT

If I understand you correctly, I should purchase an external CD-RW, and a few CD-R's. My system doesn't have a burner device.

Now, how do I connect it to the PC, or will it have instructions? Does it need a special port, like the USB? I still have one USB port, and a parallel port, and a few others back there.



Collapse -
No room for an internal burner?
by Ray Harinec / April 12, 2005 3:00 PM PDT

Do you have an unused IDE port. Your system should be able to support four IDE/ATAPI drives. CD-ROMS and burners are called ATAPI drives, or optical drives among other things. LOL

There are two IDE ports [controllers], each can have a Master and a Slave drive on them [uses the ribbon cables]. The floppy drive is NOT an IDE drive.

Toni is finally getting her website back up. It is basically all technical info and tips regarding computers. She is still loading the data for a lot of the pages but is finally getting there. It's URL is

Collapse -
I forgot the www. in front of pcwarfare but
by Ray Harinec / April 12, 2005 3:05 PM PDT

the link still worked. LOL

Collapse -
Externals are three times the money
by TONI H / April 12, 2005 8:28 PM PDT

If I'm shopping for good prices, good quality, and great tech support, including returns if necessary...this is where I shop. To me, they are the best of the best for computer stuff...

Here's a link to the page with various internal burners....they are in the low $50 range. Internal burners fit into an empty 5-1/2" bay (you just remove the cover plate and slide them into place from the front of the computer), jumper it first as a slave, then hook it up to the power connector inside the computer coming from the power supply (just like the harddrive has), and either connect it to the middle connector on the gray flat cable that has your harddrive on it, or hook it to its own gray cable (you might have to buy one for about $6 unless the drive comes with one as they usually do) and connect the other end of the cable to the motherboard in the Secondary IDE connector position.

The drive should also come with four tiny bolts to mount the drive to the frame of the bay.

As you boot up, the bios will detect it, and windows should spot it immediately and install it as new hardware without even telling you via a 'found new hardware' window......check in Device Mgr and you'll see it in the CDROMS listing or My Computer on the desktop.

Most of the drives purchased from newegg also include the Nero software for burning so you don't even have to buy that extra.....


Collapse -
by Shirley R / April 13, 2005 4:21 AM PDT

Tks very much for replying. I know you are busy setting up your web site & appreciate your time. If I install an internal burner I would have to take it to Best Buy because I am not knowledgeable enough to do this myself. (:

I visited your web site and it is looking great. I used to visit your old one and was disappointed when you had to shut it down. Glad it's back, and I'm sure a lot of other folks will be also.


Collapse -
Best Buy
by TONI H / April 13, 2005 5:30 AM PDT
In reply to: Toni:

might be able to get you a good sale price on the burner since they'll be doing the install, too.....give them a call first to find out.

Thanks for the kind words about the site. There's lots to do on it now that I got some of the components working right after a week of pulling my hair out....been creating new pages all day today already so more will be going up every day.

Give a holler here anytime you need help, Shirley...we're all friends who help friends, but if you've been around this long, you know that already.


Collapse -
OK, Toni, will do. BTW
by Shirley R / April 13, 2005 10:19 AM PDT
In reply to: Best Buy

I particularly liked the CTRL & mouse feature on your web site to enlarge the text. Really neat!! I never saw that before. Happy

Take care.

Collapse -
(NT) (NT) Good for you, enjoy...
by Willy / April 12, 2005 9:56 AM PDT
In reply to: The USB is working!!!
Collapse -
(NT) (NT) Tks.Willy,
by Shirley R / April 12, 2005 12:53 PM PDT
Collapse -
Attache 2.0 FlashDrive
by ViolaJoan / May 10, 2005 5:20 PM PDT

I just wanted to say, I also purchased an Attache 256 M
USB 2.0 Flash Drive and I am having exactly the same problems as you are in looking for the driver to install it on my home computer. I am still figuring out how I can get mine to work, and will let you know if I find anything. Best of luck, Joan

Collapse -
I have a Attache, needed a driver for Windows 98
by glb613 / May 10, 2005 7:58 PM PDT
In reply to: Attache 2.0 FlashDrive
Collapse -
by glb613 / May 10, 2005 9:48 PM PDT
Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.