Question

Updating rooted Galaxy S3

I rooted my Galaxy S3 when I first got it, and it's been fine ever since. The only problem so far is that I received an update notification saying there was an update for Android. I downloaded it and tried to install it, but had a problem when it restarted to install. It went to the screen that it gives when you first root (the one where you pick the rooting package and get it to install). Then it shows the Android robot dead. Fortunately, restarting again allowed it to revert back to the way it was. But how do I update the software?

Discussion is locked
Follow
Reply to: Updating rooted Galaxy S3
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Updating rooted Galaxy S3
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Back to where you got the root from.

And ask them how to un-root the phone. I've found too many do this and then turn the device into a brick or forgot that not only can you root, but you must be ready to un-root the device.
Bob

- Collapse -
So...

You're saying that I need to un-root first in order to install the update? If I do, can I root again right away? I also am curious as to what this will do to apps that require root access. Will they be okay as long as I don't use them?

- Collapse -
What apps need root?

Sorry I can't answer either question as I don't do roots or have apps that need such. The folk that gave you this root should step in.
Bob

- Collapse -
Hmm.

What these will do is, that if you unroot your S3, The phone will restart or respring, (i guess) after that if you try to go to that application, it will say that your phone does not have root access.
(Tried and tested) with the application- Root explorer.

http://www.youtube.com/watch?v=TEsBwtqY2xE

This is a link of how to unroot^.

Make sure to check out my blog- http://techisalwayscool.blogspot.in/

CNET Forums