Windows Legacy OS forum

General discussion

Updating a bios on an old PCChips mobo

by TONI H / January 13, 2008 6:46 AM PST

The mobo is still good but was getting a BIOS ROM Checksum Error at bootup, then it would go to Reading A: drive, insert system disk and press Enter

After doing a google search discovered that I would need to update the bios....got the correct file for the board and the newest flash utility, and am doing it now.

But it's been so long since I've done a floppy disk bios update, I can't remember about how long it normally took....Anybody got any ideas?

TONI

Discussion is locked
You are posting a reply to: Updating a bios on an old PCChips mobo
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Updating a bios on an old PCChips mobo
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Generally less than a minute
by Steven Haninger / January 13, 2008 7:50 AM PST

has been my experience. BTW, I had a similar problem that I thought was just the battery. Battery replacement didn't help. Reflashed with the same BIOS (already the latest) and it worked. Don't know why.

Collapse -
OK...I need some bones tossed at me please
by TONI H / January 13, 2008 8:44 AM PST

I turned off the computer after an hour and a half of looking at the "please wait" message. Rebooted, same error

AMD BootBlock V1.0
BIOS ROM checksum error
Reading Drive A:
Insert system disk and press Enter

I tried unplugging the floppy drive from the mobo, rebooted, and got a slew of beeps, message showed up Failed to Read Drive A:/System Halt

Plugged it back in, used the W98 bootdisk and got back to the A: prompt, but I also noticed this time that it's reading the drive as 732MB instead of 1.44 when I do type in any command on any disk I put into the drive.

I don't know how to find the original BIOS version on the install cd I got with the mobo....I can find the awd822A.exe file which I'm assuming is only the flash utility and not the bios since that would be a 'bin' file, correct? I also looked on the cd and found the winflash.exe/winflash.sys files but they can only be run in a windows environment.

I have tried resetting the CMOS on the mobo....no go

I haven't tried using a different video card...using an ATI-9000 AGP right now. Would that be the problem?

Been all over the net and everything indicates I need to flash the bios, but I'll be darned if I can figure out how to do it at this point. I've got the latest bios available for this board, and the latest award flash utility version.

Any help would be great since this board was working perfectly until I took it out of this case to build a system for my sister (whose mobo that she sent me is shot) and I put this board back into the case for her instead. It had the cpu/heatsink fan, and ram still installed on the mobo when I took it out so I didn't have to reinstall any of that stuff....

I have no harddrives and no cdroms hooked to the mobo right now and only one stick of ram for now on the board.

Any guesses, hints, clues, thoughts? Any and all bones tossed at me will be appreciated. I love a challenge and this one I'm sure will either make or break me. LOL

TONI

Collapse -
Not sure the age of the MB
by Steven Haninger / January 13, 2008 9:01 AM PST

But, for security reasons, I remember with some you had enable CMOS flash either in the BIOS settings or by using a jumper on the MB.

Collapse -
Without exact make and model and revision...
by R. Proffitt Forum moderator / January 13, 2008 9:42 AM PST

I can't find the right files to put on that diskette.

Collapse -
PCChips M811LU 3.51
by TONI H / January 13, 2008 5:08 PM PST

The following are the two files I was able to get from http://www.pcchipsusa.com The mobo wasn't listed in the archives list when I looked, but I did find files for the board by using the search at the top for M811

Flash utility: awd861a.exe
Bios update: M811M811.bin (after extracting the zip file download)

Something I should mention is that I originally had two 512MB sticks on DDR266/PC2100 ram onboard, but when I put the mobo back into the case, I removed mine and replaced it with two 1GB sticks of DDR400/PC3200 that my sister sent because I believed it was 'backward' compatible and when I got the error, the first thing I did upon shutting down was to replace the ram again with only one 512MB stick of DDR266 to see if that was the culprit. I've never been able to get the board back up since I put it back into the case.

I'm checking the mobo manual to see if I need to reset a jumper for the ram somewhere, but if I remember correctly this board only needed jumpering for the CPU frequency at either 100MHZ or 133MHZ, and nothing was changed regarding the CPU since it is still the same one that was still attached when I took the board out originally. I never swapped it out for her Sempron 3000 since mine is an Athlon XP.

Collapse -
Also...nothing in the manual
by TONI H / January 13, 2008 5:13 PM PST
In reply to: PCChips M811LU 3.51

about how to update the bios (at least not the paper manual I have for the board....I'll check the downloaded manual I got last night to see if there are any amendments to it. I'm going on the assumption that the bios isn't the chip type that can be easily removed and replaced by buying the new one, but rather the 'soldered' type that needs to be flashed via the floppy disk or the files wouldn't have been available for download, correct?

Sure would hate to kiss this board off because it really was a pretty good workhorse with lots of features I liked (like 5 PCI slots for one) and I believe it still could be if I could get beyond this stupid error.

Collapse -
Now this is interesting.
by R. Proffitt Forum moderator / January 14, 2008 2:19 AM PST
In reply to: PCChips M811LU 3.51

From http://www.tomshardware.com/forum/154732-30-chips-m811lu-syntax-sv266ad

"I tested all mentioned BIOS on an M811LU v3.1 and the only one that works properly is the K7VTA3(6.0) BIOS - not even PC Chips own m811811.bin BIOS works properly! Happy

ECS K7VTA3 6.0 BIOS - works perfectly + UDMA works (tested to UDMA 6 / 133)

PC CHIPS M811LU BIOS - M811811.BIN, UDMA is downgraded, AGP problems

ECS K7VTA2 Pro 3.1 BIOS - identical = exact same problems as M811LU BIOS, UDMA is downgraded

ECS K7VTA3 8.0 BIOS - flashes, but only boots once after clearing CMOS (incompatible) "

The M811811.BIN looks to be broken so go try the one they found to work?

Collapse -
Back to this PCChips board
by TONI H / February 4, 2008 2:26 AM PST

I downloaded the ECS bios update, got it to a floppy disk along with the flash program, but when I boot up the computer to the floppy drive, I get:

W98 boot disk working properly, no cdrom drivers installed (I've got the mobo on a board with a video card, ram, cpu/hsf, and the power switch to an empty case connected), and can get to the A: drive no problem.

But...when I try to type in the flash program name, I have nothing but all caps, including the numbers, so I'm unable to type anything to flash the bios.

I've tried a couple of different keyboards in case the first one was having issues, but it's the same no matter what keyboard I use, so I'm stuck here.

The floppy drive is only being seen as it boots up as 720MB but since I can't get access to the bios to begin with, I can't change that. Is that part of this all caps problem?

I also can't use the numlock keypad....it's dead in the water and when I try to kick the numlock into gear, it only moves the cursor forward on the line, just like the CAPS LOCK key does. Nothing in the number area above the letters works except as if the shift key was being held down. I've tried holding the shift key down as I type to see if that would reverse everything, but it still only types all in caps, including the numbers.

Any suggestions? Or is the mobo just nothing but trash now?

TONI H

Collapse -
Trash for now.
by R. Proffitt Forum moderator / February 4, 2008 2:46 AM PST

There are places that can replace the BIOS but that's as much or more than a new motherboard.

Collapse -
Two possible suggestions
by Steven Haninger / February 4, 2008 2:47 AM PST

First, is anything in the config.sys/autoexec.bat that might turn cap lock on? Can you make a DOS 6.22 disk? Lastly, can you create a batch file to run the flash program rather than typing the commands interactively?

Collapse -
nothing that would turn on caps
by TONI H / February 4, 2008 3:10 AM PST

but sure would like to know what I need to create a batch file to run it from the floppy disk...

The two files involved are

AWD865.EXE
a360707a.bin

I've never written (never had to) a batch file, and dumb as dirt about it...teach me LOL

If it works, fine...if it doesn't, I can live with tossing the mobo out the door with the cat.

Collapse -
Don't belittle yourself :-)
by Steven Haninger / February 4, 2008 3:27 AM PST

If it's one thing I've seen in your postings it's your tenacity. Actually, you can run the command from the autoexec.bat. It might take some trial and error as you won't know what the next prompts will be. You'd add the executable to the last line followed by the binary file using proper syntax. To find out those options you just type in the executable by itself and it will usually come up with a listing of what it understands. You can edit the autoexec.bat with notepad and save it. Now, if when you run it the first time it defaults to caps on the screen, I think you might be dead. It might work...might not.

Collapse -
Just a thought
by MarkFlax Forum moderator / February 4, 2008 3:51 AM PST

and excuse my ignorance.

Those two files, AWD865.EXE and a360707a.bin are just file names aren't they?

What if Toni were to change the file names to all caps and letters only, eg

AWD865.EXE becomes AWDXXX.EXE and a360707a.bin becomes ABCDEFGH.BIN

Is there any reason why that wouldn't work?

I expect to be shot down in flames...

Mark

Collapse -
Don't think you can change the binary filename
by Steven Haninger / February 4, 2008 4:11 AM PST
In reply to: Just a thought

The executable (flash program) is going to recognize the renamed file and declare it invalid. It could be worth a try, however. Generally you can create a backup of your old flash ROM and name it as you wish. I was looking for a way to enter the proper typed characters in an automated fashion rather than rely on a keyboard that's not functioning normally.

Collapse -
Good Grief
by TONI H / February 4, 2008 4:18 AM PST
In reply to: Just a thought

Talk about being brain dead here........thank you for that suggestion. I'm going to try that instead of editing the autoexec.bat file first.

TONI

Collapse -
HAHAHAHAHAHAH...no good
by TONI H / February 4, 2008 4:27 AM PST
In reply to: Good Grief

When I get to where I need to type in the ( . ) before the file extension it comes up as > instead. lol Back to the drawing board.

TONI

Collapse -
Do you have a numeric keypad that has
by Steven Haninger / February 4, 2008 5:28 AM PST

a period on the Del key? Try that.

Collapse -
I tried that, too
by TONI H / February 4, 2008 5:54 AM PST

and all that happened was it moved the cursor over a space like other keys would do.

Hopefully I have the problem fixed now....will let you know.

TONI H

Collapse -
Removing one stick
by AceCT-2214807889169935659 / January 19, 2008 1:00 PM PST
In reply to: PCChips M811LU 3.51

I am not familiar with this particular mobo but are you sure it can run with one stick of RAM? some mobos need 2 sticks or they go crazy.

Collapse -
update
by TONI H / January 14, 2008 2:03 AM PST

Appears to be a combination of two problems....

I found an identical PCChips mobo here along with the identical Athlon XP cpu already mounted on it. Hooked it up and got the same error....replaced the power supply with a brand new in the box one (500W), and it booted up to show the 512MB ram and normal 'insert system disk' message.

Noticed on this mobo that the CPU jumper was set for 100MHZ whereas the other PCChips board was jumpered for 133MHZ (and that system worked for quite a while with that jumper setting). As soon as I reset the jumper on this second PCChips mobo and rebooted, it immediately went to a BIOS ROM checksum error. I started sweating worried that now I had three mobos dead in the water....shut down, reset the jumper back to 100MHZ, rebooted and all was well.

I've rebooted after each change (one 1GB stick of DDR400 ram, then the second one, then took out the pci video card and replaced it with the ATI AGP board, connected all front panel connectors, connected the dvd drive, connected the Maxter 300GB harddrive)...and haven't seen that error since.

I'll be installing a dial up modem for emergencies (sister is on DSL right now), then install XP Home on it.

Actually disconnected the power supply from this mobo and using a cardboard box hooked it up to both of the other mobos and the PCChips board with the Bios Rom error still gives it and the FIC mobo that my sister sent to me with a Semprom 3000 CPU doesn't even power up enough to turn the fan on the power supply. Could be either the mobo itself or the CPU....will play with options on that later on.

Supposedly there is a tool called Award Detect or something like that that I read about in another forum last night, but going to Award's site and doing a google search for variations for that name turned up nada. It is supposed to be able to detect what bios you have and the version and also if it's in working condition...and gives options of how to 'repair' it. If anybody knows of that program or has it, can you lead me in the right direction to get it, please? It would come in handy for troubleshooting, I think.

Collapse -
autoexec.bat
by AceCT-2214807889169935659 / January 17, 2008 7:33 PM PST
In reply to: update

make sure u have the correct files on the floppy. you need the BIOS but you also need the files that make the floppy bootable.

Collapse -
Toni, Is this what you're looking for?
by PudgyOne / January 17, 2008 7:41 PM PST
In reply to: update
Collapse -
or this (same page)
by jonah jones / January 19, 2008 10:18 AM PST
In reply to: update

A much easier way to get the Award/AMI BIOS number & possible manufacturer is by using CTBIOS v1.5. Run it and it'll give you the BIOS number, possible manufacturer and more. If you want to know the name of your chipset you can also download ctpci330.zip.

.

Collapse -
PC Chips M811LU
by testguyct / February 4, 2008 3:01 AM PST

I am running this same board with a Duron 1600 CPU.

I recently updated the BIOS to the latest on the PC Chips web site: M811811.bin. The info below may be overkill, but I included the details for completeness.

I first went to www.bootdisk.com, and downloaded either the MS DOS 6.22 boot disk, or the Win98SE boot disk (I can't remember which). They also have a driver-free boot disk for BIOS flashing (I haven't tried it):
ftp://ftp.veracomp.pl/mirror/abit/pub/download/utilities/drdos/drdflash.exe

I ran the boot disk .exe file, inserted a blank floppy 3.5" disk in my drive A:, then waited for the boot disk to be created.

Once the boot disk was created, I simply put the M811811.bin file and the Award BIOS flash utility file awd16a.exe (located on the PC Chips website, on the same page as the M811811.bin file) onto the boot disk.

Before inserting the boot disk, I rebooted my PC, and went into the BIOS to make sure that the PC would boot from the floppy drive first. (Press DEL key while PC is booting to enter BIOS, then go to "Advanced BIOS Features", then change "First Boot Device" to "Floppy"). Then, I made sure that BIOS write protection was off - while still in the BIOS settings, go to "Advanced Chipset Features", and make sure that "BIOS Flash PROTECT" = Disabled.

Insert your boot disk, and press F10 key to save and exit BIOS. Once your PC reboots, you should be at the A: prompt. Type awd16a.exe, then enter the BIOS filename M811811.bin. That should do it.

I am running this firmware now, using Fedora 8 Linux. I have been using this motherboard for about 3.5 years now.

Good luck, and let us know what happens ...

Collapse -
OMG.....
by TONI H / February 4, 2008 5:27 AM PST

I did a google search for the "please updata rom bios first" as that came up when I was able to get to the actual 'insert file name' window for the flash. I came across this site/post and followed the instructions given, and WHAM.....the flash went through fine. I rebooted and actually had a normal post screen again right to the floppy

However, I have a CMOS checksum error (defaults loaded) now, so I will probably be looking at replacing the battery.

I'm going to attempt to get into the bios now and check things out, if I'm able. Onward and upward..........I hope

http://www.wimsbios.com/phpBB2/topic4211.html

TONI H

Collapse -
CMOS checksum error
by testguyct / February 4, 2008 5:50 AM PST
In reply to: OMG.....

Hi TONI H,

Pardon me if you have already done this, but have you replaced the CMOS battery ? Also, have you made sure that the CMOS jumper labeled JP1 on your motherboard is located on pins 1-2 ?

Collapse -
Checksum error is gone
by TONI H / February 4, 2008 6:48 AM PST
In reply to: OMG.....

I was able to get into the bios and set the time and date to the correct information, made a few passes through other areas just to check them out but made no changes, and saved/exited. The mobo has been booting up over and over (by me, not on its own) just fine now without any more errors. I'm a happy, happy camper.

Would have not been able to get this done without all the suggestions, links to the correct file to use for the update, and the encouragement given.

Tenacious Toni thanks you all very much.

TONI H

Collapse -
Ok, Toni the Tiger
by Steven Haninger / February 4, 2008 6:52 AM PST
In reply to: Checksum error is gone

GRRRRRRREAT!!! (news)

Collapse -
Now for the history
by TONI H / February 4, 2008 7:31 AM PST
In reply to: Ok, Toni the Tiger

of how this all got started....lol

My sister's mobo we thought was dying on a system I built for her a couple of years ago....lots of little quirky things were happening. She went to ebay and bought a FIC mobo because she would be able to reuse her cpu (amd 1.12GH) and her ram in it so she could cut down on her expenses. She never sent me the system to redo for her after she got the mobo a year ago.

Then she decided she wanted a faster cpu and more things (even though her computer was running okay with the quirks...floppy drive stopped working and the Primary IDE controller quit so she was able to switch XP over to the Secondary IDE controller and kept running)...so she started buying parts to update her FIC board and have me build her a second computer instead.

I got the parts here for that second computer when her first one stopped booting up completely...wouldn't even turn on....so she shipped it to me, too.

I managed to fix the first one pretty quickly with a new power supply and all the other quirks disappeared...things went back to working correctly again, including the floppy drive and the Primary IDE controller. I shipped it back to her and began working on the second system.

Put the FIC board into the case I had here along with the Sempron 3000+ cpu she bought, and couldn't get the darn thing to even post. Tried for the whole day trying different things and figured either the board or the cpu was shot but didn't take the time for much testing at that point. I pulled out the PCChips mobo I had that already had an Athlon XP cpu and hsf already installed on it but removed the Athlon XP and put in her Sempron to see if it would work on that board...and the proverbial sh.. hit the fan at that point. I got the errors when booting up that I posted here at the beginning of this thread.

Could never get going on it, so I pulled out another PCChips mobo I had with another Athlon XP cpu and hsf already installed on it...it booted up, but only after I clocked the cpu down on the mobo to 100fsb instead of the 133fsb that it was set for originally and actually WORKED with that setting. Figured good enough for the little bit my sister uses her computer for, finished installing everything and shipped it out of here. With 2GB of ram in it compared to 1GB in her other system that she is going to use as a backup and connects to the net with every so often in order to get her updates, she's still faster than the old system so she's happy.

Today, I grabbed her FIC board, popped in my Athlon XP that came off the first PCChips board that had a bios that was crapped out per my posts, and although it was sitting on a piece of plywood with a power supply, ram, cheapy video card and the power button from a handy case attached, it all booted up just fine. One down, one to go.

Now I grabbed the PCChips board that had been working at one time, popped in my sister's Sempron, hooked up all the other goodies and a floppy drive, powered up and kept my fingers crossed. The bios error came up again about the ROM crap, came back here, got the links to the ECS bios update file from Robert....tried that, go a new error in the flash program about 'please updata bios rom first' and did a google search on that error. Found the next link that I posted here about using uniflash.exe and a file that he created letting me make a 'new' awdflash.exe file from that information....

And here I am...

Now I have two motherboards and two amd cpu's and all four are working....two more computers I can give to grandkids. LOL

I'll NEVER build another computer for my sister again...this is the fourth one in less than 8 years, and I'm done even if I have to disown her. lol

TONI H

Collapse -
Favors for friends and family are a nice gesture
by Steven Haninger / February 4, 2008 8:37 AM PST
In reply to: Now for the history

but the expected service and support afterwards can be a headache. The only way I can deal with my own obsession to fix something is to, at some point, totally destroy it once it starts eating up too much of my time. I'd have broken that MB in half long before today. Wink

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?