Mac OS forum

General discussion

unlocking a jpeg

by novice22 / November 8, 2007 9:43 PM PST

this will be easy for you guys, but I'm a beginner

Am using a Mac, OSX (10.4.10), and can't remove a locked jpeg that I have transferred onto my desktop from a data plug. Every time I drag the icon into the trash, the message tells me it cannot complete the action as the file is locked. Naturally I don't know any passwords.

Have I really got to keep this file for ever?

Discussion is locked
You are posting a reply to: unlocking a jpeg
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: unlocking a jpeg
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
with the jpeg not active or open anywhere -
by boya84 / November 8, 2007 10:06 PM PST
In reply to: unlocking a jpeg

no application running to view it...

Click once on the offending jpeg. This will select it.
Under the "File" command line item, select "Get Info" (you can also press command I).
At the bottom of the "General" section, deselect "Locked".
Close that Info window, trash the jpeg.

Collapse -
perfect, thanks
by novice22 / November 8, 2007 11:22 PM PST

knew it would only be a matter of minutes...

Collapse -
You are very welcome.
by boya84 / November 8, 2007 11:49 PM PST
In reply to: perfect, thanks

I am presuming it worked... I am currently experiencing a similar issue on my Windows XP machine - but all the easy methods are not working. Drag to the trash in Windows is not working. Right-click Delete is not working. Changing various properties of the file makes no difference. I already have administrator rights on the machine. Trying to delete the file from a DOS command line prompt is not working. Neither is starting up in "Safe Mode" or a bunch of other things I have tried - or been instructed to do by the IT tech support folks.

I may have to live with this until I format the drive... which I just don't think is important enough to delete this file... But it does remind me daily why I spend my hard-earned money on my Macs at home.

Collapse -
unlocking a jpeg on a Mac
by fessora / November 12, 2007 1:11 AM PST

Like the previous 'Novice', I too am using Mac OS 10.4.10 and have a set of Jpegs that refuse to go a way. Every time put them in the trash I get a message saying it can't be done becasue they are 'locked'. I cannot find the Get info under the file menu and I tried '' -that had information for Windows users only.
They are driving me mad - please help!
yours fessora

Collapse -
answering my own query!
by fessora / November 12, 2007 1:48 AM PST

I finally found the 'Get Info'- I had been looking in Photoshop! I didn't realise that I had to unlock the jpegs without taking them out of the trash. I have now done it. Thanks anyway - I wouldn't have known about the Get Info and checking the 'locked' box without the forum.

Collapse -
by boya84 / November 12, 2007 2:58 AM PST
Collapse -
by 52Nash / March 29, 2008 7:16 AM PDT
In reply to: unlocking a jpeg

I'm also a beginner and this is a little different, jpegs are locked on flash drive I have done what was noted regarding choosing -"deselecting" locked/unlocked however; that portion is ghosted over I do not have that option to change, what is next move? Mac OS X 10.4.11 i Mac 5,1 Intel dual Core 2 Ghz Any helpp appreciated.

Collapse -
Flash drive
by mrmacfixit Forum moderator / March 29, 2008 9:02 AM PDT

if the above did not work for you, try this.

Copy everything from the flash drive to the hard drive.

Format the flash drive using drive utility. Format it MS-DOS

Put back the things you want from the HD to the flash drive, leaving the offending ones on the HD

Try the permissions tip with those items that you want to delete.

Let us know


Collapse -
by 52Nash / March 29, 2008 9:23 AM PDT
In reply to: Flash drive

reformating MS-Dos from above answer. I am sorry to ask but where do I find that, to do that, to make it happen? I want flash drive totally empty with nothing on it. Sorry to be a bother this is not my "thing"

Collapse -
Go to Disk Utility
by mrmacfixit Forum moderator / March 29, 2008 11:33 AM PDT
In reply to: I am VERY NEW

and format that flash drive.

Take a look around Disk Utility and you will find the option to erase or partition.
Select your flash drive,
choose partition
Choose 1 partition
choose MS-DOS
choose Apply or Format

You should be done


Collapse -
YES that worked free at last!!
by 52Nash / March 29, 2008 12:35 PM PDT
In reply to: Go to Disk Utility


Collapse -
unlocking a jpeg
by Argilval / February 8, 2012 4:50 AM PST
In reply to: unlocking a jpeg

I was sending a document[ that i scanned as a jpeg file] to someone and they could not open it. I did not realize that I had set up my iMac so only I was able to look at some documents. So I also used 'command i' feature to unlock the jpeg at the very bottom of the page and changed the permissions to allow the person to look at and write on the message. worked !! thanks!

Collapse -
jpeg won't delete
by shaunkosh / March 22, 2012 2:05 PM PDT
In reply to: unlocking a jpeg

i have one jpeg file and two bmp file that won't delete and when i try it just says ( The item "354087429.637374tmp.bmp" can't be moved to the Trash because it can't be deleted.)

any suggestions

i have a imac osx version 10.7.3

Collapse -
unlocking a jpeg
by IdeaMonkey / August 29, 2014 9:26 PM PDT
In reply to: unlocking a jpeg

I have moved some files from a PC to a portable hard drive and then on to my Mac running Mavericks. There are 2 photos, both on the disk and on my Mac that I can not delete. If I go to show info, the jpeg is described as "locked". I click on the lock and put in my password and the lock "unlocks". But it still won't delete. In the Get info pane there is an area called "General" and it has 2 check boxes "Stationery Pad" which is unchecked and "Locked "which is checked. It is however lighter a than the other boxes and I cannot uncheck it. At the bottom under "Sharing & Permissions" it says "You can only read. Then it has "Name" and "Privilege". It says "Fetching" and opposite that is "Read & Write". Below that is "Staff" which is "Read Only" and "Everyone" which is also read only. I can open the box on these last 2 but it won't accept changing to "Read & Write" Opposite the "Fetching" box it won't let me open it.

If I move it to trash it makes a duplicate that I also can't remove so know I have 4 locked files. It won't "Move" only "Copy". I've tried Mac Keeper shredder with the same effect. Any help?

Collapse -
First step, Get rid of MacKeeper
by mrmacfixit Forum moderator / August 30, 2014 12:37 AM PDT
In reply to: unlocking a jpeg

At the bottom of the Info box there is a + & - sign.
After unlocking the info panel, if applicable, hit the + sign and from the list of people that yo see there, choose your name.
Give yourself Read & Write.
Make sure there are no "locked" check marks and close the Info window.

Now try the delete

It would have been better had you created your own thread instead of hijacking this 7 year old one.


Collapse -
Didn't work
by IdeaMonkey / August 30, 2014 7:23 PM PDT

I'd already tried the + and - thing. It looks to me like it is looking for a user that only exists on the old PC.

Sorry about using an old thread I'm new to this didn't realise the protocol but shows how long the problem has been around.

I can't uncheck the locked box it is a light grey and won't respond to the mouse.

Can I add a screen shot to this post?


Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions

Does BMW or Volvo do it best?

Pint-size luxury and funky style

Shopping for a new car this weekend? See how the BMW X2 stacks up against the Volvo XC40 in our side-by-side comparison.