Computer Help forum

General discussion

unable to update definitions for webroot spysweeper

by luke_da_duke / March 16, 2009 12:48 PM PDT

Ok so I have been using webroot spysweeper with antivirus for a couple years now with no problems. Now I am unable to update my definitions. I have the auto updates to do It every hour and I still receive the same "unable to update definitions" box at the bottom of my screen. I have tried to update manually with no luck. This seems to have happened around the time I downloaded the new version 6.107 I believe, but I just cannot figure this out. I have checked all the support forums, written them e-mails with no response and Im very flustered. Webroot has some of the worst customer service Ive ever seen and I just want to get my moneys worth out of this subscription and quit them. Please help me.

Discussion is locked
You are posting a reply to: unable to update definitions for webroot spysweeper
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: unable to update definitions for webroot spysweeper
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Hmm...
by FrankQC / March 17, 2009 9:16 AM PDT

Maybe their servers are down?
Maybe the company went bankrupted which in turn the customers lose service?

You should just stick with official corporation antiviruses i.e. McAfee and Norton. They can't afford to have bad customer service. They have a reputation to keep.

Collapse -
hmm
by luke_da_duke / March 17, 2009 9:53 AM PDT
In reply to: Hmm...

your right, however I still have like 200 days left on the subscription so I just kinda want to get my moneys worth ya know? Thank you for your reply and I will keep that in mind next time I go to purchase any antivirus software. Does anyone have any recommended procedures I can take or download to help fix this problem?

Collapse -
unable to update definitions for webroot spysweeper
by jimmyloosh / March 19, 2009 8:16 PM PDT
In reply to: hmm

@ hmm. i'm having the same problem over here. i'm using regcure registry cleaner, i dont know if that is the problem. also i'm using pc tools firewall and it is set to allow all instances of spysweeper. webroot spysweeper was working perfectly for a few weeks then all of a sudden the program isnt able to check for updates..

Collapse -
Norton, McAfee Are A Waste of Money
by tdk650 / June 29, 2010 2:24 AM PDT
In reply to: Hmm...

Get Vipre Antivirus/Antispyware Premium, this is an excellent program, its cheaper and it actually works! Been using it for quite some time, and couldnt be happier. Word of advice, uninstall any other virus program before trying.

As far as the Webroot problem, stopping the services and restarting seemed to work for me for now.

Collapse -
same problem as you...
by vatrpr / March 27, 2009 2:06 AM PDT

Please let me know when you figure this out, as I am having the exact same problem. I'm thinking of going to another virus program, but I have a couple hundred days left of my subscription as well. This sucks!

Collapse -
nope nope nope
by luke_da_duke / April 3, 2009 2:08 AM PDT
In reply to: same problem as you...

Still cannot figure this thing out. And might I acknowledge the horrible customer service provided by Webroot? What i did do was download the free total system scanner provided by Microsoft one care. It found a trace of a TrojanDownloader:JS/Reno. This might have something to do with the problem, however it was "unable to fully remove" with the one care program. This might be something to look into. Thank you all for your input, and after all this....I will never touch a Webroot product again, they just turned a Webroot lifer into a Webroot neveragainer!!

Collapse -
webroot
by botta75 / August 28, 2009 8:01 AM PDT

Hi - I know this was a while ago... I am working with Webroot and want to offer you a chance to speak with them about your frustrations and ask for your suggestions on how we can help you in the future. Are you open to that? thanks so much. HG

Collapse -
Restart Client Service
by mc40638 / April 19, 2010 4:04 AM PDT

I have seen the same problem and have a workaround on WIN XP, SP3.

a) STOP webroot completely. The ICON should disappear from the list of running programs on your taskbar.

b) CONTROL PANEL/ADMINISTRATIVE MANAGEMENT/CONTROL SERVICES

c) Stop and start WEBROOT Client Services (this is the guy which talks to their servers)

d) Restart WEBROOT AV (ESSENTIALS) Program. It will not take forever - apparently some of the program remains resident.

e) Try a manual update. It may be slow but should work.

Collapse -
unable to update definitions for webroot spysweeper
by syffat / May 15, 2010 6:22 AM PDT
In reply to: Restart Client Service

Will this work for Windows Vista too?
Mine stopped working as soon as I downloaded the newest version.

1) How do you stop it completely? What are the steps to take to stop it?

Collapse -
Webroot unable to update spyware definitions.
by Schmelaap / August 20, 2010 9:46 AM PDT

I had the same problem on my Dads computer, I completely uninstalled webroot then even removed registry entries, and and all folders.
I re-installed and still had the same problem. It would start the download of new definitions and download some of it then freeze.
My Dad's computer uses ATT for ISP. I took the computer to my house and tried it on Comcast cable and everything downloaded fine.
Next I am going to have att come out and check the service to my dads house or his cableing inside to see if maybe the connection is to resistive. Also I might add that when this would not download at my dads, he could still get to the internet and do anything else he wanted so this is kind of strange.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

Does BMW or Volvo do it best?

Pint-size luxury and funky style

Shopping for a new car this weekend? See how the BMW X2 stacks up against the Volvo XC40 in our side-by-side comparison.