General discussion

Unable to open serial port

I am trying to open a virtual serial (usb to serial) port in Hyperterminal and it tells me that it cannot open the COM port. I have tried the exact steps on other computers running Windows 200, XP, and Vista and it works just fine. This means it is not the device and has to be the individual computer, The drivers are loaded correctly, it enumerates and can be seen in device manager on the problem computer. My guess is there is another program blocking me from using it although there are other possibilities. I have tried multiple combinations of rebooting, reinstalling drivers, and killing background processes that may be accessing the virtual serial port.

Discussion is locked
Follow
Reply to: Unable to open serial port
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Unable to open serial port
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Just fixed one like that.

Turns out the maker had a buggy USB to serial driver. Since you didn't supply details I can't see if there is an updated driver. But do ask them.
Bob

- Collapse -
More details.

It is actually a custom board using an Amtel ATmega32U4 MCU with a USB 2.0 interface. I am using a custom USB CDC stack with a custom .inf driver file. The driver shouldn't be the problem because for one, the code is pretty generic for what I am doing. For two the board communicates fine on other computers with the same driver. It is just very frustrating that I can't figure out why the port won't open on this one specific computer. It has to be either a conflict with another program or some changed setting, but I can't find it. Thanks for the response though.

CNET Forums