It's nothing I've run into. Does it work OK on your apple macbook pro?

i7 usually is the Intel Core i7 CPU but I'm left to guess it's an iPhone 7. I have iOS 11.2.5 now. You?

There are ideas from the web but why not pester Instagram about this as well.

1. Disable Autoplay
Some users managed to solve video issues by disabling the Autoplay. It seems that, for some of the users with older devices, the Autoplay smothered video playback. However, Instagram removed ‘Disable Auto Play’ for unapparent reasons so you’ll still have videos preloaded while connected via Wi-Fi. At least you can prevent preloading on mobile data and this is how.

Open Instagram app.
Tap Options.
Choose Cellular Data Use.
Tap Use Less Data.

2. Really CLOSE INSTAGRAM!
Double-tap the Home button. When you double-tap the Home button, you’ll see the app navigator on your screen Use your finger to swipe up on the Instagram app to close it. Now that you’ve closed the app, reopen it and see if Instagram is working again.