Usually, in such cases you uninstall and reinstall the product. If it doesn't work, contact Farstone Support. They should tell you if your version is compatible with SP2 or a patch is available.

Good Luck,

Cetin


Trying to unweave, unwind, unravel
And piece together the past and the future,


T. S. Eliot