Windows 7 forum

Question

unable to create a new file or edit a file in a folder

by ssc801_1 / April 5, 2013 3:57 PM PDT

I am the owner and administrator of a folder in Program Files. If I attempt to edit an ini file and save the file I get:

1.message box from Notepad saying I can not create the file - Make sure the path and name are correct(they are) I press ok
2. I get a Save as Dialog Box - I click save
3. message box File already exists do you want to replace it
- I click yes
4 I get the first message again

I also noticed if I click New in the context menu of the files list of explorer there is only the option to create a Folder (no file types) The same issue exists for newly created folders inside this folder.

So I go to properties of the folder and select the security tab. I then attempt to edit the permissions for the Administrators group - it says I have full control and I can change anything but the 'Special Permissions' (which is set to Allow)

So I try the Advanced button

The Administrators group has 2 entries:
Full Control - <not inherited> - Applies to this folder subfolders and files (Everything is allowed)
Special - inherited from program Files - applies to this folder only (this entry can not be deleted)

Quite often while doing this and other things I get a prompt for - Windows needs your permission to continue

I have tried so many things and logged on an off so many times - What am I missing?

I have this same issue in Vista at times

The only thing I can do is copy the ini file into another folder, edit it there, delete the original, and copy the changed file back into the folder with a number of extra 'Windows needs your permission to continue' prompts along the way. It simply isn't worth this run around every time the point is for software to be convenient ...

Discussion is locked
You are posting a reply to: unable to create a new file or edit a file in a folder
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: unable to create a new file or edit a file in a folder
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
TRUE!
by R. Proffitt Forum moderator / April 6, 2013 2:12 AM PDT

Some files are open and held open by apps. All I see for the file name is .INI so if this was a desktop.ini then explorer could have a lock on it.

Please tell more.
Bob

Collapse -
Good thought
by ssc801_1 / April 15, 2013 12:37 AM PDT
In reply to: TRUE!

Thanks for your response.

But the method that does work is copying it and deleting the original. I do not think that would work if there were a lock on the file. I am pretty sure I tried using unlocker.exe to check for that.

And it is not Desktop.ini it is the primary program initialization file.

I am pretty sure the issue is related to default security settings that come with Vista on first use.
Security seems to be much more complex than it was in XP


It seems the key is not being able to create a file in that folder. I can create a file in another folder or delete the .ini file. I get many prompts before the deletion is allowed.

Collapse -
Your choice what to do next.
by R. Proffitt Forum moderator / April 15, 2013 2:42 AM PDT
In reply to: Good thought

If you feel like it's too much security you can change that. But as it's pretty dangerous I want nothing to do with lowering the new security back to days of old. But it is your choice to turn off file protection then research that and you get what you want. Again, I'll part with an example and state it's not a good thing to turn off.

http://windows7themes.net/how-to-disable-windows-7-file-protection.html

Bob

Collapse -
Thanks again
by ssc801_1 / April 16, 2013 2:57 AM PDT

Not sure what I am going to do yet.

Interesting, it seems the Global Policy Editor is not on my pc gpedit.msc

Changing security for a single location for administrators only, I have no problem with.

Collapse -
oops group policy editor
by ssc801_1 / April 16, 2013 2:59 AM PDT
In reply to: Thanks again

group policy editor

Collapse -
As I wrote, an example.
by R. Proffitt Forum moderator / April 16, 2013 3:00 AM PDT
In reply to: Thanks again

I don't want to advise turning that off. But you can research this area and should discover how to disable it with registry edits. That's even more dangerous as one wrong entry can cause folk to reinstall the OS. That's why I didn't supply a regedit based answer.
Bob

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

Does BMW or Volvo do it best?

Pint-size luxury and funky style

Shopping for a new car this weekend? See how the BMW X2 stacks up against the Volvo XC40 in our side-by-side comparison.