Samsung forum

General discussion

Unable to connect to Samsung Smart Hub server

by pablo_pa / January 19, 2014 5:34 PM PST

Hello,

I'm getting an "Unable to connect to the server. Please contact the Samsung service centre." error when setting up my Samsung UE39F5300 Smart TV.

I am connected directly to my route with a wire. Internet test is OK and I have been able to use the browser on the TV, so internet connection is not the issue.

Anyone knows what the issue might be? I have read in other threads about Samsung servers being down more frequently than they should be. However, since I just bought my TV, I cannot say if this might be a faulty TV or just a real issue on Samsung servers side.

I have been checking my router's setup and everything seems to be open (no firewall in use).

Thanks in advance for your help.

Discussion is locked
You are posting a reply to: Unable to connect to Samsung Smart Hub server
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Unable to connect to Samsung Smart Hub server
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
New question
by jimmyblackfish / January 19, 2014 6:16 PM PST

Sorry everyone, brand new here.
i need some help. I have a Samsung HT-C655W dvd home theatre, had it for about 4 years, great unit. Lately it rejects alot of discs, original discs. The strange thing is: If i make a burnt copy of the original, it will work, so will any "home made" discs made via computer on blank discs.
I updated the firmware and did the region free hack, still no difference. I really don't want to have to burn a copy of all my discs to watch them (or rented ones!). Has anybody come across this problem?
Cheers

Collapse -
Please put new questions in your own discussion.
by R. Proffitt Forum moderator / January 19, 2014 11:56 PM PST
In reply to: New question
Collapse -
(NT) Thanks Bob. Sorry guys.
by jimmyblackfish / January 20, 2014 4:57 PM PST
Collapse -
No problem.
by R. Proffitt Forum moderator / January 20, 2014 11:49 PM PST

Hope your issue gets solved.
Bob

Collapse -
Sorry no. But we have many things to try.
by R. Proffitt Forum moderator / January 19, 2014 11:57 PM PST

Sadly with the fall of the Net Neutrality law it is now possible for ISPs to cause this and be well withing their rights.

Did you try the usual first response of change to the Google DNS?
Bob

Collapse -
I tried many things
by pablo_pa / January 20, 2014 1:11 AM PST

Thanks for your reply. I had already try that. The point is that Internet test is successful. I have access to the internet, and DNS is properly working, since I can navigate through the browser, I have played youtube videos, etc.

It is quite frustrating to contact both Samsung customer service and BT (my ISP) and find out their answers are reduced to reset the setup or blame mutually the other counterpart.

On BT they told me everything is open by default (which is what I see in my router settings). Samsung support people told me it should be an issue with ISP or just a faulty TV, which seems weird since I do have internet connection on it.

Any other idea is more than welcome.

Collapse -
Remember I'm taking your word as to the issue.
by R. Proffitt Forum moderator / January 20, 2014 1:23 AM PST
In reply to: I tried many things

If you can't log into or connect to Smart Hub I'm left to wonder how you got access to the internet browser on the TV. I thought we needed one before the other?
Bob

Collapse -
No issues with BT, so.....
by jstanmore99 / January 20, 2014 5:45 AM PST
In reply to: I tried many things

Hello,
Assuming your BT = my UK British Telecom...... they do not block Samsung traffic and neither of my currently t'internet connected sets have issues connecting to Samsung servers for Smarthub updates or general connectivity across a BT broadband service.

Therefore, I would rule out an ISP-related problem. It's got to be local to your LAN.

You have clearly tried a few things above. Could you check/try a couple more please? Apologies up front if some of these are obvious to you.
i) Can you clear out your tv web browser cache? And then connect to e.g. BBC.news and check a time/date stamp is current? Want to be sure you *still* have current connectivity OK and not a cached page or something daft like that. Silly i know but important to start with a clean slate.
ii) Are you using DHCP or static IP address? Change to a unique static IP if using DHCP....no point in a dynamic address for a device that will never move and indeed you may want to set up permanent IP shares to in future. You can define a static range in the router if not already done so. Ensure subnet mask = 255.255.255.0
iii) Check your gateway address is correct on the TV (if your t'internet is good, this must be correct). Just put in your router IP.
iv) You've already posted about your DNS being on 8.8.8.8 and 8.8.4.4. This is fairly key IMHO. https://developers.google.com/speed/public-dns/ Try BT's own 62.6.40.178 & 62.6.40.162 as I *KNOW* this works
v) Check your router has no internally blocked IP addresses/domains defined
vi) Check your router has no odd port ranges being blocked.
vii) Check your not cloning mac addresses behind your router.
viii) Have you created a Samsung account and registered it on the TV? I do not think this should prevent you getting Smarthub, but I'm not Samsung and perhaps they are quietly tightening up access to apps to ensure people log in to the servers? (I'm not a fan of them collecting metadata on everything we watch personally)
ix) Finally.....is your TV a UK model TV being used in the UK or a European/etc model? I know that some apps are blocked according to country-specific Samsung TV model codes. e.g. BBC iplayer is blocked outside of UK by non-UK TV models for DRM purposes. No reason *whatsoever* to understand why Smarthub would experience the same.....but another thread to investigate perchance? I have an interesting article bookmarked if you wish to have it should this be a consideration.

Your router type/model might help us PD the issue if none of the above move you a step forward?
Let us know progress and if you need more help (it's frustrating the number of ppl who never report back!)
Best of British
J

Collapse -
Problem solved!
by pablo_pa / January 20, 2014 7:35 AM PST

Thanks a lot for your comments.

I had indeed try a lot of things, ip setup, router options and firewall, etc...

I updated the tv software (which had failed in previous attempts) and now my smart hub is up and running. So no need to look at any other setup.

Last question, does Samsung limit apps available by country?

Thanks a lot for your help

Collapse -
No.
by R. Proffitt Forum moderator / January 20, 2014 7:41 AM PST
In reply to: Problem solved!

"does Samsung limit apps available by country?"

I have to write no. Countries limit apps (that is, governments.)
If you need examples, just ask.
Bob

Collapse -
Same problem
by mariebee21 / January 20, 2014 8:55 AM PST
In reply to: I tried many things

I was having the same problem setting up my smart hub for the first time today. My internet connection was perfect (I could use the TV browser) but I was getting the "unable to connect to server" message when I tried to set up the smart hub.

However, I have solved my problem by updating the software on the TV. This took about an hour. Using the menu button on the remote control, scroll down to "support" and then to "software update"

Hope this helps!

Collapse -
SMARTHUB NETWORK FAULT
by AP_EFFECTS / February 25, 2015 8:21 AM PST

We have the same fault 'network interference' It recommends to contact the internet service provider BT (LONDON) but that will not help as the Samsung servers are down.

Who knows how long they will take to get back online, could be days if the equipment is damaged, claims could be put in for the loss of service.

This just shows how vulnerable internet based technology is, i am currently using Apple tv and ps4 to run apps, the apple tv runs much faster than smarthub and the apps for example netflix have a much better layout, you could use laptop to run apps and connect via hdmi in the meantime.

AP E F F E C T S *

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?