Windows Legacy OS forum

General discussion

Unable to close out of a program using the red 'X'

by NickBurns10 / May 27, 2010 12:24 AM PDT

I am having troubles closing out of a program using the red 'X'. We are able to close the program by using File/Exit, but would like to figure this out. No matter which user is on the computer, same issue occurs with this program. We ruled out that it is not an issue with the program and tried uninstalling and reinstalling the .net's on the computer, but nothing has worked. Any suggestions?

Discussion is locked
You are posting a reply to: Unable to close out of a program using the red 'X'
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Unable to close out of a program using the red 'X'
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
That's me?
by R. Proffitt Forum moderator / May 27, 2010 12:39 AM PDT

I author a few .net apps and as the author you have a choice on what to do when the X is clicked. Did you ask the app's author what they did?

Collapse -
Is this a particular program?
by MarkFlax Forum moderator / May 27, 2010 2:39 AM PDT

If so, how did you rule out it was a programming issue.

You say you tried uninstalling and reinstalling the .nets on the computer. What prompted you to try that, and have you tried uninstalling and reinstalling the program in question?


Collapse -
Unable to close out of a program using the red 'X'
by pcs365_12 / May 27, 2010 9:56 PM PDT

you can try to re-register the dll files associated with the apps using the command in run : regsvr32 "applicationdll.dll"
Please change the dll file name according to the names in the application and restart the machine.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Samsung Galaxy S8's major makeover

This year's flagship phone gets a sexy new design and Bixby, a house-made digital assistant.