PC Hardware forum

Question

UEFI restores default settings everytime i turn on the PC

Hello, I'm having this frustrating issue with my PC and I can't find any solution. I hope some of you guys can help.
Few days ago I've got this message on the screen right after turning on the PC: UEFI date/time not set, press F2 to setup, F1 to continue. So googling around I've find what seemed to be the solution, that is change the CMOS battery. Then when I restarted, this message was replaced by this one: UEFI defaults have been loaded, press F2 to setup, F1 to continue. Since then I'm not able to start the PC without getting this message and more important I can't save any UEFI. This would happen ONLY if I also unplug the power cord. If I just shut down the system and leaving the power cord plugged in, the system boot up normally. By pressing F1 I can get to Windows and the system seems to run smooth, without any problem. CPU temps are normal, RAM get detected normally, SSD and HDD works, everything seems fine.

I tried pretty much everything to solve the problem and I followed similar posts but without any luck.

This is what I've tried so far: CMOS reset with jumpers (few times) and by removing the battery, changed the old battery with a new one and tested both with a voltmeter (both 2,9V pretty much), clean the battery holder with alcohol and by rubbing the contacts, disconnect any peripherals device, flashing the UEFI with the new update (2.00) and even the older ones (1.80,1.90), changed UEFI settings, reinstalled Windows 10 three times and changed between Home and Pro versions, updated all the drivers, disabled all the USB ports, removed the MB from the case, cleaned all the parts and mounted it back, even changed thermal paste..

As you can see this is driving me crazy!!!Please help!

These are my specs:
MB: ASRock H97 Pro4
CPU: Intel 15 4440
RAM: 2x4GB HyperX Fury Black DDR3
GPU: Onboard graphics (atm because I'm waiting for the new ones)
SSD: Samsung Evo 250 GB Sata III
HDD: WD Caviar Blue 1TB
PSU: Enermax Triathlor ECO 550W
OS: Windows 10 Home

MONITOR: AOC g2460pf (this info is probably useless but all this started because I needed to install beta drivers for it and had to reinstall Windows 10 to do that)

I apologize for my poor English but it isn't my native language. Thanks in advance.

Discussion is locked
You are posting a reply to: UEFI restores default settings everytime i turn on the PC
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: UEFI restores default settings everytime i turn on the PC
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

REVIEW

Sublime suburban chariot

High on style and technology, the 2019 Volvo XC90 is an incredibly satisfying everyday crossover.