Question

UEFI BIOS Cursor "possessed"

Hello all. I am trying to install Ubuntu from a zip drive when I realized that, now, a problem occurs whenever I enter my UEFI BIOS; an emphasis on "now" because it has never happened before. I can enter UEFI just fine, but once in, the cursor randomly jumps up and down the far side of the screen. It seems to respond slightly to my actual mouse movements and keyboard inputs, but it pretty much does whatever it wants to.

I've tried: Disconnecting the zip drive with Ubuntu on it, Plugging mouse and keyboard into alternate USB ports, Not plugging in the mouse at all, plugging in alternate mouse and keyboard into all available USB ports, and finally un-installing my anti-virus because I came across some info that said that could be the culprit. I don't know what else to do or why this could be happening; that is besides disconnecting one of my monitors. I originally had only 1 when first setting up the BIOS. I think I will actually try that now that I've thought of it. However, just in case that isn't the fix, thanks for your help in advance and here's all the info I can think of:

---------- BUILD ----------
Windows 7 SP1 64Bit --- OS
Sabretooth 990fx --- MOBO
AMD Zambezi FX-8120 (OC...I think) --- CPU
16GB Ripjaws --- RAM

----------HIJACKTHIS LOGFILE ----------
Logfile of Trend Micro HijackThis v2.0.4
Scan saved at 12:41:02 AM, on 8/31/2012
Platform: Windows 7 SP1 (WinNT 6.00.3505)
MSIE: Internet Explorer v9.00 (9.00.8112.1644Cool
Boot mode: Normal

Running processes:
C:\Program Files (x86)\Steam\Steam.exe
C:\Users\NJH\AppData\Roaming\Spotify\Data\SpotifyWebHelper.exe
C:\Users\NJH\AppData\Roaming\Dropbox\bin\Dropbox.exe
C:\Program Files (x86)\D-Link\DWA-566\AirNCFG.exe
C:\Program Files (x86)\Bamboo Dock\BambooCore.exe
C:\Program Files (x86)\Ask.com\Updater\Updater.exe
C:\Users\NJH\Downloads\HijackThis.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.searchnu.com/102
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Local Page = C:\Windows\SysWOW64\blank.htm
R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =
F2 - REG:system.ini: UserInit=userinit.exe
O2 - BHO: AcroIEHelperStub - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - C:\Program Files (x86)\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll
O2 - BHO: Ask Toolbar BHO - {D4027C7F-154A-4066-A1AD-4243D8127440} - C:\Program Files (x86)\Ask.com\GenericAskToolbar.dll
O3 - Toolbar: Ask Toolbar - {D4027C7F-154A-4066-A1AD-4243D8127440} - C:\Program Files (x86)\Ask.com\GenericAskToolbar.dll
O4 - HKLM\..\Run: [JMB36X IDE Setup] C:\Windows\RaidTool\xInsIDE.exe
O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "C:\Program Files (x86)\Adobe\Reader 9.0\Reader\Reader_sl.exe"
O4 - HKLM\..\Run: [D-Link D-Link DWA-566] C:\Program Files (x86)\D-Link\DWA-566\AirNCFG.exe
O4 - HKLM\..\Run: [BambooCore] C:\Program Files (x86)\Bamboo Dock\BambooCore.exe
O4 - HKLM\..\Run: [ApnUpdater] "C:\Program Files (x86)\Ask.com\Updater\Updater.exe"
O4 - HKLM\..\RunOnce: [removeSearchqudatamngr] cmd.exe /c RD /S /Q "C:\Program Files (x86)\Searchqu Toolbar"
O4 - HKLM\..\RunOnce: [removeSearchqutoolbar] cmd.exe /c RD /S /Q "C:\Program Files (x86)\Searchqu Toolbar\Datamngr\ToolBar"
O4 - HKCU\..\Run: [Google Update] "C:\Users\NJH\AppData\Local\Google\Update\GoogleUpdate.exe" /c
O4 - HKCU\..\Run: [Steam] "C:\Program Files (x86)\Steam\Steam.exe" -silent
O4 - HKCU\..\Run: [Spotify Web Helper] "C:\Users\NJH\AppData\Roaming\Spotify\Data\SpotifyWebHelper.exe"
O4 - Startup: Dropbox.lnk = C:\Users\NJH\AppData\Roaming\Dropbox\bin\Dropbox.exe
O11 - Options group: [ACCELERATED_GRAPHICS] Accelerated graphics
O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://fpdownload2.macromedia.com/get/shockwave/cabs/flash/swflash.cab
O18 - Protocol: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - C:\PROGRA~2\COMMON~1\Skype\SKYPE4~1.DLL
O20 - AppInit_DLLs:
O23 - Service: Adobe Flash Player Update Service (AdobeFlashPlayerUpdateSvc) - Adobe Systems Incorporated - C:\Windows\SysWOW64\Macromed\Flash\FlashPlayerUpdateService.exe
O23 - Service: @%SystemRoot%\system32\Alg.exe,-112 (ALG) - Unknown owner - C:\Windows\System32\alg.exe (file missing)
O23 - Service: D_Link_DWA-566_WPS Service (D_Link_DWA-566_WPS) - Unknown owner - C:\Program Files (x86)\D-Link\DWA-566\ANIWConnService.exe
O23 - Service: @%SystemRoot%\system32\efssvc.dll,-100 (EFS) - Unknown owner - C:\Windows\System32\lsass.exe (file missing)
O23 - Service: @%systemroot%\system32\fxsresm.dll,-118 (Fax) - Unknown owner - C:\Windows\system32\fxssvc.exe (file missing)
O23 - Service: @keyiso.dll,-100 (KeyIso) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @comres.dll,-2797 (MSDTC) - Unknown owner - C:\Windows\System32\msdtc.exe (file missing)
O23 - Service: @%SystemRoot%\System32\netlogon.dll,-102 (Netlogon) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: NVIDIA Display Driver Service (nvsvc) - Unknown owner - C:\Windows\system32\nvvsvc.exe (file missing)
O23 - Service: NVIDIA Update Service Daemon (nvUpdatusService) - NVIDIA Corporation - C:\Program Files (x86)\NVIDIA Corporation\NVIDIA Updatus\daemonu.exe
O23 - Service: @%systemroot%\system32\psbase.dll,-300 (ProtectedStorage) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @%systemroot%\system32\Locator.exe,-2 (RpcLocator) - Unknown owner - C:\Windows\system32\locator.exe (file missing)
O23 - Service: @%SystemRoot%\system32\samsrv.dll,-1 (SamSs) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: Skype Updater (SkypeUpdate) - Skype Technologies - C:\Program Files (x86)\Skype\Updater\Updater.exe
O23 - Service: @%SystemRoot%\system32\snmptrap.exe,-3 (SNMPTRAP) - Unknown owner - C:\Windows\System32\snmptrap.exe (file missing)
O23 - Service: @%systemroot%\system32\spoolsv.exe,-1 (Spooler) - Unknown owner - C:\Windows\System32\spoolsv.exe (file missing)
O23 - Service: @%SystemRoot%\system32\sppsvc.exe,-101 (sppsvc) - Unknown owner - C:\Windows\system32\sppsvc.exe (file missing)
O23 - Service: Steam Client Service - Valve Corporation - C:\Program Files (x86)\Common Files\Steam\SteamService.exe
O23 - Service: NVIDIA Stereoscopic 3D Driver Service (Stereo Service) - NVIDIA Corporation - C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvSCPAPISvr.exe
O23 - Service: TabletServicePen - Wacom Technology, Corp. - C:\Program Files\Tablet\Pen\Pen_Tablet.exe
O23 - Service: Wacom Consumer Touch Service (TouchServicePen) - Wacom Technology, Corp. - C:\Program Files\Tablet\Pen\Pen_TouchService.exe
O23 - Service: @%SystemRoot%\system32\ui0detect.exe,-101 (UI0Detect) - Unknown owner - C:\Windows\system32\UI0Detect.exe (file missing)
O23 - Service: @%SystemRoot%\system32\vaultsvc.dll,-1003 (VaultSvc) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @%SystemRoot%\system32\vds.exe,-100 (vds) - Unknown owner - C:\Windows\System32\vds.exe (file missing)
O23 - Service: @%systemroot%\system32\vssvc.exe,-102 (VSS) - Unknown owner - C:\Windows\system32\vssvc.exe (file missing)
O23 - Service: @%SystemRoot%\system32\Wat\WatUX.exe,-601 (WatAdminSvc) - Unknown owner - C:\Windows\system32\Wat\WatAdminSvc.exe (file missing)
O23 - Service: @%systemroot%\system32\wbengine.exe,-104 (wbengine) - Unknown owner - C:\Windows\system32\wbengine.exe (file missing)
O23 - Service: @%Systemroot%\system32\wbem\wmiapsrv.exe,-110 (wmiApSrv) - Unknown owner - C:\Windows\system32\wbem\WmiApSrv.exe (file missing)
O23 - Service: @%PROGRAMFILES%\Windows Media Player\wmpnetwk.exe,-101 (WMPNetworkSvc) - Unknown owner - C:\Program Files (x86)\Windows Media Player\wmpnetwk.exe (file missing)

--
End of file - 7242 bytes

Discussion is locked
Follow
Reply to: UEFI BIOS Cursor "possessed"
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: UEFI BIOS Cursor "possessed"
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
UEFI and such.

I don't want to annoy you but there are a few new machines with UEFI BIOS that Linux will not install to.

Not only that but you seem to be overclocking which means no one in their right mind will support this machine.

I suggest you take this up with the machine's maker and get them to replace the parts as needed.
Bob

- Collapse -
OK

Thanks for the reply. Therein lies the problem. I built the machine myself. This is my first build. Could you tell that I am overclocking by the Logfile or is it that I mentioned it? I posted "I think" because I thought that I reset it to default not long after I OC'd it. I just wanted to test whether or not the performance would be noticeably better. It didn't seem to be so I reset it to default, or at least I thought I did. However, when I got into the UEFI yesterday, it was reading at 3.9GHz instead of the 3.5GHz that it is supposed to be running at. It's read the correct speed as far as I could tell up until now. God I hope that isn't the problem. Is there any way to test if there is any damage that you know of? I've used Seatools before and that didn't turn up anything, or maybe I just need a new MOBO and/or
CPU?

- Collapse -
You listed overclocking in your post.

I have no reason to doubt you.

There is one idea I didn't see put out and that is to use the reset jumper for the BIOS.

-> Zip Drives are quite rare. Given how old and troublesome they can be, maybe it's time to move your files off those 100MB disks?
Bob

- Collapse -
Tried that as well.

Yes, I've reset the jumper and the battery. It didn't fix anything. The last thing I can think of doing is flashing the UEFI. The only problem with that , now that I think of it, is that I believe I have to actually go through the UEFI in order to flash it. The whole reason I want to flash it is because I can't operate it in the first place. Lol, the irony is just too much. Is there anyway to bypass going into the current UEFI and just go straight into upgrading it/installing a fresh one?

I will probably have to just buy those replacement parts you mentioned. Another MOBO and OS cuz that was OEM. God, the problems just keep piling on don't they.

- Collapse -
Let me comment about OEM

If this is a Microsoft OEM issue I've found Microsoft to bend and issue you a new CD key when the motherboard fails. They will NEVER issue that key if your machine is some Dell, HP or "make."

http://www.asus.com/Motherboards/AMD_AM3Plus/SABERTOOTH_990FX/#download shows
a DATE of 7/20/2012 for the current BIOS.

I see it can use DOS to update the BIOS.
"Bupdater Utility V1.26 for flash BIOS under DOS."

Bob

- Collapse -
Tried that as well

I've tried putting the BIOS file and updater on zip drive and unplugging all SATA hard drives and booting, but a few different errors appear at different times. These errors include: "No BOOTMGR detected", "Not a system disk", and "Overclocking Failed...", errors all appeared at different boots. The latter pisses me off because it shouldn't be overclocking to begin with. Now the CPU is running at the OC speed, even after the jumper and battery being reset. The one thing that is common in all of these scenarios is that the keyboard does not work and I have to manually shutdown each time. I wish there was someone to know if there is a problem with everything, or just a problem with one thing.

- Collapse -
Odd to try a ZIP drive.

I would have gone old school with a floppy or maybe make a bootable CD. But as it stands you seem fixated with the Zip drives.

I've encountered such owners and usually have to take it back to the shop to get it done. That is, we have floppy drives and more there.
Bob

- Collapse -
Guess I Will try CD/DVD.

Lol, zip drives just seemed to be the easiest way to go, especially when it comes to backing up the old BIOS. Since it isn't working, I will just have to try using a compact disk. I don't have a floppy drive and haven't seen anyone with one since George Bush Jr. was first elected. Now to figure out how to convert a .ROM into a .BIN/.ISO. Hmmm...

- Collapse -
I had a few Zip drives too.

But to make them bootable was a feat recently and since they are too small and error prone I gifted them to some friends with dead Zips so they could get their data out. I don't do data recovery anymore since folk have become too litigious over that.

I know that drive too well.
Bob

CNET Forums