Storage forum

General discussion

U3 launcher on my pendrive is missing hence no access

by Asuaboah3006 / October 7, 2009 5:08 PM PDT

I am using SanDisk cruzer micro usb pendrive of size 4GB. I recovered a movie i had deleted that i needed back. I then used it to cover power iso from a different computer. When i inserted it back in my computer but the u3 launcher did not come. It was as if the u3 drive which usually launches is deleted and only blinks. I tried it on different computers even the one that i copied the power iso from. Because there is a password on the drive and can only be opened where the u3 launcher is working. I cannot get access to the drive. Formatting does not work. Please help me solve this problem

Discussion is locked
You are posting a reply to: U3 launcher on my pendrive is missing hence no access
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: U3 launcher on my pendrive is missing hence no access
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
by R. Proffitt Forum moderator / October 7, 2009 10:49 PM PDT

1. Head to and fish.
2. Need data recovery?

Collapse -
by Joliet Eddie / October 9, 2009 5:14 AM PDT

I hope that you can get access to your drive. If you do, I would suggest doing what I did with my U3 USB drives: format them completely as plain old USB drives. You get more usable space and are not subject to the U3 software, which you have discovered is not trustworthy.

Collapse -
my U3 has malfunctioned
by Asuaboah3006 / October 14, 2009 9:19 AM PDT
In reply to: U3

thanks for the support. I tried the u3 site. But they mentioned two possible causes of this problem. One being software conflicts (they mentioned something like 'InCD' installed programs which i do not have any on my computer. The second being drive allocation problems on my computer

I tried these things but i don't know what to do next because the drive is still locked and i can't get access.

is there any way/program that can allow for the u3 to be run from my computer so as to access the pen drive?

Collapse -
I'm going with no.
by R. Proffitt Forum moderator / October 14, 2009 10:25 AM PDT

Try and the takeaway lesson has to be to never encrypt, store things where there is any impediment to later retrieval. Flash Drives = 9, U3 Drives = 0.

Collapse -
I will try it and see
by Asuaboah3006 / October 21, 2009 1:02 PM PDT
In reply to: I'm going with no.

thanks bob for the suggestion. i will check the site out and see if they have advice on how to save my usb drive.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?