General discussion

TV can't see new firmware update on USB stick (LA32C650)

Nov 2, 2010 6:57PM PDT

Hi, Samsung just released a new firmware update (3001.1) - never done a firmware update for my new TV (which I heart bigtime) - and I wanted to update it, and I followed the upgrade steps on the PDF on the support page where I downloaded the firmware...

...but when the TV searches the USB stick for the firmware update it says nothing is on there. Anybody have any ideas how to make it work/been successful?

A samsung support rep emailed me earlier in the week because I asked about the previous update (2002.0 - which was the latest until today) to find out what firmware update does and he said "This firmware update will add codecs and also ensure the best reception." - so assuming 3001.1 does that and more I really want to get it updated. Have been having issues with certain types of MKV videos (not playing/not even seeing them on external drive for example), so I want to get the most functionality out of the TV.

Discussion is locked

Reply to: TV can't see new firmware update on USB stick (LA32C650)
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: TV can't see new firmware update on USB stick (LA32C650)
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
Nov 2, 2010 7:40PM PDT

Make sure the key is formatted in fat32 and NOT ntsf (or whatever it is for vista,xp,7)..

- Collapse -
USB drive is formatted FAT32 - doesn't make a difference
Nov 3, 2010 6:28AM PDT

I also tried two seperate usb sticks. Yes, they are freshly formatted and have no other data on them apart from the firmware folder.

- Collapse -
USB drive is formatted FAT32 - doesn't make a difference -
Nov 3, 2010 2:36PM PDT


Did you unzip the file and extract it directly to the USB drive?


- Collapse -
Anyone had any success updating to 3001.1?
Nov 4, 2010 7:25AM PDT

Hi HDTech,

Thanks for looking into this thread.

Yes I did that - I read the firmware update instructions on the Samsung New Zealand Support page for my TV thoroughly. I rung Samsung New Zealand (where I am) and they are stumped too, but looking into it. Is it possible the firmware update is broken/doesn't work on all? I haven't yet heard anyone say 'I updated to 3001.1 and it worked fine'.

Just to get this out of the way:

1. I went to the correct region and correct page for the support for my TV.
2. The firmware update directs to a global link for Samsung, so it's not something wrong with a local version of the Firmware EXE.
3. I am very technically competent. It's not a question of 'has he done it wrong' - it just isn't. I have followed the instructions to the letter and walked through the steps on the phone with Samsung Support - I know I am doing it right.
4. I am not angry at all, I love my TV, it would just be great to get the full functionality out of it, that's all.

Like I said, anyone had any success with the 3001.1 firmware update?



p.s. Why does it only have to be an executable install? I have a Mac and a Windows 7 laptop, so I did it on the Win7 laptop, but I am smart enough to extract a ZIP file correctly as are most power video users like me. I have been a video professional for over 10 years, most people who would be utilising the Media 2.0 functionality of your great Series-C sets are pretty savvy as I can tell by reading some of the archives of this forum.

p.p.s. _Please_ don't think I am angry. I am just an direct kinda guy (read: abrupt S.O.B.), that's all Happy

- Collapse -
Anyone had any success updating to 3001.1?
Nov 4, 2010 10:14AM PDT


I didn't perceive this as angry at all. Well thought out and explained, I thought.

I'll be happy to bump this back up, but here's what I do know.

1. The service center in your region will be able to address this more directly than I will be able to. (U.S. region only here, so I'm somewhat limited).
2. If the set is under warranty, it's likely that it can be serviced if it's not working properly. If you have a new firmware update (newer than the current version), then it should install.

You noted that you haven't seen anyone from NZ who has loaded it. Have you seen any posts that said that people tried to update it in your region and it didn't work? If you have links from NZ boards that indicate this, I'd be curious to see.

My recommendation would be to opt for a service on the set to see if they can send someone out to either figure out why it's not installing, or repair the unit so that it can install.

I don't want to be viewed as "passing you off" either, but they can help more than I can. I feel like the host at the restaurant, when what I really want to be is the waiter on these issues. Happy


- Collapse -
Samsung NZ can't install Firmware update either.
Nov 5, 2010 10:45AM PDT


Samsung NZ cannot install the firmware update either. They have sent the issue up, like me they think the firmware update may be broken, or need updating.

I was asking if ANYBODY has successfully installed 3001.1 - not if anyone in NZ has. Why do Americans always think the rest of the world is some foreign wild jungle that has no similarity to their own country?


I can't believe the Media 2.0 functionality will have any difference between any territory.

- Collapse -
Samsung NZ can't install Firmware update either.
Nov 5, 2010 11:50AM PDT


Different firmwares are available for different regions - because different regions do operate differently than the U.S. PAL, SECAM, NTSC, 50Hz, 60hz... so the firmwares do differ specifically by region.

3001.1 may not exist in other regions, or may address something completely different even if the numbers line up. That's all I was saying. Happy

If you want to get a global response, I won't argue. But it may not indicate anything related to your situation.


- Collapse -
Nov 5, 2010 7:07PM PDT

My set does all the Hertz ranges. It does all the pixel sizes up to Full HD 1080p. It does both the PAL's, SECAM, and both the NTSC versions of colour range and frame rates. These issues are redundant in this age of HDTVs which are designed to play any of the broadcast standards and inconsequential for this TV and especially for the Media 2.0 function. I am a video professional, for ten years now. Very technical person.

The 3001.1 update is global. Period. I first saw it on the US site and then went to my local region. Can you even see if you can download it yourself and see if you can update it successfully or get someone else at your Samsung base to do so? No offense but I have a problem, and it's not a very good representative of Samsung when you aren't even trying to solve it, test anything yourself, you are just saying: 'Who knows? You may have done it wrong.' And then stating some nonsense which is not even pertinent to the problem at hand or wholly accurate.

Not very helpful is it? Please HDTech, get your hands dirty and help me solve the problem.

Thank You.

- Collapse -
re: Groan
Nov 5, 2010 7:10PM PDT

actually it may not do SECAM, I shouldn't make that claim, but I know for sure about the PAL & NTSC issues.

- Collapse -
sorry HDTech, my bad.
Nov 5, 2010 7:29PM PDT

I just wanted to double-check: you are right my model isn't even sold in the US. I must have thought I was looking at the .com/US site. You can't check it because you won't have the LE32C650 model.

Sorry, I am right about the technicals but I understand now because you won't have the model to test.

Sorry just getting frustrated.

- Collapse -
Anyone had any success updating to 3001.1?
Nov 7, 2010 9:26PM PST

I'm in the UK with a UE55B7020 and I am experiencing the exact same issue - I have patched the TV 2 or 3 times before, so I know that I am following the correct process. I am IT literate (Been in IT for 25 years), so I know that I am downloading / zipping / formatting correctly etc.

It would be nice for Samsung to provide details on what each firmware addresses, so that we would know if the firmware is appropriate, but hey, we can't have everything Wink

Love the TV though, just want to keep up-2-date with all patches.

- Collapse -
LCD TV wont detect new firmware 3000.1 from samsung
Nov 8, 2010 8:49AM PST

I cannot upgrade my LE46B650T as well as it cannot detect the software on the usb stick.was hoping it would solve some picture problems that Im having but have had no luck at all. After reading someone saying Samsung have no clue why i just cant be bothered wasting my time calling them only to be told the same thing.

If someone could shed some light on this please it would be much appreciated. I really doubt the update will solve my picture issue but it would be worth a try at least before calling a tech. Just in case someone might want to help, i have vertical coloured lines all over the screen. I suspect its a hardware issue but still need to upgrade as i have done so in the past without any problems.

- Collapse -
LCD TV wont detect new firmware 3000.1 from samsung
Aug 28, 2013 9:42PM PDT

All extracted files must be in a folder named 'image' and anyone other files have to be outside the root folder of your USB.
So, format your USB and then, copy the extracted folder called images to the root of your USB.

- Collapse -
Years later.
Aug 29, 2013 12:17AM PDT

This thread is more than 1030 days old. It is very likely that it does not need any further discussion and replying to it will serve no purpose. However, if you feel it is necessary to make a new reply, you can still create a new post.

It's quite old and is now closed.

CNET Forums

Forum Info