General discussion

TROUBLE GETTING EPSON PRINTER TO WORK FOR ME. I NEED HELP!!

I am using a Powermac G4 350mhz. desktop computer. I am using Tiger OS 10.4.5.

I have a brand new Epson Stylus CX4800 printer. I have tried to get it to work but it won't. I follow the instructions and load the software but my printer drivers will not appear on the printers list. Has anyone else had this problem or heard of this problem. Please help me. Thank you for taking the time to read this.

Discussion is locked
Follow
Reply to: TROUBLE GETTING EPSON PRINTER TO WORK FOR ME. I NEED HELP!!
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: TROUBLE GETTING EPSON PRINTER TO WORK FOR ME. I NEED HELP!!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Try this

Try this

Unplug the printer from the USB cable.

Go to the control panel and remove your printer.

Restart your computer.

Put in the installation disk for the printer and follow the instructions. It may ask you to check to see if the cables are connected properly. At that time plug in the USB cable to the printer.

After installation is complete and you printed the test page and corrected the settings, restart your computer.

The problem should be gone.


Hope this helps.


Rick

- Collapse -
Epson Printers

Unfortunately the method just described is indicative of the method that Epson and HP use for loading their drivers on Windows machines.
Try this:
Disconnect the printer USB cable from the Mac. Hopefully the USB cable is plugged into the rear of the G4 and not into the keyboard USB ports. Avoid using a USB hub, especially a non-powered one, until this is sorted out. Restart the machine.
Go to the Printer Setup Utility. If there is any mention of your printer in the window, click on it and then, using the Delete icon, delete the printer.
It does not appear that OS X has support for the CX4800, it has support of a huge number of Epson printers, so you have to make sure that the drivers were loaded correctly. Also, that the correct drivers for OS 10.4.5 were loaded. The drivers on the CD may not be suitable for 10.4.5
Hop on over to the Epson web site and download the Printer drivers and the Twain and Scanner drivers for OS 10.4.4 and install them. (They are there, I just checked)
Install them and restart the machine.
Turn on the printer, connect it to the USB port and go to Printer setup utility. If the printer is not visible, click the Add button and follow the instructions.

If all this fails, try a different USB port, unplugging devices if necessary.

Let us know what happened

P

CNET Forums