you are trying to reinvent the wheel, you have an association set incorrectly or your Mac is not configured quite right.

When everything is set up correctly, attaching your Samsung S860 camera to your Mac should do the following:
1. Automatically launch iPhoto
2. iPhoto reads the contents of the camera memory
3. You are presented with the import page of iPhoto, along with a set of thumbnails of the pictures in your camera.
Clicking on the import all button does just that.

Try this: Open iPhoto. Go to iPhoto/Preferences in the Menu bar. In the General Tab, make sure that iPhoto is selected in the dropdown menu next to "Connecting camera opens". Close preferences.
Close iPhoto and connect your camera and see what happens.

Now this:
If you have a couple of those jpeg files still on your desktop, the ones that changed to rtf, select one of the by single clicking on them. Control + Click, or Right click, the file and choose Open with. Choose Preview. If the file is a valid jpeg file, it will open in all its glory.
One other point on this subject, it is possible that you are not actually dragging the correct file onto the desktop.
Check with the manual or dig around inside that mounted camera's folders, you may find that the real files are stored in a different place from your other camera.

Let us know how you get on

P