Alert

Tplink-MR3020: 4G Huawei E3276 Problem Resloved.

Finally got Huawei E3276 4G LTE(indian airtel) to work on mr3020 .

its been more than 40 mins works perfect:

Please try these steps:

>Visit http://ofmodemsandmen.com/downloads.html

--scroll down to the first table , under yellow box OpenWRT R36486 click download
--file name openwrt-mr3020-v1-HM2013-11-23.bin
--Now update the tplink 3020 firmware using this file(openwrt-mr3020-v1-HM2013- 11-23.bin)
It will take few mins to update and restart.
.

--Now the config steps:

i'm using wirless connection(no rj45) with Huawei E3276 4G LTE connected
--Now the default Router page ip (gateway) should be 192.168.1.1(use ipconfig to the address)
--shows the logon page, create new password
--Config steps for Huawei E3276 4G LTE
From the router home screen
go to Modem>Connection>Change APN to service provider one(airtelgprs.com for Airtel india)
Leave blank username and password
Change Pin or dial # according to service provider (*99#)
Authentication Protocol to CHAP again provider dependent check the E3276 config settings on the modem itself and leave the default settings for the rest.

Now the critical step that worked for me:

Go to Modem>Network status
Should indicate no data connection
Beside communication port u will see decrease and increase button.
click increase first 1 or twice until u see /dev/ttyUSB1 for communication port
it should connect immediately
showing the modem name provide name,signal strength and rest of the info like TPlink screen

Check if ur able to browse,if yes back up the config:
System>backup/flash firmware>Generate archive

u can use to restore the config

I have connected my laptop, mobile even downloaded 1gb game on my Lumia 920
it works prefect no disconnection.

I believe the key step is to toggle the communication port decrease and increase option
until u get the port number.

These steps worked for me,hope it works for others to with MR3020 may be even other models.

I have saved the config file and screen cap of the working screen.

I have tested this many times:
unplug the modem,restart the router.
Config still remains.

No issues works neat.

Also remember to secure the Wi-Fi.

Will keep u posted if any changes

Just want to thank the openWRT developer/programmers and all the contributor of whirlpool.net.au.


Excuse the grammar was so excited to post results Happy

Cheers,
Gowda

Discussion is locked

Follow
Reply to: Tplink-MR3020: 4G Huawei E3276 Problem Resloved.
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Tplink-MR3020: 4G Huawei E3276 Problem Resloved.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Need Help

Hi Mr.Gowda,

I have Huawei E3276 dongle with Airtel's 4h connection.

I want a adapter or WIFI router pocket size so that i use it while i travel.

Could you please give me a suggestions on this?

- Collapse -
Suggested 4G supported routers

Hi Rakesh,


I believe we don't have Router that officially supported Airtel 4G E3276.

You have 3 options here.

>Buy Airtel 4G wifi router which around 5k, works well.

> Cheaper solution is TPlink routers,I'm using Tplink MR3020 4G router which around 1.5k Rupees.
But it needs a bit of tweaking to work,i can assure you it works and I have been using it over 3 months now.

In the above article, I have detailed the tweak you have to follow for it to work.
Tplink released a latest firmware,i wont install it since im not sure it would support airtel dongle.
so far i'm the only one get this mR3040 to work.

>Or you can wait few more months for some vendor to provide a airtel 4g supported router.


Let me know if this helps.

Cheers

- Collapse -
Planning to buy

Hi Mr.Gowda,

Thanks for your reply.

I see there are some wifi routers from Dovado but they are very costly to afford.

I even see Tp-Link as alternative, i sent emails to support team of Tp-Link they said they need some time to make compatibility for all 4G devices. I received the latest by yesterday itself.

So planning to budy Tp-Link TL-MR3040 link as below:

http://www.snapdeal.com/product/tplink-portable-battery-powered-3g4g/640545?vendorCode=f57a47&

Please let me know does your tweak work for this?

Regards
Rakesh

- Collapse -
Suggested Soution

So ur using the different router with battery backup TL-MR3040.
My solution works for MR3020,i believe it should work with MR3040 ,something u must decide if you want to try or not and their is no optional aswell until tpilink fixes the 4g issue.

Now the steps u might want to try:
Please try these steps:

>Visit http://ofmodemsandmen.com/downloads.html


--scroll down to the first table , look for MR3040 ,under yellow box OpenWRT R36486 click download
--file name openwrt-mr3040-v1-HM2014-01-25.bin
--Now update the tplink 3040 firmware using this file(openwrt-mr3040-v1-HM2014-01-25.bin)

For this logon to ur tplink router page I guess IP should be 192.168.0.254(check the router in the front)
look for the option to update
t will take few mins to update and restart.
.

--Now the config steps:

i'm using wirless connection(no rj45) with Huawei E3276 4G LTE connected
--Now the default Router page ip (gateway) should be 192.168.1.1(use ipconfig to the address)
--shows the logon page, create new password
--Config steps for Huawei E3276 4G LTE
From the router home screen
go to Modem>Connection>Change APN to service provider one(airtelgprs.com for Airtel india)
Leave blank username and password
Change Pin or dial # according to service provider (*99#)
Authentication Protocol to CHAP again provider dependent check the E3276 config settings on the modem itself and leave the default settings for the rest.

Now the critical step that worked for me:

Go to Modem>Network status
Should indicate no data connection
Beside communication port u will see decrease and increase button.
click increase first 1 or twice until u see /dev/ttyUSB1 for communication port
it should connect immediately
showing the modem name provide name,signal strength and rest of the info like TPlink screen

Check if ur able to browse,if yes back up the config:
System>backup/flash firmware>Generate archive

u can use to restore the config

I believe the key step is to toggle the communication port decrease and increase option
until u get the port number.

Also remember to secure the Wi-Fi.

CNET Forums

Forum Info