Question

Toshiba Satellite BIOS issues

I have a Toshiba Satellite C-50b-14d and this morning i updated the BIOS via Toshiba through their updater program.

I now can not boot into windows at all.

How can i flash the BIOS to its original version and hopefully resolve this problem. The only files i can see on the support section on the website are .exe which cant run without being in Windows.

System is currently running (or was) windows 8.1

Please can anyone help?

Many thanks,
Adam

Discussion is locked

Follow
Reply to: Toshiba Satellite BIOS issues
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Toshiba Satellite BIOS issues
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
You should contact Toshiba about this.

In the future remember if it ain't broke, don't fix it!

- Collapse -
Answer
Here's a thing.

It's going to be technical so that out of the way...

If the OS was installed with say the BIOS in AHCI mode and the BIOS update changes that, well you must set the BIOS to the same settings the OS was installed as. Or it may not boot. Other names are CSM, Legacy and others.

- Collapse -
No luck

I have tried switching from UEFI to CSM and it brings up a message asking to select proper boot device or insert boot media.

- Collapse -
Try BIOS defaults.

And if the EFI records were lost well, that's a mess. Sorry but it's way complicated and something I can only deal with when the machine is in front of me. You may read I'm not a fan of this new BIOS as weird things like that happen and the HDD is actually ready to boot but the UEFI boot entry was lost. Nod to BIOS/UEFI defaults.

- Collapse -
totally confused now!

So i just went through all the troubleshooting options. One of them was to boot into another version in Windows. Oddly there were 2 versions of Windows 8 to boot into. Tried one same problem, tried another one. It booted in fine but it was like having the pc for the 1st time, setting up all apps etc. Actualy got to the desktop and some files seemed to be in place but some programs had gone. Rebooted again to see if it would boot into this again but we are back to square one again??!!

- Collapse -
Remember

I know that we can't trust a PC with our last copy of our files, emails and such.

Since it is booting something maybe the cheap exit is the factory recovery then putting your stuff back on it?

- Collapse -
Answer
I think this can be done in desktop pcs...

CNET Forums

Forum Info