Question

Toshiba laptop, speakers not working help!

Hi,
I recently did a clean Windows 8.1 Pro (x64) install on my Toshiba Satellite P850 which used to have Windows 7. Even since, the speakers havent been working. The audio jack on the other hand works just fine with my headphones.
Im pretty sure I installed all the toshiba drivers I needed for my fresh win 8.1 install from the toshiba website.
I checked the sound settings for both windows and the toshiba functions. I checked, uninstalled and reinstalled the sound devices in the device manager. The speakers appear to be working normally on the software's end. Windows displays that headphones are not plugged which mean its not just stuck on that. Ive even ran the win 8 sound troubleshooting without successfully finding the problem.
I dont believe its a hardware problem as they were working perfectly fine right before my win 8 install neither do I believe its linked to my sound drivers at this point since the headphones socket works just fine.
Did anyone else experience that kind of problem? Im really all out of ideas so any suggestions as to what my next move should be would be welcomed.
Thx Happy

Discussion is locked

Follow
Reply to: Toshiba laptop, speakers not working help!
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Toshiba laptop, speakers not working help!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
And that would be expected behavior for clean install.

You have the OS but I don't read where you went to Toshiba for drivers and APPS!!!!

Many get the drivers but forget that today's PCs require apps to turn on/off laptop features. Every model differs so I will not have your machine specific list handy. But I do know to look for Apps and Drivers for the laptop.

This is why most of us use the factory recovery media.

- Collapse -
about drivers and apps...

As I said : '' Im pretty sure I installed all the toshiba drivers I needed for my fresh win 8.1 install from the toshiba website.''
I went here more specifically : https://support.toshiba.ca/support/isg/center/en/index.asp?p=PSPKBC-057010.
(PSPKBC-057010 being my model according to a certified toshiba product information tool)
In the drivers section, in the windows 8 clean installation.
I got them all and installed them all.
So if this page is missing somthing I wouldnt really know where to look then... :/

- Collapse -
link

CNET Forums

Forum Info