Question

Time for a Clean Install?

I've moved recently and, prior to moving, everything on my iMac (mid-2010) and hardwired HP 1300n printer were working relatively well. I was experiencing issues with the App store where it would say there were updates, tried to install them and, even though the App store said they were installed, they really weren't. They would always reappear as an update that hasn't been installed yet. I know this because I would check the version numbers. I solved that issue for the most part by manually downloading the updates from the Apple Support site and that worked - up till now.

Not only is that not working, but I now have a number of other issues since setting up my system in our new home.

1. I can no longer print anything to my printer. It's hard wired to the iMac so there are no wi-fi issues. When I try to print, I get a message in the print que window that "The printer is not responding" or "The printer may not exist or is unavailable at this time". I tried other cables and get the same results. In the Printers & Scanners preference, it says "In use" for my printer. I have only the one printer.

2. Up in the upper right on the Menu bar I use to have my name as the logged in user and was able to switch users there between my wife and I. That no longer exists.

3. The Date and Time indicator that usually appears in the Menu bar is gone. When I go to the Date and Time preferences. The Show Date & Time in the menu bar is unchecked, but when I check it, it disappears within a second continually.

4. I have the same issue as in #3 with the Time Machine icon in the Menu bar as well.

5. When I open Calendar, there is no scroll bar to move between the months when in month mode. It does appear when in Day and Week mode.

6. I'm on Yosemite v10.10.4. Trying to install Yosemite v10.10.5 over it no longer is possible either through the App store or manually.

I'm sure there are more issues I'm forgetting or have yet to discover, but I want to do something about this as something definitely seems corrupted. Here is what I have tried so far:

1. Ran Repair Disk Permissions through in Disk Utility.

2. Ran YASU, CC Cleaner, Mac Scan, and Onyx to no avail.

3. Tried re-installing the OS updates.

4. Out of the terabyte HD, I have 860 GB available, so lack of space is not an issue.

What I would like to try is a Clean Install but I have some questions.

1. The computer came with Snow Leopard. If I re-install that, will I be able to go straight to El Capitan with the free update when it is available or do I need to reinstall each update which followed Snow Leopard?

2. Should I stop updating the OS somewhere prior to El Capitan or even Yosemite because of my iMac's age (mid 2010)?

3. Besides my personal files/folders, is there anything else that you recommend be saved manually?

4. Is there any value in doing a Time Machine save knowing that I am having issues with what I have?

Although the computer is usable for the most part, I need to be able to print. I'm frustrated and need to do something about all these issues.

Your help is most appreciated!

Discussion is locked
Follow
Reply to: Time for a Clean Install?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Time for a Clean Install?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Please try one thing.

Create a new user account and see if the troubles follow that new account.

- Collapse -
New User Test

Before setting up a new user account, I switched to my wife's account and she has the same issues. I set up a new account and some of the issues went away, such as the date/time now appeared, as did the quick switch of user names in the upper right of the menu bar. The unable to print issue remains the same.

- Collapse -
Another attempt!

I tried reseting the printing system. What happened was that the printer disappeared from the Printer & Scanner preferences and, when I went to re-install it, it never showed up again. It's simply not available or listed.

I tried booting into safe mode and the printer wasn't available their either. Totally gone.

While in Safe Mode, I wanted to see if I could install the 10.10.5 update and that didn't work either. It appears as though my only option is to do a clean install unless someone has any other options for me to try.

- Collapse -
Answer
i always recommmend a clean install

i don't recommend a clean install all the time or even with every software iteration.... however in my opinion when it's a bit more fun to start out fresh with the new software when it's time to update and you're already having debilitating problems ANYWAY... that being said i'm looking at options right now to install el capitan from a usb... otherwise reverting to a disk version of snow leopard works and after a few updates to it that it will offer to download and install el capitan automatically maybe even less effort that that... but it was very easy i remember. i personally recommend NOT personalizing it until it's to the new software... all the correctly working bells and whistles will be available. i accidentally had problems with the "me" software once after they abandoned that and went with icloud.... kept popping up from time to time even after updating to mavericks...

CNET Forums