PC Applications forum

General discussion

tighVNC

by paulchwd / July 8, 2007 1:47 AM PDT

I have a laptop and a desktop on the same network, i wanted to connect to the laptop from the desktop via tightVNC and tunnel the connection through openSSH, but i think i am missing something:

Laptop has static private IP of 192.168.1.103 (the vnc port 5900 and the ssh port 22 are forwarded to this ip on the router)

In putty i set the Host name to: 192.168.1.103 (laptop i want to connect to)

In the tunnel section i set:

source port 5900
destination 192.168.1.103:5900

(I did not change the ports when I installed tightvnc, so it has defaults)

i press open (still in puty) and log into ssh server ok

when i open tightVNC and try to connect to: 127.1.1 it cannot connect to the host....

and in VNC allow loopback connections is enabled

Any help is much appreciated.. thnx x10

Discussion is locked
You are posting a reply to: tighVNC
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: tighVNC
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Typo
by paulchwd / July 8, 2007 1:50 AM PDT
In reply to: tighVNC

I meant 127.0.0.1 not 12.1.1


thnx

Collapse -
and if you try to connect to
by jonah jones / July 8, 2007 2:23 AM PDT
In reply to: tighVNC

your static IP 192.168.1.103?

jonah "hoping i read your post correctly" jones

.,

Collapse -
yes
by paulchwd / July 8, 2007 2:29 AM PDT

yes, for port forwarding reasons, i made the IP of the laptop static which is 192.168.1.103

Collapse -
then i would suggest you try
by jonah jones / July 8, 2007 2:41 AM PDT
In reply to: yes
start
run
cmd


ipconfig /all and see if the IP matches your setting

jonah

.,
Collapse -
ipconfig
by paulchwd / July 8, 2007 2:52 AM PDT

all settings in ipconfig match the static settings i put in

Collapse -
thanks x 10
by paulchwd / July 8, 2007 3:30 AM PDT

Thanks i am aware of connecting to the loopback from vnc, but is port 5964 the port you set up for VNC server when you installed it?

I has this configuration:

in putty client: host ip: 192.168.1.103(laptop i am connecting to)

tunnel info: source port: 5900 (i am assuming that source port is the port you set up for VNC server on the host machine (my laptop) )

destination: 192.168.1.103:5900

then i press open, log on to ssh ok and keep it open

i go to the vnc client and input: 127.0.0.1:5900

at this point it says failed to connect

Collapse -
according to the tutorial
by jonah jones / July 8, 2007 3:53 AM PDT
In reply to: thanks x 10

When you run the TightVNC viewer (client), you will actually put in the following addresses: 127.0.0.1:64 - or - 127.0.0.1::5964

my config is:
host: (laptop) IP#-port 5900 (PC connected to a LAN with the laptop connected to the PC via a hub)

no SSH


jonah

.,

Collapse -
thnx but no work
by paulchwd / July 8, 2007 4:07 AM PDT

still no work, i never set anything to do with port 5964 is that the default port for vnc viewer ? and i also never forwarded it on my router?

if you go to www.PCwebs.ca/vnc.doc you can see my settings for the client...thnx x 10

Collapse -
port 22?
by jonah jones / July 8, 2007 9:14 PM PDT
In reply to: thnx but no work

why not try 59**?

i have to say that i'm no VNC expert!, and so far "touch wood" defaults have worked well.....


/.

Collapse -
22 ?
by paulchwd / July 9, 2007 7:51 AM PDT
In reply to: port 22?

thanx for the reply, are you referring to the port 22 in next to the HOST ip in Putty? as i think that is the default ssh port

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?