Windows Legacy OS forum

General discussion

This is a good one, expert help only please!

by dlars121 / November 23, 2005 9:10 AM PST

My standalone XP system has been hacked. The configuration has affected the entire system and the malicious files affect the BIOS and Boot process as well as the Windows XP Professional OS. Here is what I know:

1. All system resources are being redirected, some utilizing network paths.

2. False or non-physical drive letters exist. Even if I remove floppy drive, and disable onboard controller and floppy in BIOS, if I boot to prompt, there is still both an "A" and "B" drive reference as well as others such as "X" and "Z".

3. Although it is standalone machine, another machine or device is connecting, and has Administrator, privledged access.

4. It seems USMT or system migration tool was used to transfer or dulicate my settings. There is a CMD.exe command of "pushd" and "popd" which is present that copies entire directory tree and creates a new drive letter for it at the END of the stack.

5. Settings that I change either through user interface or even in registry are being over-ridden by someone with command line execution using switches and modified commands that appear proprietary or at least non-stock.

5. Even if I re-format and try complete fresh install, after only a minute or two, the offending party or device sets up it's own partition in free space at the END of the drive and it is booting from there apparently.

6. There are file references to Novel Netware, NTLanman, NTworkstation and a reference to an 8 digit "internal network number" which is hexadecimal.

7. User interface for "services" does not show all services. From CMD i can execute "ListServc" command and additional services are enabled as "Boot" or "Automatic":
LanManServer
LanManWorkstation
DMBoot
DMConig
NETBIOS Helper
NETBoot
Some of the services cannot be disabled through user interface including "Windows Audio" and "Windows Time".

There is a file called "redbook" that seems to be filled with re-direct routing info.

I have loads of files and logs that show what is happening, but I cannot wrestle control of the system back. A new hard drive instantly gets re-affected as does new mother boards. When I try to reinstall from CD, the system actually boots from a psuedo/virtual "A" drive and does a network install.

The MSIEXEC Windows Installer appears to be modified and when I try to install software suh as firewall or Antivirus, it gives me false or inaccurate error messages as to why it can't be installed.

A lot of the corrupt files appear in all caps type style.

One file references a "Hydra-OCC" TSOC terminal services install and some remote stuff as well as permissions and file access list config changes.

My residence was actually broken into and that day my computer booted funny and used a different display driver and gave "Updating system configuration" message, so I am pretty certain what happened was not limited to remote access and does indeed involve a hardware addition or change although nothing seems visually modified or added.

System now finds and configures "USB Mass storage devices" on boot or OS install.

Have to go but much more detail or files available if needed. Please help.

Lars121

Discussion is locked
You are posting a reply to: This is a good one, expert help only please!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: This is a good one, expert help only please!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Since changing the....
by Michael Geist / November 23, 2005 9:28 AM PST

hard drive as well as the mainboard effects the same result, I would look for a network source for the intruder. Try your install with the new components off network , adding AV/antispyware software before attempting Internet travel.

Collapse -
Strange to say the least,
by phattdaddy / November 23, 2005 9:40 AM PST

If you have as you say installed a brand new hard drive and the new drive immediately becomes infected that is weird. You have started off with an absolutely clean PC it is impossible from this state that any corruption from your original setup can cross pollinate the new drive even from the Bios. I would respectfully suggest that you check all USB ports on your machine for a foreign plugin drive. Failing that someone has swapped your boot disc for something that has been doctored.
Have you tried to reinstal XP from the MS instal discs
with a brand new drive in place?

Collapse -
Simple
by thought_stazi / November 23, 2005 10:36 AM PST

Pop in your Windows CD, and format the drive as you reinstall Windows.

Then be absolutely sure that you install ALL of the latest security patches, including SP2... Make sure you have a virus scanner installed and that it's kept up to date... And make sure you avoid using Internet Explorer and Outlook/Outlook Express as much as humanly possible.

Do that, and the odds of this ever happening again are very significantly less.

Collapse -
Still not fixed....
by dlars121 / November 25, 2005 2:29 AM PST
In reply to: Simple

I have tried all of these things, as I am pretty capable as a PC Tech & Systems Administrator. I installed a new motherboard, harddrive, and system RAM, and the system was again affected. I am certain there malicious data is being hidden in unsuspecting places such as CD/DVD cache or even on-chip L1/L2 cache. In one instance, an "XBIOS" or software bios was being used and Partition Commander indicated that it was being stored in RAM.

When I have installed, I am installing with only 4 connections (physical/hardwire connections)to PC (AC power, mouse, keyboard, and VGA display), so no network, CAT5, USB, POTS or anything. MY XP Pro install wont prompt me for file system choice, (NTFS or FAT32), the entire process is done in 1280x1024 resolution where as it would usually ask if I want to change resolution from default, and then test adapter to see what it could handle, and it installs PLUS!, IE, and Netscape Navigator, as well as a non standard HAL.DLL (Hardware Abstraction Layer). It's doing a network install, or at least redirecting the install resources to use a different location. I have heard you can create a folder anywhere and make it a "drive letter". Makes me wonder.

Partition Commander keeps showing changed partition and file formats (FAT32e, and OS/2 Boot Manager). There seems to be some dynamic partitioning going on in freespace on drive.

Here is what seems to be main obstacles:

1. Malicious data seems to be being stored in RAM or Cache and affects system boot even before Windows. Does anyone know of any good utility or application to read and/or clear non volatile RAM such as CD/DVD cache, BIOS, Display Adapter BIOS, IDE hard drive cache etc ?

2. I can't install anything from DOS, as I get "program cannot be run in DOS mode", even if it is a DOS application. I know that usually a .PIF or dos.sys file is responsible for this, but I haven't found any reference to it.

3. If I am successful in getting a Windows desktop, the windows installer is corrupt, so I can't install anything, and if I can, the utility such as firewall or antivirus gets modified or gets a "helper" file added on boot to disable it's effectiveness.

4. The CDROM is affected in BIOS and seems to be root of problem as the only way I can reliably transfer a file to system is via floppy, which is referred to as "B" drive since there is a phantom A drive.

Perhaps I should post some log files, MEM debug data, step by step process sequence or ?? Many thanks for the valid advice and to the guy who suggested someone has an overactive imagination, all I can say is if it was just my imagination, I would simply imagine that it was fixed and then we wouldn't be having this problem. The computer in question housed data and attorney/client info regarding litigation between private party, National Institutes of Health and DARPA, so it is reasonable to suspect some substantial tampering has occurred. As I mentioned, the location that houses the machine was broken into, but not burglarized, immediately before PC problem so it is likely machine and/or location was modified from a hardware perspective and this might not be relegated solely to software and or virus activity. Prior to the break-in, for 2 dyas straight, there were attempts to gain remote access and the amount of ICMP and UDP activity tripled during these two days. After the break in, the microwave oven would no longer function in the AC outlet where it was located, so someone moved it to a different part of the room where it worked fine. Other appliances work fine in faulty outlet. I did some inspection and found a modified AC transformer and relay were to blame. Someone didn't like our microwave. Any thoughts on a solution to this whole mess would be appreciated, because I'm going on 4 weeks without Online access or a PC that will house data or permit e-communications.

- Lars

Collapse -
OK, First Off
by thought_stazi / November 25, 2005 2:52 AM PST
In reply to: Still not fixed....

The odds of something be stored in the places you think are very, VERY slim. Most of the things you list (CPU cache, HDD cache) are simply not possible. Those simply aren't accessable to anything but those hardware components. Besides that, they're flushed every time the device powers down.

There's a small chance it could get stored into Flash RAM used for the CMOS, but that would take some pretty impressive assembly skills. Way too much work when there are far easier methods of causing mass problems. There's also a small chance of an MBR virus, but those are virtually extinct because they're too much work when you can write a few dozen lines of VBScript code and bring down mail servers the world over.

The most likely scenario here, is that one or all of your backups are infected. You may be forced to abandon them, or use much older ones, before you were infected.

Also, if you're installing a pre-SP2 version of XP, you might want to make a slipstreamed install CD on some other computer. Otherwise, it's possible to get infected with a large number of worms within minutes of loading Windows without a firewall.

Collapse -
I have tried all of these things.
by Cursorcowboy / November 25, 2005 11:31 PM PST
In reply to: Still not fixed....

I'm not so sure. Anybody else?

A. I installed a new motherboard, harddrive, and system RAM, and ... When I have installed,

with only 4 connections (physical/hardwire connections) to PC (AC power, mouse, keyboard, and VGA display), so no network, CAT5, USB, POTS or anything

MY XP Pro install wont prompt me for file system choice, (NTFS or FAT32)

it installs PLUS!, IE, and Netscape Navigator, as well as a non standard HAL.DLL (Hardware Abstraction Layer)


Pleas read through paragraph #5, the forum thread, ''Some ''history'' which may help 'u understand the processes.''

it's doing a network install, or at least redirecting the install resources to use a different location

when I try to reinstall from CD, the system actually boots from a psuedo/virtual ''A'' drive and does a network install

although it is standalone machine, another machine or device is connecting, and has Administrator, privledged access.


B. To rehash, since it's already been said or asked but nowhere have I seen an answer except as excerpted above:

phattdaddy - Have you tried to reinstall XP from the MS install discs with a brand new drive in place?

I am, and possible others, are not sure if the drive you mentioned above was actually ''new'' or was a drive which had been used previously?

danthevan - Did you remove all internet connections from your pc before trying a fresh install also do you have a wireless internet connection

There are no wires going anywhere from that box to a wall outlet of any sort other than the AC PC plug?

mrkhlp - DISKPART.EXE and etc.

The Diskpart command-line utility is explained in the article [Q300415] along with the actions that are supported by the ''Disk Management (Q309000)'' snap-in tool to ''display'' (click to see a screen shot) disk configuration, such as the detail and list options among others to ascertain disk by number, the status, size, free space, and etc.

thought_stazi - Also, if you're installing a pre-SP2 version of XP, you might want to make a slipstreamed install CD on some other computer.

1. Perhaps if you'll quit describing the problem and elaborate specifically on the product(s)/item(s) used, fully described steps you perform as well as the system's response at that time, somebody or you may identify that certain point in time when something malfunctions or something is identified as the cause.

2. From my prospective:

a. The motherboard BIOS needs updating and perhaps only certain options set which only you would know.

b. The particular XP CD used needs identifying -- most members know what one is supposed to do and it does not fit your description.

c. If the hard drive was formally new, what does ''FDISK /Status'' give as its current cofiguration. How/What prepared that drive for the system?

d. The processes used and procedures mentioned in #1 above.

Collapse -
you mention an electrical outlet being modified..
by Melati Hitam / November 26, 2005 3:19 PM PST
In reply to: Still not fixed....

Check those things.... there is a network connection device using power line..

Check the whole house...

Collapse -
silly question but
by danthevan / November 23, 2005 6:00 PM PST

did you remove all internet connections from your pc before trying a fresh install also do you have a wireless internet connection thinking maybe one way they got in. this is happening a little bit in london where i live people buy expensive wireless cards which range from 50 feet to just over 1 mile or 1 kilometre
so they can use your internet connection or get into your pc


hope this helps a little dan

Collapse -
(NT) (NT) so, non-experts need not answer....;-)
by jonah jones / November 23, 2005 6:54 PM PST
Collapse -
HMMM,, It sounds like someone
by retired / November 23, 2005 7:48 PM PST

has a pretty wild imagination.

Collapse -
Some assumptions....
by Papa Echo / November 23, 2005 8:11 PM PST

You seem knowledgeable enough not to go into the net before installing that firewall. Stand alone= no net- work issues. Break-in = maybe your installation disks have been exchanged = possible but unlikely. All things considered, it is likely you have a bug in your system- memory chip resident, or DIOS resident - all unaffected by the format before reinstallation. The name of the bug ? It's called a HUMBUG ! Happy

(Sorry if I am wrong. I am no expert, but I can't resist replying.)

First time poster ? Welcome to the forums !

Collapse -
question
by mrkhlp / November 25, 2005 9:00 AM PST

I agree with your disks may have been doctored. But when you boot the infected system have you run DISKPART.EXE from the command prompt to see if there are added partitions that shouldn't be there or drives for that matter. It sounds like if your disk are doctored when you reload everything a hidden partition is getting created on the drive. Does the drive appear to have the same amount of space as it did originally or is it missing a few gig? A simple format won't get rid of a hidden partition it will just clean the one you formated.

Mark

Collapse -
Yes, you are right....
by dlars121 / November 26, 2005 4:50 AM PST
In reply to: question

Mark,

Good call, and yes there are indeed hidden partitions being created without my locally initiated input. Over the several weeks I have been affected, I have discovered a couple different conditions being reported, but I usually have to rely on Partition Commander or Maxtor's "maxblast" software to see the partitions because they seem to be hidden from Microsoft "diskpart.exe" and "fdisk.exe"...

The partitions in question are usually 1MB or 8MB and I have seen them reported by Partition Commander and Maxblast as the following formats:
1. "unknown"
2. FAT32e (yes, an "e" on the end)
3. OS/2 Boot Mgr
4. and others that escape me at the moment... maybe HPFS?... the old/first NT file system?

All of the software I have used tells me that these partitions sre "write protected" or inaccessible", "cannot be deleted" , "is needed by Windows setup" or other questionable error messages. I did find a file on the machine written in Visual Basic that used the "RND" (random) procedure to pick a random error message from an array of pre written error messages. This simply would echo a random error command to the user and halt install or other user initiated action that might wrestle admin control back from the system.

Here is where I am now at. All of the components have been replaced other than powersupply, system fans, pentium 4 processor, and CD/DVDR/RW drive. I have installed new main board, system RAM, IDE hard drive and still have no network card, modem or other connect to net that I have initiated locally. There is a built-in 10baseT/100 netcard on mobo.

I'm still questioning if a small device could be phyically present that is responsible and permitting partitioning, plug and play recognition or even remote access. As I mentioned, on boot before windows, "reading NVRAM" is displayed and there are 2 "USB Mass Storage devices" being found and configured. As far as the partitioning issue, it seems to be dynamic with indicated docking/undocking, mounts, taking place, and eventhough it is supposedly standalone desktop PC, PCMCIA is being mentioned in driver files. On XP install, support for 64-bit dual-boot is loaded, it pauses at loading "Hardware Abstract Layer" (HAL.DLL) for about 4 minutes, and "Windows Executive" takes about 2 minutes, where as always in the past with same hardware at same location, using same install CD, Windows Exec and Hardw. Abstract Layer would simply flash very briefly while being transfered from install CD. Another strange thing is that it keeps referring to hard disk as "IDE-0 on ATAPI on MBR". The core issue has something to do with DOS recognition of CD and IDE hard drive. Is it possible that someone could use the 8mb of cache from the CD/DVD drive and configure it is NVRAM (non-volatile) and mount/label it as an A drive so that it would be bootable? Regardless of what I do partition wise, it is only a matter of a few minutes before I am relegated to an extended partition and the 8mb has set itself up as primary active partition either through USMT migration tool or "PUSHD" dos command or both. As I mentioned, even if I pull the power and ribbon cable from floppy, there is still an A AND a B drive in DOS as well as others at end of stack which has been weirdly varying between X and Z and M and N, which in retrospect can be easily explained with a "lastdrive" set in config.sys. There seems to have been a modification to the malicious system in recent week with some redundancy incorporated and SCSI reference on Boot. I can delete malicious files and they return, and even if I damage a partition it gets fixed. I am going nuts trying to get to the bottom of this and I am convinced that the problem cannot be corrected via software or user interface. There has to be a hardware issue to explain why reformat or complete writing of zeros to drive does not correct problem.

I can't rely on media I place in CD/DVD tray because even if the disk is reliable, the exe that executes isn't the same as what I used to see and/or has a different interface and/or permissions/capabilites of software, and additionally, my control of the system is compromised even before DOS boots, or when a "safeboot" or boot from floppy is initiated. I have tried everything, including setting up 4 partitions using different file formats including varying active partitions either in middle or end of stack, with strategically placed LINUX partitions knowing that will corrupt the neighboring partition for swap file usage, but all to no avail. No matter what, there ends up being a 1MB-8MB partition setup at TOP of stack that is being used for boot. There has to some memory on box somewhere with perhaps embedded driver that is allowing BIOS/Boot recognition and config. I don't see any other explanation for system behavior.

- Lars

Collapse -
another question
by mrkhlp / November 26, 2005 5:05 AM PST
In reply to: Yes, you are right....

when you redo your computer is it disconnected from everything not needed ie: network, internet, external drives, flash drives and printers. So you just have a bare machine? I do know if you have printers with jetdirects they can be hacked and used to do some funky things to your system.

Mark

Collapse -
Still another question
by mrkhlp / November 26, 2005 5:18 AM PST
In reply to: another question

Have you gone into the bios and disabled USB support and well as disabling the floppies A and B then try booting to see what happens? Just leave what you need to get the system up and running enabled in the bios and see if any of the symtoms go away. If as you say that drive a is acting as a boot disk this could kill it unless it's some kind of virtual drive. Also in the boot sequence make sure that drive C: is it no cd rom no floppy. See if the system will boot.

Mark

Collapse -
Last thing
by mrkhlp / November 26, 2005 5:25 AM PST
In reply to: Still another question

As you know Microsoft says DOS is dead funny how we have to keep going there to get rid of unwanted stuff. Anyway I don't know how much you know about the different commands but if you can get to a command prompt only there are ways to delete things windows says you can't. One thing is to look at the attributes of these files if they are just read only it's no big deal to get rid of them.

Mark

Collapse -
One more thing
by mrkhlp / November 26, 2005 5:28 AM PST
In reply to: Last thing

I promiss turn off system restore because anything you fix will come back via system restore.

Mark

Collapse -
Hack Update
by dlars121 / December 17, 2005 4:28 AM PST
In reply to: One more thing

I had already tried most of the solutions offered here on the forum, but the only solution that worked was to physically remove the machine from that location, plug it in somewhere else, and run windows setup. Although I did get a desktop and I can now install application CD's etc., there is still something residual outside of windows and resident in memory, BIOS or hidden hardware device. For instance, during format and OS install, (XP Home, w/ SP2 this time), I kept receiving a message flag "You interrupted setup while copying from .CAB file..." and the interface gave me three options: "skip file" "cancel" (exits setup), or "details". The details would reveal the file that was not copied and gave option to search for them (included mouse.vxd, 1394.vxd, USBHID and others), and I also got an error message that was strange that said "cannot find device "BLUEGLYPH".

To recap, here is the situation.

Standalone XP machine w/ DSL connect had litigation and case evidence data regarding a case against National Institutes of Health and DARPA. Hack attempts started with UDP and ICMP packets coming in, but I closed up ports. Someone broke in to location and physically accessed the machine. The day the break -in was detected, the machine booted differently and gave "system configuration updated" message after loading different device drivers.

Machine was then never the same. The BIOS was modified or used a EBIOS or XBIOS to limit my control over IO. Flash of BIOS was ineffective. Problems came from ATAPI device/CDROM and FLoppy. Partition was being modified with a OS/2 Boot Manager partition being setup on the fly without my user input. Almost any and all applications were being disabled or corrupted. System was booting as client or workstation to an administrator or a domain manager like it was on a network. In command prompt only, A and B drives were present even if I disabled drive and FDC in BIOS and physically removed cable. There was a strange boot process that I could not get rid of that used a redirect where my C: prompt was actually (truename CMD) = //C::A: (not exact, but similar).

I could completely format all IDE hard drives or even ZAP or write all 0's to the drive and flash bios and clear CMOS, and during windows setup with legit XP Home w/ SP2 disk, would get a non-standard install and corruption. There were POPD and PUSHD commands in CMD that would copy entire volume and make a new drive letter. It was also finding and gonfiguring 2 USB Mass storage devices on setup and before Windows boot that I was unsure what devices those were. The boot seemed to be bad from the get go right at "Reading NVRAM".... gotta go.... thanks. Again though, most problems gone now that I relocated the machine, but seems to be some residual problem. I think there is a device or configuration that is capable of wireless data transfer hidden in the box somewhere, but in new location, it is not finding another device or access point that was previously present at the original location. I obtained a signal detection device that indicates no Wi-Fi/802.11 signal is present, but it indicates that bluetooth is present, although I am not aware of any bluetooth capable devices present at the location. Bluetooth is indicated even if machine is off, unplugged.... thanks again.

Collapse -
you seem to know your stuff so....
by peasonokay / December 17, 2005 6:29 PM PST
In reply to: Hack Update

All James Bond like but i will give you the benefit of the doubt for now.

if you have gone to all this trouble changing motherboards etc etc and suspect there may be a device in the machine then surely its worth spending $200 (

Collapse -
Reply
by dlars121 / December 20, 2005 7:22 AM PST

1. Yep, disabled flop and USB in mobo, but somehow there is A & B drives available at command prompt that contain boot files.

2. BIOS issues are two-fold: 1. Seems to be altered or modified as enable/disable parameters that I know have been present in past are now greyed out, inactive and unchangable. 2. If I flash it to known good BIOS, I either experience a auto restart and subsequent second flash, or a suspect "EBIOS" or XBIOS" type soft BIOS being enabled.

3. I've used several source disks for install, the latest being a known-good legitimate version of XP Home that has SP2 performed on install.

4. Yes, I finally just bought a new machine, but still want to get to bottom of issue with this machine.

Thanks again for the all the help.

- Lars

Collapse -
Experts only huh?
by PKsteven / November 26, 2005 3:50 PM PST
In reply to: Yes, you are right....

Well I have read all this , and first, would you be willing to define "expert"? I do have a question for you. You obviously have more knowledge than your average user, perhaps a "lot" more, yet you insist you are being hacked. If you unhooked all peripherals\cards\cables that would connect you to any outside source, put in a different hard drive, then how would you explain anyone doing this to your pc? This would have to be a divine intervention. Sure there is the new outlet network that uses the power line as a networking source, however, your pc has to be set up for this if I remember correctly. You need a special converter to do this and unless you do, then I would have to "in my non expert opinion, say you are blowing the proverbial smoke up our ....@##%%" I will personally apologize if you can answer this in a way that makes sense and is believable.


(( A new hard drive instantly gets re-affected as does new mother boards)) you stated this. And replacing motherboards.
Now I have one more question, how many of your average users, would go around changing their motherboards, drives , etc...constantly instead of simply unplugging the pc from any outside source? You are obviously very smart but if you can answer me, it would be appreciated.

Paul

Collapse -
Hi comicfan,...
by Melati Hitam / November 26, 2005 4:08 PM PST
In reply to: Experts only huh?

I also did mention about electrical power line network...

and he did also mention that their electrical outlet thing, have been modified by someone.. so it is possible although he did change anything and not connected to internet.. he still get the problem.

as to any converter needed to do that power line thing.. it could be has been install somewhere in the house...

It is also possible there are new devices that we don't know yet. especially in his business environment.

have a nice weekend..

Collapse -
Few problems with this...
by PKsteven / November 26, 2005 4:28 PM PST
In reply to: Hi comicfan,...

First off, even if broken into, who is going to go through all these modifications to a stand alone pc unless it had extremely valuable information and it was known? This is getting into james bond stuff now.
Also, I don't see where this was a work invironment.(could have missed it though.)
And, it was clearly stated this was a stand alone machine. You can't just modify the outlet and pc and have network through power, you still need the service. Go ahead and run a 110 line to your network cable and see what happens. You may even not have to go to the hospital if you are lucky. New devices we don't know about? Well, let me put on my super duper decoder ring and see what we can find by golly. And honestly, I don't mean any ill will toward you, and had I been speaking instead of writing, I would not be yelling at you, but many things don't make sense in this matter. You take care.
Paul

Collapse -
As I have mentioned....
by Papa Echo / November 26, 2005 4:39 PM PST

..near the beginning, it's a bug --a HUMBUG !

Collapse -
Yes, i do think so...
by PKsteven / November 26, 2005 4:53 PM PST

I do agree with you, this is....aaarr, these little green men keep trying to take my computer to fuel their ship! I keep telling them, it's an emachines, it will just cause the ship to break down but noooooo.

Collapse -
(NT) (NT) It sounds like a communist plot to me......
by crazeebob2000 / November 26, 2005 4:41 PM PST
Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

GIVEAWAY

Turn up the volume with our Apple Byte sweeps!

Two lucky winners will take home the coveted smart speaker that lets Siri help you around your connected house. This sweepstake ends Feb. 25, 2018.