Question

Thinkpad L540 hotkey errors

I recently got a used thinkpad L540, in which the previous owner mainly used linux ubuntu on. Apparently she accidentally deleted windows 10 once and had to redownload it.

Anyways, I didn't like how the fn and ctrl keys were positioned and that I needed to press fn key to use the regular function keys (f1, f2, etc), so I went ahead and did the fn-ctrl key swap in Bios and use with function lock (fnlk) on.

Things were working fine for a while, but then one day some of the hotkeys such as mute, lower volume, wifi/signal, and settings key stopped working only when I have fn-ctrl key swapped and have function lock on. If I turn the function lock off, things work fine (with the keys fn-ctrl keys still swapped) or just undo the fn-ctrl key swap, all the hotkeys work fine with or without function lock, but these two features are pretty important to me.

I've tried downloading the hotkey integration, and power management driver from lenovo for windows 10 for my model, but they didn't work.

Has anyone else had these problems or know any solutions to this?
I'm planning on leaving to China for work (for about a year) with this laptop and really would like to have this problem resolved.

Discussion is locked
Follow
Reply to: Thinkpad L540 hotkey errors
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Thinkpad L540 hotkey errors
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Yes.

But laptops often use a maker app to drive those functions. I see you tried this but is there more installed than those and W10? I've run into folk the blow up the OS with cleaners.

- Collapse -
Not really

I checked the programs and features and there weren't much installed before this started happening. Could it be from something installed with linux? Or is there like hot key setting that I need to work with?

- Collapse -
If you wiped the drive and just had W10

I worry it's just another driver and app issue. You didn't mention you installed anything else so maybe it's time to try the factory issued OS?

- Collapse -
Factory issued?

By factory issued OS, do you mean OS from lenovo or something? Or just doing a factory reset? The previous owner said that she got this windows 10 from lenovo after she accidentally removed it.
Also, few days ago, it suddenly started working again for some reason, but after few days of working, it stopped working again.
It used to make the beep sound for unmanageable key combination before I disabled that from BIOS, could it perhaps be the key combination?

- Collapse -
Either is what I do next.

If there is a factory reset, then I can try that if the restore media is lost.

I do not have this model to play with so it may be time to call Lenovo and have them walk you through this area.

CNET Forums