General discussion

Telnet Service MIA

I am using a 2 yr old AMD AthlonXP 1800+ powered PC running Win XP Home SP2. Also Norton Systemworks 2003 all updated.
I also have a broadband connection so everything is up to date.
2 days ago while I was browsing my net connection just stopped. Finally The ISP tech cane home and found out the the main antenna power plug had come off.
This is a cable connection which I log on tousing a login client provided by the ISP.
So anyway after the tech guy came in he checked up everything and said the network was fine but when he came to check up my machine apparently the Telnet service from the services window is missing and I cannot use the login client without that.
He suggested that I reinstall windows.
Thats the last thing I want to do.
Could somebody help me out here? Is there anyway just to import that service?
Only 2 incidents I can think of whihc may have even remotely affected my computer.
I installed a new stick of RAM last week.
Also last week during a routine AV scan Norton deleted a file called cmd.ftp (or something similar) bcos it was infected with the Sasser worm.

Help!!

Thanks
Jay

Discussion is locked

Follow
Reply to: Telnet Service MIA
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Telnet Service MIA
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Re: Telnet Service MIA

OK, I'll take it that your connectivity method requires this. Probable it's because in SP2 Telnet is disabled.

So, click Start, Run type services.msc and press Enter. Locate the Telnet item, right click, click Start.

Good Luck,

Cetin


Trying to unweave, unwind, unravel
And piece together the past and the future,


T. S. Eliot

- Collapse -
No, Sorry not possible..because

Thanks for your reply.
Your solution is not possible for the simple reason that the telnet item is not present on the services list!!
I know, its totally weird, the ISP tech was also baffled hence his solution of a Win reinstall.
I tried all sort of shenanigans with my miniscule knowledge but telnet is not being displayed in the services list in all instances.
I finally tried searching for telnet on the hard disk and i got a few results 3 telnet.exe in the system32, service pack backup and i386 folders, the telnet help files and 6 .CLASS files with Telnet in their names and also 3 telnet.exe.something.pf files in the Prefetch folder.
I dont know why the telnet service should disappear from the list. Please give me a solution to get it in that does not involve a full reinstall! To think I was in the process of downloading the Win update files to get ready a SP2 slipstream CD in case of trouble Sad

Anyway Help!

- Collapse -
Re: No, Sorry not possible..because

The name of the telnet service is tlntsvr.exe. You can try to check out it in the registry and change it from disabled to Auto.

Click Start, Run type regedit and press Enter. Expand the following path:


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TlntSvr


In the right pane, look for Start. You should change it from 4 to 2.

Note

Start value conforms to the following meanings.

00000002 - Automatic
00000003 - Manual
00000004 - Disabled


Good Luck,

Cetin

Trying to unweave, unwind, unravel
And piece together the past and the future,


T. S. Eliot

- Collapse -
XP Home and "Telnet Server"?

I may be wrong, but XP Home didn't offer the telnet server. The telnet client works fine and does not require the telnet service.

Somethings a litte confused, so think it over.

Bob

- Collapse -
Telnet

Telnet is only in WinXP professional

- Collapse -
I have 2 XP Home laptops to compare "right now".

And both can run the telnet.exe. However, neither seem to have the telnet "server".

When we write about "Telnet", we have to differentiate between the server and client.

Bob

- Collapse -
You're right Bob, so what is the solution?

You're right I did not find telnet server in the registry.
So what is solution to my problem?
What is the way to get telnet in the services list?
Thanks
Jay

- Collapse -
Did a Registry Search

ok considering the earlier advice, I did a search of the registry for 'telnet' and got the following results.

1. HKEY_USERS/S-152-a long list of numbers/Software/Microsoft/Telnet

Default Value Not Set
BSASDEL 0
CRLF 1
Debug Flags 0
DELASBS 0
Mode Console
NTLM 1
Prompt Flags 0

2. HKEY_LOCAL_MACHINE/System/Control Set 1,2, 4 and Current Control Set/Control/NIs/MUILanguage/RCV2/telnet.exe

Default Value Not Set
0 Long list of numbers
1 ditto

3. HKEY_LOCAL_MACHINE/Software/Classes/Telnet

Default URL:Telnet Protocol
Edit Flags 0x00000002 (2)
URL Protocol

4. HKEY_LOCAL_MACHINE/Software/Classes/tn3270

Same as above

Any Ideas?
Thanks

- Collapse -
Re: Did a Registry Search. Not necessary ...

OK, let?s strighten this up. Telnet Service is present only in windows XP Pro indeed. I wasn?t read your first message attentively, so I assumed that you?re using XP Pro and was mislead by the fact that you said that it worked before (thinking to XP Pro). What I provided in my previous messages it?s for windows XP Pro. You have XP Home so you obviously won?t find it under services.msc and in the provided registry path. In other words, don?t look for something that doesn?t exist.

Now, I suggest to contact your ISP provider again. Why ? Because the connection method needing such a thing it?s very unprobable. Taking into account that it worked in the past, the culprit should be elsewhere.

In parantheseis, I saw in the past some weird ISPs using login scripts but now this method vanished.


Good Luck,
Cetin


Trying to unweave, unwind, unravel
And piece together the past and the future,


T. S. Eliot

- Collapse -
Weird! Started working again!

Huh??!! It just started working again! I guess its ok now.
Thanks Cetin for all your help!
Cheers

- Collapse -
You are welcome. All's well that ends well [NT] .

.

CNET Forums

Forum Info